Visit Our UNIX and Linux User Community

mount external usb drive on Redhat 9

Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers mount external usb drive on Redhat 9
# 1  
Old 05-23-2003
Question mount external usb drive on Redhat 9

I am using Redhat 9 Linux, and am trying to get my external usb drive mounted (fat32). If I look at the KDE Control panel, it lists a usb 2.0 storage device under "USB Devices" (also in /proc/bus/usb), and under "SCSI" as scsi1. I looked at /proc/scsi/usb-storage-0, and it lists it there also. What do I enter into mtab or fstab as a mount point? Thanks, Jeremie.
# 2  
Old 05-23-2003
to be honest i am not sure about this, as i have not worked with usb storage devices.. but it should be able to be mounted easily enough with the mount command:
# mount -t vfat /dev/scsi1 /yourmountpoint/
# 3  
Old 05-23-2003
I tried that with /mnt/usb as the mount point. It told me "that mount point doesn't exist", so I created /mnt/usb as a directory. Now it says mount: special device dev/scsi1 does not exist. I have tried mounting it as dev/sda1, dev/sda2, dev/sdb, etc... and it tells me "mount: wrong fs type, bad option, bad superblock on /dev/sd*, or too many mounted file systems (aren't you trying to mount an extended partition, instead of some logical partition inside?)" or "mount: /dev/sd* is not a valid block device".Is there a way to tell what it should be mounted as?

Last edited by jeremiebarber; 05-23-2003 at 02:19 PM..
# 4  
Old 05-23-2003
See the question and answers on - the next to last post looks like it worked.
# 5  
Old 05-23-2003
Thanks, but it still gives me the same errors listed above. I am still trying.
# 6  
Old 05-23-2003
See the faq on - this one is on mounting usb drives.

You may need to read some other faq's there to insure you have the proper modules loaded.
# 7  
Old 05-24-2003
Thanks for the help. Jeremie

Previous Thread | Next Thread
Test Your Knowledge in Computers #18
Difficulty: Easy
Facebook purchased the popular video teleconferencing software 'Skype' from Microsoft.
True or False?

10 More Discussions You Might Find Interesting

1. Red Hat

Usb external drive

Hi Guys I am using RHEL5 O/S. We have mounted the usb external hard drive to the server as root. I want the user oracle to be able to write into this external hard drive. How do i do that ? Please Help!!! (1 Reply)
Discussion started by: Phuti
1 Replies

2. UNIX for Advanced & Expert Users

Waking Up USB External Hard Drive for file archiving

Hello Experts, I hope I'm writing to the correct category for my question. I have a very basic shell script for doing file archiving to the external usb hard drive (WD studio edition II 2TB formatted as FAT32 for compatibility). The shell script only needs to run once per day. It basically... (8 Replies)
Discussion started by: johankor
8 Replies

3. Hardware

Flapping (reconnecting) external USB drive

Hi gurus, during playing movie via VLC or SMPlayer I get several time the error that file cannot be read. File was stored on external USB disk. During this error I get another dialogue message that says the new removable disk was connected..., just as if power goes off and on again or if I power on... (1 Reply)
Discussion started by: wakatana
1 Replies

4. Debian

Unable to mount external drive

Trying to mount an external 160GB Toshiba drive but.... this is my dmesg tail output: usb 2-2: new high speed USB device using ehci_hcd and address 3 usb 2-2: New USB device found, idVendor=13fd, idProduct=1618 usb 2-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0 usb 2-2:... (4 Replies)
Discussion started by: Ridson
4 Replies

5. UNIX for Advanced & Expert Users

script to automatically mount external usb hard disk

hi all, I have a debian lenny 5.0 server without GNOME installed. the server is at a customer's premise. I want to backup data from the server to the external usb hard disk. the backup will start at e.g 01:00 everyday. the user will plug the drive before going home. also the user will... (1 Reply)
Discussion started by: coolatt
1 Replies

6. Ubuntu

driver for external drive case on usb port

Hi I have to buy my selfe external case for hdd but I don't know whether my ubuntu linux, needs some driver to be able to work with this device or it has inside of itselfe this driver ? rhx for help. (1 Reply)
Discussion started by: presul
1 Replies

7. Solaris

USB External Hard Drive for Solaris 10 Sparc

Hi- I would like to know if anyone has used any USB External Hard Drive, about 500/750GB or 1TB, with any of the Solaris 10 "SPARC" systems. Not on intel nor amd platform. I'm looking for the compatible drive and found a few listed on Sun solaris ready page, but I'd like to have inputs from... (3 Replies)
Discussion started by: agfa_109
3 Replies

8. Solaris

Installing Solaris x86 through an external DVD drive through the USB port...

Is there a way to install Solaris 10 x86 with an external DVD drive that connects through the USB port? I would think I would run GRUB off of a floppy disk and somehow use that to make it look to the USB port to boot from but I don't know how to do that. Can anyone help me out? (1 Reply)
Discussion started by: Bradj47
1 Replies

9. Solaris

FAT32 usb external hard drive - how to mount??

Hello ! What is the comand to mount and usb hard disk ? I have Solaris 10 installed! 10nx! (1 Reply)
Discussion started by: daniel.balasa
1 Replies

10. UNIX for Dummies Questions & Answers

Accessing files on external USB drive using UNIX?

Hi Folks, I'm a serious UNIX newbie... I'm using a bash shell on Mac OS X. Basically I took up unix in order to use a specific image processing software package... I've learned enough to write a script to batch process all of my images, but I have so many that I would like to use an... (1 Reply)
Discussion started by: Slanter
1 Replies

Featured Tech Videos