Visit Our UNIX and Linux User Community


FTP/TELNET on linux, not working


 
Thread Tools Search this Thread
Top Forums UNIX for Dummies Questions & Answers FTP/TELNET on linux, not working
# 1  
Old 05-12-2003
FTP/TELNET on linux, not working

I'm trying to ftp to my linux box from windows and from unix and its not working. I can telnet just fine, but ftp doesn't work. Where should I start looking? What config file is it that controls the ftp? Why does telnet work and ftp not? I'm using redhat 6.1, samba's working for browsing the directories, but no ftp works.
# 2  
Old 05-12-2003
check the file /etc/inetd.conf

look for the line starting with ftp, most likley it has an # infront of it, which means the service is commented out, ie not running. remove the # and issue the command ( as root):
/etc/init.d/inetd restart

if that dosnt work then you probably dont have an ftp daemon installed. check your redhat package manager and pick one to install.
# 3  
Old 05-12-2003
Try to ftp from your unix box to your unix box. does that work? if not, then it may be a problem with the ftp daemon

check to see if you dont also have the ftp port commented out in /etc/services Be sure you have the following lines in /etc/services (and they are NOT commented out). They define the service, port and protocol.

ftp-data 20/tcp
ftp 21/tcp

You can get the ftpd at ftp://ftp.wu-ftpd.org/pub/wu-ftpd I beleive that wu-ftpd-2.6.1.tar.gz is the latest version.

check to see if you have an /etc/ftpaccess file. This file is used on linux systems to provide ftp access control - Do a google search on ftpaccess to find out more. This file can be used to set up anonymous ftp, groups, non-anon and more..

Other WU-FTP files to check out are:
/etc/ftpaccess
/etc/ftpgroups
/etc/ftphosts
/etc/ftpusers


Last edited by google; 05-12-2003 at 10:24 PM..
# 4  
Old 05-13-2003
hm

hmm. none of this worked. I can ftp out, i can telnet in from unix, but cannot ftp in from windows or unix. I've checked the /etc/inetd.conf file and the ftp is not #remarked out, not sure what the problem is. I don' thave a /etc/init.d/ directory. FTP was working a couple of months ago, but isn't now for some reason, i mean working in, now can't ftp in at all from any platform.
# 5  
Old 05-13-2003
ftpaccess file

this is the ftpaccess file, but nothing is glaring out at me that might be wrong:

class all real,guest,anonymous *

email kmartin@dyess.nlxcorp.com

loginfails 5

readme README* login
readme README* cwd=*

message /welcome.msg login
message .message cwd=*

compress yes real,anonymous
tar yes real,anonymous
chmod no guest,anonymous
delete no guest,anonymous
overwrite no guest,anonymous
rename no guest,anonymous

log commands real
log transfers real,anonymous inbound,outbound

shutdown /etc/shutmsg

passwd-check rfc822 warn
tar no guest
compress no guest
chmod yes real
delete yes real
overwrite yes real
rename yes real
# 6  
Old 05-13-2003
ftpusers

this is the ftpusers file: I've tried putting my username in there, to no avail, doens't even allow root, its locked up and no one can get in there for some reason. It's broadcasting fine in Exceed, so that's there.


root
bin
daemon
adm
lp
sync
shutdown
halt
mail
news
uucp
operator
games
#nobody
*
all
# 7  
Old 05-13-2003
The ftpusers file is for denying the users listed ftp access.

See the faq at wu-ftpd.org
 

Previous Thread | Next Thread
Test Your Knowledge in Computers #239
Difficulty: Easy
In March 1970, the ARPANET reached the East Coast of the United States, when an IMP at the Department of Energy in Washington, DC was connected to the network.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

telnet and ssh not working .... but it pinging in Solaris 8

hi Everyone telnet and ssh not working in Solaris 8 .... but it pinging.... i also checked /etc/services /etc/inet/inetd.conf ps -ef | grep telnet ans default router ... everythinking is ok .... when i connect telnet then suddently closed ... and ssh is connection refused ... help... (1 Reply)
Discussion started by: coolboys
1 Replies

2. Windows & DOS: Issues & Discussions

ANT: Telnet is not working

I am trying the below ANT telnet task: <telnet userid="appldev" password="techm123" server="${BT_Server}"> <read>/u01/appldev/devappl/po/11.5.0/reports</read> <!--write>cd /u01/appldev/devappl/po/11.5.0/reports/</write--> <write>ls</write> <read... (0 Replies)
Discussion started by: Dip
0 Replies

3. Linux

FTP not working under Linux but working under any other OS ??? Very strange

Dear all, I am totally despaired and puzzled. Using Filezilla under Windows under the same network as our Linux servers is working. Using FTP command-line client under any of our Linux debian servers is not working ! I tried with different FTP servers -> same problem ! All commands are... (12 Replies)
Discussion started by: magix_ch
12 Replies

4. Red Hat

FTP on Linux is not working as expected

Hi, I need to write a Linux shell script which will perform an FTP operation to another server. main.sh will contain - ftp -nd Dest.IP.address < ftpScript.sh Contents of ftpScript.sh is given below - user userid passwd prompt lcd /vidya/Input cd vidya/Output mput *.* close ... (1 Reply)
Discussion started by: vidyak
1 Replies

5. UNIX for Dummies Questions & Answers

Telnet is not working properly

telnet at my system is behaving stange. Some times I am able to telnet to other machines but sometimes it stop doing that. Then i have to reboot the machine and most of the time (not 100%) it works. SImilar is the case with SSH. Sometime it works , some time it don't. i am new to Unix and I do not... (1 Reply)
Discussion started by: deepak_pathania
1 Replies

6. Red Hat

telnet & ftp in linux AS4 with root account

hi, i installed linux as4, i need telnet and ftp with root account. anybody show me how to configure. TIA, Bong (3 Replies)
Discussion started by: bong02
3 Replies

7. Solaris

after patch, telnet not working

The problem: I installed the Solaris 8 recommended patch cluster 117350-11 over 108528-15 before the Christmas break. The server is a SunFire V100. Here is the situation: Before the patch install, there was a working cron job that did daily, weekly, and monthly backups of the V100 filesystems... (3 Replies)
Discussion started by: antalexi
3 Replies

8. Cybersecurity

One accout for FTP other to TELNET

Hi All, If I want to have two user accounts from the same grop in UNIX Solaries. However, I want one of them to be used only for FTP while the other for TELNET. Can anybody tell me how to do that? Best Regards (13 Replies)
Discussion started by: omran
13 Replies

9. UNIX for Dummies Questions & Answers

FTP is not working after installing Linux 7.3

hi all, After installing Linux 7.3, when I wasn't be able to FTP to this machine from another machine; however, I do get the reply back when I ping this machine. All I want is able to transfer file on my local machine to this server using FTP comand and it's not working. Could someone please... (1 Reply)
Discussion started by: lapnguyen
1 Replies

10. IP Networking

FTP or Telnet

Dumb question I'm sure but how on earth do I transfer files from a sco unix machine to my windows 2000 machine. I'm typing commands on my Win2000 machine. All I can seem to do is move files around on the unix system? (8 Replies)
Discussion started by: Timbash
8 Replies

Featured Tech Videos