Visit Our UNIX and Linux User Community


DHCP server cannot execute script: permission denied exit 32512


 
Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers DHCP server cannot execute script: permission denied exit 32512
# 1  
Old 04-09-2020
DHCP server cannot execute script: permission denied exit 32512

I created a DHCP server on ubuntu 18:04 using isc-dhcp-server that normally works. I want to run a script located in /user/sbin but get error of permission denied with exit status 32512. Probably it's a permission error but I'm not expert. This is my dhcp server located in:

/etc/dhcp/dhcpd.conf

Code:
default-lease-time 86400;
max-lease-time 7200;

ignore client-updates;
authoritative;

use-host-decl-names on;
log-facility local7;


subnet 192.168.1.0 netmask 255.255.255.0 {
    range 192.168.1.101 192.168.1.150;
    option subnet-mask 255.255.255.0;
    option routers 192.168.1.3;
    option domain-name-servers 192.168.1.100;
    ddns-rev-domainname "in-addr.arpa.";
}

on commit {
    set ClientIP = binary-to-ascii(10, 8, ".", leased-address);
    set ClientMac = binary-to-ascii(16, 8, ":", substring(hardware, 1, 6));
    log(concat("Commit: IP: ", ClientIP, " Mac: ", ClientMac));
    execute("/usr/sbin/update_DB.sh", "commit", ClientIP, ClientMac);
}

/var/log/syslog

Code:
Apr  8 14:28:05 dhcp dhcpd[1223]: Commit: IP: 192.168.1.102 Mac: XXX
Apr  8 14:28:05 dhcp dhcpd[1223]: execute_statement argv[0] = /usr/sbin/update_DB.sh
Apr  8 14:28:05 dhcp dhcpd[1223]: execute_statement argv[1] = commit
Apr  8 14:28:05 dhcp dhcpd[1223]: execute_statement argv[2] = 192.168.1.102
Apr  8 14:28:05 dhcp dhcpd[1223]: execute_statement argv[3] = XXX
Apr  8 14:28:05 dhcp dhcpd[1227]: Unable to execute /usr/sbin/update_DB.sh: Permission denied
Apr  8 14:28:05 dhcp dhcpd[1223]: execute: /usr/sbin/update_DB.sh exit status 32512

anyone knows how to solve it, please? Thanks!
# 2  
Old 04-09-2020
It's clear from your post:

Quote:
Apr 8 14:28:05 dhcp dhcpd[1227]: Unable to execute /usr/sbin/update_DB.sh: Permission denied
Please post the output of:

Code:
ls -l /usr/sbin/update_DB.sh


Previous Thread | Next Thread
Test Your Knowledge in Computers #396
Difficulty: Medium
HP-UX was the first Unix to offer access control lists for file access permissions as an alternative to the standard Unix permissions system.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Permission denied running shell script in opensuse

Hello, I am having an odd problem in open suse 12. I have a shell script and when I try to run it, I get "permission denied" The permissions from ls -l are, -rw------- 1 user1 users 25904 Jan 10 16:26 script.sh I have tried to change the permissions in dolphin but this does not change the... (5 Replies)
Discussion started by: LMHmedchem
5 Replies

2. HP-UX

Swinstall and rsync - execute permission denied

Hello, I have managed to install rsync using swinstall and also as far as I can tell the dependancies we didn't have. However when trying to execute the binary I get the following error :- />rsync sh: rsync: Execute permission denied. />which rsync /usr/local/bin/rsync... (10 Replies)
Discussion started by: YogaBija
10 Replies

3. Shell Programming and Scripting

Help with Permission Denied on script with sed

I am trying to develop a script to replace a lowercase URLs with an upper case URLs in HTM files. Basically.. replace href="somelowercaseurl" with href="SOMEUPPERCASEURL". In place. the href's are not located in any specific position in the file. Here is my shell script : export... (5 Replies)
Discussion started by: smarty
5 Replies

4. UNIX for Dummies Questions & Answers

Getting Error 0403-006 Execute permission denied.

Hi All, Need your help.. I am writing one script in which I am assigning value to one variable but when i am executing it is showing error "0403-006 Execute permission denied" below is the line of that script : INPUT_COUNT=wc $GIF_DIR/input/VID_RIMS.DAT | awk '{print $1}' and access... (2 Replies)
Discussion started by: NirajThakar
2 Replies

5. Shell Programming and Scripting

shell script and Permission denied

Have the following in a .sh file. printf "Installing ... \ r" cd $ ORG_DIR / a_a . / configure> error.log Make 1> error.log 2> error.log make install> error.log But when I run I get the following. install.sh: line 270:. / configure: Permission denied make: *** No rule two make target... (3 Replies)
Discussion started by: Mumie
3 Replies

6. Shell Programming and Scripting

Change: xecho: execute permission denied error

Hello, I am have an issues with one of my scripts. I get the following error when I get to the point in the script where I am making the change. The change does take however. the error is "change: xecho: execute permission denied" Everything was working properly until I start cleaning... (3 Replies)
Discussion started by: simpsonjr
3 Replies

7. AIX

rm: execute permission denied in AIX

Hello All, We have an existing ssh set-up between 2 Unix servers ( Server A and Server B). Recently, we've had a problem where we cannot delete files (via app engine and even manually, after connecting thru ssh) on Server B. We manage Server A but Server B is handled by a different group, as a... (1 Reply)
Discussion started by: chipahoys
1 Replies

8. AIX

0403-006 Execute permission denied.

Hi i am running the below script in vio server, i changed to aix mode..then #./script1 </code> ##Set today Date as file name. vardate= date +"%m%d%y%H%M%S" varhost= hostname filename= "$varhost_$vardate" echo $filename </code> the output is ....... </code> # ./mount_test ... (6 Replies)
Discussion started by: honeym210
6 Replies

9. UNIX for Advanced & Expert Users

wat is execute permission denied???

hi, i have a problem and is needed by next week. when i need to run a program at the specified time using the crontab, after that the program which will send a messege to the screen using the say command, which will show "Hello" but there is an error when i run it, in the mail it show that ... (5 Replies)
Discussion started by: ckng
5 Replies

10. UNIX for Advanced & Expert Users

mount: failed, reason given by server: Permission denied

Hi , I have a filesystem on AIX 4.3.3 which i need to share with other clients who use Windows NT and Redhat linux 7.3. I use samba to share this with Windows NT Clients. Now i was to share this with Linux clients. When i try to nfs mount this on Linux i get "mount: failed, reason given by... (1 Reply)
Discussion started by: Sushesh
1 Replies

Featured Tech Videos