CentOS 7 trying to install failed to start vnc server : with configured resource limit was excee

Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers CentOS 7 trying to install failed to start vnc server : with configured resource limit was excee
# 1  
Old 04-06-2020
CentOS 7 trying to install failed to start vnc server : with configured resource limit was excee

i followd this tutorial :
How to Install and Configure VNC Server in CentOS 7

to install desktop and connected it via vnc from my windows PC using VNC viewer
but im getting this error in the : sudo systemctl start vncserver@:1 stage
im doing all from my user centos which is the main user im using with sudo enabled :
my /etc/systemd/system/vncserver@:1.service looks like this :

    Description=Remote desktop service (VNC)
    After=syslog.target network.target
    # Clean any existing files in /tmp/.X11-unix environment
    ExecStartPre=/bin/sh -c '/usr/bin/vncserver -kill %i > /dev/null 2>&1 || :'
    ExecStart=/usr/sbin/runuser -l centos -c "/usr/bin/vncserver %i"
    ExecStop=/bin/sh -c '/usr/bin/vncserver -kill %i > /dev/null 2>&1 || :'

this is the info :

  -rw-r--r--. 1 root root 1828 Apr  6 16:25 /etc/systemd/system/vncserver@:1.service

now im trying to start the vnc server :

   [centos@ip-10-0-0-111 ~]$ sudo systemctl daemon-reload
    [centos@ip-10-0-0-111 ~]$ sudo systemctl start vncserver@:1
    Job for vncserver@:1.service failed because a configured resource limit was exceeded. See "systemctl status vncserver@:1.service" and "journalctl -xe" for details.

what can be the problem ?
# 2  
Old 04-06-2020
Can we see :
systemctl status vncserver@:1.service -l

Take a look at this article :
Solved: vncserver service failed a configured resource limit was exceeded

Hope that helps
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. HP-UX

VPAR Resource Capacity Limit

Hello Guys Could you please let me know the command to find the resource (vCPU & Memory) capacity limit for the VPAR's (HPUX 11.23) on integrity Virtual host servers running HPUX 11.31 OS. For eg. I want to know what is the max vCPU and memory that I can assign to one VPAR. The Base Virtual... (0 Replies)
Discussion started by: prvnrk
0 Replies

2. Solaris

Reuse old/configured server for new purpose problems.

Greetings. First of all I consider myself a newbe in Linux, that's why I'm seeking your help so please be patient! I was given an old server (Solaris) that has Oracle (10.2.0) installed with a few databases. I'm supposed to reuse this server for this new application which will process data... (11 Replies)
Discussion started by: RedSpyder
11 Replies

3. Red Hat

Authentication Failed in Linux centos

Hi everyone ... ( Linux Cent OS ) i cant login as root user in my lab machine ... i did give correct root and root passwd ..but it showing Authentication Failed ... plz help me (0 Replies)
Discussion started by: coolboys
0 Replies

4. UNIX for Advanced & Expert Users

lvm swapon failed Device or resource busy

Is there a trick to mounting swap in n a lvm? I can't get it to work. # swapon -va swapon on /dev/mapper/VG-lv_swap swapon: /dev/mapper/VG-lv_swap: found swap signature: version 1, page-size 4, same byte order swapon: /dev/mapper/VG-lv_swap: pagesize=4096, swapsize=4294967296,... (1 Reply)
Discussion started by: cokedude
1 Replies

5. Solaris

Start of VNC with Solaris

Hello, We have machines running Solaris 2.8 These are part of a process control system. A selection menu after the launch of Solaris can be selected whether the Solaris desktop or Leitsoftware to start. VNC server is up and running when the Solaris user interface is started or when the... (1 Reply)
Discussion started by: eckart.t
1 Replies

6. Red Hat

xen vnc not working in Centos

i configured XEN to use port 5902 and it worked. I installed vncserver on the host machine. Now when i connect to 5902 it redirects me to the centos machine not to the XEN guest. (0 Replies)
Discussion started by: mrjoli021
0 Replies

7. Solaris

Solaris:Tomcat-Failed to access resource /WEB-INF/lib/One.jar

Hi All, I have configured the tomcat 6.0.26 and it is working fine in Solaris. Testing JSP and SERVLET program I ensured tomcat is configured properly (My guess). ------------------- Now I placed my Servlet and JSP code under /users/kalai/sample. I have created a soft link to... (1 Reply)
Discussion started by: kalpeer
1 Replies

8. UNIX for Dummies Questions & Answers

Mail/ftp/web servers, on VIRTUAL!! dedicated server. Also resource usage. Centos 5.

Hi. First of all, would 4 or 5 websites, 1 ftp server (when downloading by someone or a few persons or one, concretize) and one mail server (not many emails, just to sound official and have a nice, spam-free email for myself). Websites with not that many, but some, later more visitors, quite... (0 Replies)
Discussion started by: newn
0 Replies

9. AIX

failed login time limit

Hello, we had a situation where an account was locked out due to too many failed login attempts. From the logs (failedlogin, etc) it appears that AIX 'remembered' the failed login attempts from the past month or so. does anyone know where this is set, or how long it will remember the number of... (2 Replies)
Discussion started by: zuessh
2 Replies
Login or Register to Ask a Question

Featured Tech Videos