Mac OS X Catalina - NFS File Access Behavior in CRON or Launchd

Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers Mac OS X Catalina - NFS File Access Behavior in CRON or Launchd
# 8  
Old 03-20-2020
Instead, show us the mount command used or the according (if applicable) /etc/fstab line.
I've tried about 50 combinations, in the current and most simple form I use /etc/fstab

# Warning - this file should only be modified with vifs(8)
# Failure to do so is unsupported and may be destructive.
cady:/volume1/nfs       /System/Volumes/Data/nfs        nfs     rw

But in an attempt to try a lot of different combinations quickly I just used mount commands directly. Here's a sampling from my history.

mount cady:/volume1/nfs /System/Volumes/Data/nfs
mount_nfs -o resvport cady:/volume1/nfs /System/Volumes/Data/nfs
mount_nfs -o noacl cady:/volume1/nfs /System/Volumes/Data/nfs
mount_nfs -o nolock cady:/volume1/nfs /System/Volumes/Data/nfs
mount_nfs -o nfsvers=4 cady:/volume1/nfs /System/Volumes/Data/nfs
mount_nfs -o nfsvers=2 cady:/volume1/nfs /System/Volumes/Data/nfs
mount -o rw,sync,no_root_squash,no_subtree_check,insecure cady:/volume1/nfs /System/Volumes/Data/nfs

Using either mount commands directly, or using auto_master/auto_nfs, or /etc/fstab I can easily get the NFS drive mounted, and the permissions and ownership is correct. From a shell I can copy files to/from the local system to the NFS mount without troubles. The logs on the NFS server show no errors. I've already posted the unhelpful error log from the client machine.

I've tried lots of different combinations of owner/group/permissions via chown, chgrp and chown. Currently sitting at:

brians-mbp:etc root# ls -la /System/Volumes/Data/nfs/hosts
-rwxrwxrwx 1 1024 _lpoperator 2393 Feb 8 14:29 /System/Volumes/Data/nfs/hosts

I was hoping somebody familiar with how Mac OS X specifically creates the environment in which Launchd or cron jobs run could shed some light. Even though root has access to the files, and the Launchd or cron job is owned by root, it somehow isn't executed with normal root rights.
Login or Register to Ask a Question

Previous Thread | Next Thread

7 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Launchd-owned processes unexpected behavior

Ok, so I have been struggling with this for a few days and I think I need an explanation of a few things before I go any further. I'm not sure it's possible to do what I'm trying, so before I pull my hair out, here is what I'm doing: I have written a program in LiveCode that sits on our... (2 Replies)
Discussion started by: nextyoyoma
2 Replies

2. UNIX for Advanced & Expert Users

Different redirection behavior in BASH/Linux when run under cron vice login ???

run_xfs_fsr is a xfs filesystem maintenance script designed to run under cron. The system is a home theater personal computer running mythbuntu 10.10, and is accessed remotely for these tests. cron runs a script, ( at 02:30 that runs the subject script under BASH and sets the... (3 Replies)
Discussion started by: keepitsimpleeng
3 Replies

3. Shell Programming and Scripting

grep startup messages from catalina.out file

Hello Team, I am trying to extract date from the following output and trying to compare with current date and if there is 10 minute difference between the two. it should logs message in the file server is started.can anyone help me to implement this in the script? (1 Reply)
Discussion started by: coolguyamy
1 Replies

4. Red Hat

NFS Access Issue

Hi, I am facing issue on NFS. I have shared /data file file system on Server, added below lines in /etc/exports /data,no_root_squash,sync) the owner of /data directory was test(uid 500) and same I have mounted on another server where the... (3 Replies)
Discussion started by: manoj.solaris
3 Replies

5. Shell Programming and Scripting

Behavior of Bad Script in Cron Job

Hi A Ksh script is deployed in a server and executed through cronjob. If one of the line in the middle of the script fails . Are the remaining lines executed ? (3 Replies)
Discussion started by: Sivaswami
3 Replies

6. AIX

Cannot access NFS file system

I create a NFS file system. I can read this system from client, however, I cannot write anything in this folder. Why? (1 Reply)
Discussion started by: rainbow_bean
1 Replies

7. UNIX for Advanced & Expert Users

Strange IP traffic behavior when using Samba and FTP (Windows/Mac to Linux)

I have set up a samba share on my Linux server. I have a gigabit switch, gigabit NICs in each machine. I have set up the /etc/samba/smb.conf to support no delay, 8192 send/receive buffers, etc. This helped the rate for Samba go from about 4MB/S to about 10MB/S, but I expect to see about... (1 Reply)
Discussion started by: perspectx
1 Replies
Login or Register to Ask a Question

Featured Tech Videos