Disable Solaris Gnome 3 screen blanker

Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers Disable Solaris Gnome 3 screen blanker
# 1  
Old 02-06-2020
Disable Solaris Gnome 3 screen blanker

One of the more annoying features of the Gnome 3 desktop in Solaris 11 is its insistence on blanking the screen after five minutes of inactivity. And for the life of me I can't figure out how to make it top doing that. I'm running it in a VNC viewer so the host PC can take care of screen blanking.

I tried the Dconf Editor going to org -> gnome -> settings-daemon -> plugins -> power and unchecked "idle-dim". sleep-inactive-ac-timeout was already et to 0.

I tried org -> desktop -> applications -> lockdown -> check "disable-lock-screen".

I tried exiting the vnc viewer and strarting a new vnc server. But none of this works. The screen still blanks after five minutes. There's plenty of stuff on the web on how to do this in Linux and indeed I was able to do it in a Ubuntu VM running Gnome 3 but I just can't get it to work in Solaris 11. What am I missing here?


There's something about posting a question in public that causes the answer to come to you. In this case here is what to do.

Run the DConf Editor (Top menu Applications-> System Tools -> dconf editor) and go to org -> gnome -> desktop -> session and set "idle-delay" to 0. The screen will no longer blank out. No reboot needed. I'll leave this topic up because AFAIK this is the only place on the web that has this secret,

Last edited by Michele31416; 02-06-2020 at 03:56 PM..
This User Gave Thanks to Michele31416 For This Post:
# 2  
Old 02-06-2020
Hi Michele31416...

Thanks for updating your post with the answer...
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX and Linux Applications

vnc viewer presents black screen along with GNOME settings daemon errors.

Hello folks, I'm remotely connecting through VNC to two machines, each running Red Hat 5.9, from mine which is running Windows 7. Both connections were working well before. However, now one of the machines only gives me a black screen, with a pop up that says: "There was an error starting... (1 Reply)
Discussion started by: Miguel E. Perez
1 Replies

2. Solaris

Solaris 11 disable IPv6

I've new installed Solaris 11 on Sparc T4-1. I'd like to disable IPv6 but with no luck. lo0: flags=2001000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4,VIRTUAL> mtu 8232 index 1 inet netmask ff000000 net0: flags=1000803<UP,BROADCAST,MULTICAST,IPv4> mtu 1500 index 2 inet... (6 Replies)
Discussion started by: samer.odeh
6 Replies

3. Red Hat

command line tool to disable screen lock and/or screen saver

Hi, I have a simple question : how to disable screen lock and/or sreen saver with command line with RHEL5.4 ? (1 Reply)
Discussion started by: albator1932
1 Replies

4. Solaris

Gnome in Solaris 9

Hi My problem is that I kind of opened gnome environment from the cde environment and now I do not know how to turn it off so any suggestions will be much appreciated. and I am running Solaris 9 as root user I am also a beginner in unix Thanks in advance (4 Replies)
Discussion started by: Theeb
4 Replies

5. Solaris

Gnome Packages on Solaris 10 u6

If my system is supposed to be a pure oracle database server can i remove all the GNOME packages from the system ? Currently system is installed with Everything+OEM and i want the image to be as small as possible remove the unnecessary softwares from it so that its a master image for other servers.... (2 Replies)
Discussion started by: fugitive
2 Replies

6. UNIX for Advanced & Expert Users

How to disable the clearing of the first page when executing screen tool

Hi Guy, In order to monitor the user sessions, I have put the screen tool in the .profile in order to record the whole session. However, when the user logs in, the screen command is executed and the screen is first cleared, then the command prompt appears. so, I basically want to disable the... (2 Replies)
Discussion started by: saad26
2 Replies

7. Solaris

How to install gnome in solaris

How to install gnome in solaris 9 and 10, how to enable java environment in solaris 9 and 10. Thanks in Advance (1 Reply)
Discussion started by: durgaprasadr13
1 Replies

8. Linux

Disable Maximize/Resize on GNOME

Hello, I would like to know wether if its possible or not to do the following: 1) Disable the maximize button on a "particular" window. 2) Disable the resize option on that "particular" window. 3) Disable the right-click properties that appear when you click on a minimized app thats sitting... (2 Replies)
Discussion started by: preacheronsunda
2 Replies

9. UNIX for Dummies Questions & Answers

Solaris Express Slow to load Gnome

Hi, I recently installed the latest Solaris Express Developers Edition. I'm building a NAS and want to use RAID Z, and Solaris 10 didn't have the drivers for my HD controller card. Everything is up and running fine, but I notice it takes a good 8 minutes to load gnome (or X, not sure where it... (2 Replies)
Discussion started by: ciscocbee
2 Replies

10. Solaris

Gnome on Solaris 10

I have just installed Gnome on Solaris 10, I am wondering how to get it listed in the “session” selection box on the login screen, as it currently isn't. Any Ideas? :o (1 Reply)
Discussion started by: Dredz
1 Replies
Login or Register to Ask a Question

Featured Tech Videos