UNIX script error message

Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers UNIX script error message
# 1  
Old 01-28-2020
UNIX script error message

I have this UNIX script code with a query to export sql table in Oracle and export to csv file. The code gets the data correctly. However, when I run the script second time, I got the error message "not spooling currently" and shows the older data in csv file. When I delete the csv file and run the script it works again. I want the script to get me the recent data when I run it.
Do you know why?


sqlplus -s xyz_dev/abc123@GEEE3 <<EOF





Last edited by Neo; 01-28-2020 at 12:39 PM.. Reason: Code Tags Please See YT Video on this: https://youtu.be/4BuPvWJV__k
# 2  
Old 01-28-2020
Perhaps the SPOOL command will only write to a new file and refuse to append or overwrite an existing one.

Do you get any messages if you remove the SET FEEDBACK OFF and try it again with the file existing?

I hope that this helps.
# 3  
Old 01-28-2020
unis error message "not spooling currently"

Thanks Robin,
I have tried that and still got the same error " not spooling currently".
Any more ideas why?

# 4  
Old 01-28-2020
I think in addition to setting a spool name you have to

# 5  
Old 01-29-2020
Thanks all for your replies.
I think I found the problem. Every time I try to see the csv output file, the sheets are open on my window and never tried to close it. When I close all the current sheets and run the script again, it works.
I will update more findings.

# 6  
Old 01-29-2020
Change the $FILE variable include time of execution embedded in ?

EXECDATE=$(date "+%Y%m%d%H%M%S")

So each time you execute a script, it will generate a CSV file with current date up to second included.

If this is being executed in extremely high intervals, one may find various ways to generate 'randomness' to include in file name.
But for this and other things, you would need to include operating system details and shell used.
Please include those in this and future posts!

Hope that helps
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

UNIX script error message

Greeting!! I wrote the below script to e-mail me only file names in a specific directory when a file is delayed for some time in a that directory. I am getting unexpected eof error message. I don't want any email if the folder is blank.(if the condition is not met) I am not getting the email at... (4 Replies)
Discussion started by: Hope
4 Replies

2. Shell Programming and Scripting

Slack message multi line from UNIX script

Hi OS: Redhat Version 7.5 Enterprise Trying to post message from shell script to Slack channel and trying below code: text="$msg" text1="$lmsg" if ] then echo "No text specified" exit 1 fi escapedText=$(echo $text | $text1 | sed 's/"/\"/g' | sed "s/'/\'/g" )... (13 Replies)
Discussion started by: onenessboy
13 Replies

3. Shell Programming and Scripting

Error message while openning the xls file generated by UNIX

Hi All, I have created a unix script to mail the xls file.This is being done using mailx command fdate=`tail -1 abc.xls | cut -c1-8` SUBJECT="CARD GL Exceptions : ${ENV} for ${fdate}" destname=CARD_GL_Exceptions_$fdate sed 's/#BUSINESS/BUSINESS/1' abc.xls > abc2.xls mv abc2.xls abc.xls... (2 Replies)
Discussion started by: karthik adiga
2 Replies

4. Shell Programming and Scripting

How to deliver an error message from script?

Hi I have a script that pick up a file on another server, and place it on a solaris server, but I came across the following error: mget HLR01_21092014? 200 Port command successful 150 Opening data channel for file transfer. HLR01_21092014: No space left on device 426 Connection closed;... (18 Replies)
Discussion started by: fretagi
18 Replies

5. Shell Programming and Scripting

Passing error message back to script

I have one script that calls another script during execution. The other script does some processing, then either returns with exit 0 (if successful), or exits with error code numbers (if failed). However, in addition to the error code, I would like for that second script to be able to pass a... (4 Replies)
Discussion started by: AcerAspirant
4 Replies

6. Shell Programming and Scripting

Self referencing script error message

Hello again all. I have a user editable script that I'd like to have point out the user error to. Problem is I'm having troubles getting an echoed error message to give me the line. Here's what I'm trying to do. grep -n $loc /this/script.sh where '$loc' is the argument passed to the script.... (9 Replies)
Discussion started by: DC Slick
9 Replies

7. Shell Programming and Scripting

Error message while executing the shell script

Hi All, When I am trying to execute the below shell script I got this error message. script ========== #!/bin/bash /usr/java/jdk1.5.0_10/bin/java - classpath /var/lib/asterisk/agi-bin/mysql-connector-java-3.0.15-ga-bin.jar/: /var/lib/asterisk/agi-bin/jarfiles:... (4 Replies)
Discussion started by: ajayyaduwanshi
4 Replies

8. UNIX for Advanced & Expert Users

send a message through email to 5 people using unix script.

Hi All, I want to send a message through email to 5 people in unix script. Please let me know, how to do it.Please do reply it is urgent. Thanks, Mary. (3 Replies)
Discussion started by: MARY76
3 Replies

9. Shell Programming and Scripting

send a message through email to 5 people using unix script?

Hi All, I want to send a message through email to 5 people in unix script. Please let me know, how to do it.Please do reply it is urgent.How to do it?Please reply.thanks! Thanks, Mary. (2 Replies)
Discussion started by: MARY76
2 Replies

10. Solaris

Error Message in unix

Hi all......I'm sorry if my english is not that good. Can somebody help me to about this error. I found it in message.log Jan 16 18:22:42 ASM imapd: get_balanced_partition: -- chosen Jan 16 18:22:50 ASM SUNW,UltraSPARC-III+: NOTICE: Corrected system bus (CE) Event detected by CPU1 at TL=0,... (2 Replies)
Discussion started by: komang
2 Replies
Login or Register to Ask a Question

Featured Tech Videos