Find: missing argument to `-mtime'

Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers Find: missing argument to `-mtime'
# 1  
Old 01-06-2020
Find: missing argument to `-mtime'

this find command works when using manually on the command line
$ ls -latr file*.log
-rw-r--r-- 1 oracle dba 75 Jan  4 05:00 file_2.log
-rw-r--r-- 1 oracle dba 75 Jan  4 05:00 file_1.log
$ find . ! -name -prune -type f -name "file*.log" -daystart -mtime 2

however when using it on a on bash shell script as
for i in `find . ! -name . -prune -type f -name "$vfile" -daystart -mtime +$pday`

where the variable $vfile is the first parameter for the file to search and $pday is the second parameter days how old is the file

it is getting the error
$ sh file*.log 2
current directory .
find: missing argument to `-mtime'
no aging files found that are file_2.log days old

please help thank you.

Linux version: 2.6.32-754.15.3.el6.x86_64
# 2  
Old 01-06-2020
This is telling you that the value for pday is not set or not an integer, so your command as a whole becomes invalid. Could you sh -xv file*.log 2 and review the output to see what is actually being run? Do you actually assign the argument 2 to that variable pday ? I presume it would need something like pday="${2}" early in your code to do that.

It might also be that the shell where you are running the command has expanded file*.log to each file it found, so that might mess up the input. You could try by wrapping it in double quotes, so sh -xv "file*.log" 2 might be better. Obviously drop the -xv if this does the trick.

If this is still failing, could you paste the output/errors showing the expanded find command as it is trying to run?

Kind regards,
This User Gave Thanks to rbatte1 For This Post:
# 3  
Old 01-06-2020
originally it was written on AIX and is working fine then had to moved the to same script to Linux. basically the goal of the script is to find a file that is days old depending on the parameter.

here is the output using this command sh -xv file*.log 2
+ p1=file_1.log
+ pday=file_2.log

++ pwd
+ vdir=/sbin/scripts
++ pwd
+ vhomedir=/sbin/scripts
+ vctr=0

# check for null parameter
if [ $# -lt 1 ]; then
  echo current directory $vdir
  echo no parameter entered
  #check for directory entry only
  if [ -d $p1 ]; then
    echo current directory $vdir
    cd $vdir
    echo no file parameter entered
  #check for directory entry and file
  elif [ -f $p1 ]; then
    vdir=`dirname $p1`
    echo current directory $vdir
    cd $vdir

    for f in $1
      vfile=`basename $f`
      #for i in `find $vdir -name "$vfile" -mtime +$pday`
      #ommit the subdirectories in the searcch
      for i in `find . ! -name . -prune -type f -name "$vfile" -daystart -mtime +$pday`
        let vctr=$vctr+1
        vfile=`basename $i`
        echo deleting aging files $vfile
        rm $vfile

    if [ $vctr -eq 0 ]; then
      echo "no aging files found that are $pday days old"
    echo $p1 not found
+ '[' 3 -lt 1 ']'
+ '[' -d file_1.log ']'
+ '[' -f file_1.log ']'
dirname $p1
++ dirname file_1.log
+ vdir=.
+ echo current directory .
current directory .
+ cd .
+ for f in '$1'
basename $f
++ basename file_1.log
+ vfile=file_1.log
find . ! -name . -prune -type f -name "$vfile" -daystart -mtime +$pday
++ find . '!' -name . -prune -type f -name file_1.log -daystart -mtime +file_2.log
find: missing argument to `-mtime'
+ '[' 0 -eq 0 ']'
+ echo 'no aging files found that are file_2.log days old'
no aging files found that are file_2.log days old

#return the cursor to the home directory
cd $vhomedir
+ cd /sbin/scripts

# put a white space
+ echo

thank you.
# 4  
Old 01-06-2020
Exactly what rbatte1 predicted
the shell where you are running the command has expanded file*.log
is happening: $2 is becoming the second file found / expanded to.
# 5  
Old 01-06-2020
tried this still don't work.

maybe I am doing it wrong.
# 6  
Old 01-06-2020
Don't quote $2 but the first parameter (the one with wild card chars) on the command line when calling the script.
# 7  
Old 01-06-2020
tried to wrap the first parameter with double quotes but still would not work.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Missing argument for option: n Error

I am trying to execute the script in another shell script passing arguments and getting the below error. #!/bin/sh /home/runAJobCli/ runAJobCli -n $Taskname -t $Tasktype I am passing the below 2 arguments and it giving error ./ T_SAMPLE_TEST MTT... (11 Replies)
Discussion started by: Info_Geek
11 Replies

2. Shell Programming and Scripting

Find by name and mtime

Hi, I'm trying to find all files that have a .ksh and .p extension and that are 7 days old by using the below find command but it doesn't seem to as expected. It gives me random results.. Can someone point out what may be wrong? find . -name "*.ksh" -o -name "*.p" -mtime -7 (2 Replies)
Discussion started by: Jazmania
2 Replies

3. Shell Programming and Scripting

find: missing argument to `-exec' while redirecting using find in perl

Hi Friends, Please help me to sort out this problem, I am running this in centos o/s and whenever I run this script I am getting "find: missing argument to `-exec' " but when I run the same code in the command line I didn't find any problem. I am using perl script to run this ... (2 Replies)
Discussion started by: ramkumarselvam
2 Replies

4. UNIX for Dummies Questions & Answers

Find using mtime

Hi, so I was using mtime and its not behaving the way I would think its supposed too. I have two pdf files. One modified today and another 6 months ago. I upload them to the solaris server. Then I run the below find statements. This finds my 2 files find *.pdf -type f -name '*.pdf' this finds... (2 Replies)
Discussion started by: vsekvsek
2 Replies

5. Shell Programming and Scripting

Help on find -mtime -exec

Hello people. Part of my script: echo "Compressing files older than 2 months in ${TEMP_DIR} directory ..." find ${DATA_DIR}/ -name '*.dat' -mtime 61 -exec compress {} \; #BELOW COMMAND DOES NOT WORK :-( <<<<<<----------- find ${DATA_DIR}/ -name '*.o.lines.*' -mtime 61 -exec compress {}... (2 Replies)
Discussion started by: drbiloukos
2 Replies

6. Shell Programming and Scripting

find -mtime +7

Dear all, find $ADMIN_DIR/$SID/arch/ -name '*.gz' -mtime +7 -exec rm {} \; is it retaining 7 days OR 8 days .gz files ? Thanks Prakash (10 Replies)
Discussion started by: prakashoracledb
10 Replies

7. UNIX for Dummies Questions & Answers

find mtime syntax

Hi guys, I am looking for a way of moving all files out of a directory with a time stamp greater then the one I specify. Can anyone suggest a way of doing so? For example, move all files out of dir1 which were created after 17:00 into dir2. Thanks :) (1 Reply)
Discussion started by: JayC89
1 Replies

8. UNIX for Dummies Questions & Answers

(find) mtime vs. (unix) mtime

Hi I've made some test with perl script to learn more about mtime... So, my question is : Why the mtime from findfind /usr/local/sbin -ctime -1 -mtime -1 \( -name "*.log" -o -name "*.gz" \) -print are not the same as mtime from unix/linux in ls -ltr or in stat() function in perl : stat -... (2 Replies)
Discussion started by: hiddenshadow
2 Replies

9. UNIX for Dummies Questions & Answers

find . -mtime

...what am i doing wrong?? I need to find all files older than 30 days and delete but I can't get it to pull details for ANY + times. The file below has a time stamp which is older than 1 day, however if I try and select it using any of the -time flags it just doesn't see it. (the same thing... (1 Reply)
Discussion started by: topcat8
1 Replies

10. UNIX for Dummies Questions & Answers

find -mtime off by one day?

If I use the find command to find files older than n days I have to enter find . -mtime +(n-1). I tried this on a Solaris 9 system and also Linux. Is this something that all Unix veterans know about (I'm new to Unix)? If so, maybe my man pages need to be updated (how to do this?). :confused: (4 Replies)
Discussion started by: ceanntrean
4 Replies
Login or Register to Ask a Question

Featured Tech Videos