Telnet command on AIX


Login or Register for Dates, Times and to Reply

 
Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers Telnet command on AIX
# 1  
Telnet command on AIX

Hello,

I need to verify whether I am able to make connection to a remote server from my AIX (os level : 7.1.0.0) host.

The host has 2 Alias IP's how can I force an source Alias IP on the telnet command.

I tried the below options but none of them worked.

Is there any other command that I can use

Code:
admin@2a[/home/user/admin]# telnet -s x.x.x.x x.x.x.x 443
telnet: Not a recognized flag: s
Usage: telnet [-f|-F] [-k realm] [-l username] [-d] [-p] [-n NetTrace] [-e terminal] [host] [port]
admin@2a[/home/user/admin]# telnet -b x.x.x.x x.x.x.x 443 443
telnet: Not a recognized flag: b
Usage: telnet [-f|-F] [-k realm] [-l username] [-d] [-p] [-n NetTrace] [-e terminal] [host] [port]

Thanks
# 2  
telnet ip.addr
will connect where the ip.addr is the destination.

If you are trying to spoof your ip try using the nc command instead. (nc is also called netcat)
how to "telnet" from a specific source IP?

telnet uses the OS to set it's source IP, you cannot specify it on the command line.

Last edited by jim mcnamara; 12-24-2019 at 07:45 PM..
# 3  
nc command did not work as well.

Code:
admin@pa[/home/user/admin]# nc -s x.x.x.x x.x.x.x 443
ksh: nc:  not found.

Please advise
# 4  
The AIX at work has some optional Linux tools for AIX installed.
If you have to do this to debug problems or set up security, then you need to consider seriously installing them.

Before I look up what you need, if you cannot install anything then it is time to roll your own. So please advise. And give me the shells you have now, and the version of AIX. I cannot be of any help without more from you.
# 5  
Here is the version and the shells

Code:
admin@2a[/home/user/badmin]# cat /etc/shells
/bin/csh
/bin/ksh
/bin/psh
/bin/tsh
/bin/bsh
/usr/bin/csh
/usr/bin/ksh
/usr/bin/psh
/usr/bin/tsh
/usr/bin/bsh
/usr/bin/bash
/usr/bin/dzsh


admin@2a[/home/user/admin]# oslevel -r
7100-04

# 6  
AIX Open Source Packages | Main / nc

This is source code with directions for compilation --- for netcat (nc is often a symlink to netcat and or the other way around.). It requires a C compiler, which I assume you have. I have not tried to build it except as the root user, a few years back.
# 7  
netcat (nc) on AIX does not exist. If you want to install it, it requires a million other packages as requisites that do not exist on AIX either - it is strictly speaking painful.
Without it, you will not be able to force AIX to use a specific source IP adress as AIX will always decide by itself which source IP to use consulting the routing table.
The easiest way to test - if you can have a temporary downtime for testing - is to temporarily change your IP address to the alias IP address and then simply telnet destinationhost port ? - And once tested just change it back.
In reality - considering that your alias sits o a physical adapter with an underlying IP, why do you even care?
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #462
Difficulty: Medium
NTPv4 introduced a 256-bit date format: 128 bits for the second and 128 bits for the fractional-second.
True or False?

10 More Discussions You Might Find Interesting

1. AIX

Can we secure telnet on AIX

Hi, I understand that, we can use SSH/SSL for encrypted/secure sessions. my question is " can we secure telnet on AIX " ? usually, we disable network services like ftp, telnet etc. and replace it with SFTP, SSH. is there a way to secure telnet without disabling it ? i found some... (3 Replies)
Discussion started by: system.engineer
3 Replies

2. AIX

I am a NEW Dummy here(AIX telnet)

I work for a health care company part of my job is to run checks we use a telnet session that we use AIX 6 commands. I have almost no programming experience but i want to learn it, we have a programmer here but he has no time my question is,, Is there anything that allows you to program a GUI... (7 Replies)
Discussion started by: jtechie3
7 Replies

3. AIX

xp to aix - telnet blank screen

hello, i am trying to test connection to a 5.3 box. from an xp machine, telnet connects but shows only a blank screen. cursor moves as i type, but no response back. have used telnet, putty and accuterm - all same result verified that telnet services are active in xp xp windoze firewall is... (10 Replies)
Discussion started by: allenhibbert
10 Replies

4. AIX

Telnet for AIX 5.3

Hi all, I have 2 servers (Oracle & Weblogic) in 1 AIX box (Different partition). I recently had done a security hardening to this AIX box. And it disable the FTP and TELNET functions of both servers. I manage to recover the settings for the Oracle server but i have totally no access to the... (2 Replies)
Discussion started by: shinnee
2 Replies

5. AIX

AIX 4 and telnet

I have a very old IBM server running AIX 4 and it runs our old inventory management software. The system was working fine until we had a recent power outage. When the machine came back on, everything seems to work fine, except telnet. The machine pings fine, but telnet says connection is... (10 Replies)
Discussion started by: shudson105
10 Replies

6. AIX

Telnet disconnects on handheld device AIX

I have intermec handheld device which is connecting to AIX Server on port 12431 or whatever. ( oracle application ) The handheld device connects for few seconds and then disconnects from the AIX server. Once it disconnects the handheld device automatically switches off. Are there any... (2 Replies)
Discussion started by: filosophizer
2 Replies

7. UNIX for Dummies Questions & Answers

Telnet Session to AIX

Hello, I have AIX 5.3 at home connected to netgear router. Port Forwarding has been enabled on the router. Problem is that if I want to telnet, I have to try 2 or 3 times before I can get a logon prompt. It times out for first or second time (Connection to session <IP_Address> failed: Connection... (1 Reply)
Discussion started by: bluebee
1 Replies

8. AIX

How to turn off telnet on AIX

Greetings. . .Can anyone out there explain how I would turn off the telnet service and close the telnet port on a AIX system? Thank you, outta. (2 Replies)
Discussion started by: outtacontrol
2 Replies

9. AIX

aix telnet disconnects

We're having problems getting disconnected from AIX with our telnet sessions. I can't ping the server when this happens, either. Other serves can be pinged at the same time. This happens both at unix and within the database. Database locks remain when editing files. unix logins remain after... (0 Replies)
Discussion started by: e1lyons
0 Replies

10. AIX

telnet problem in aix

Can somebody help me. Whenever I telnet to my server i received a message /dev/pts/0: 3004-004 You must "exec" login from the lowest login shell. Connection closed. pls help me (2 Replies)
Discussion started by: vjm
2 Replies

Featured Tech Videos