Fatal error: 'Xm/Xm.h' file not found , motif installed

Login or Register for Dates, Times and to Reply

Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers Fatal error: 'Xm/Xm.h' file not found , motif installed
# 1  
Fatal error: 'Xm/Xm.h' file not found , motif installed

i have installed open-motif -2.3.8_1 X11 Toolkit on freebsd32bit machine.
wanna compile a little script. script is ok. already compiled on other machine (linux)
the message is as follows
   cc -o button button.c -lXm -lXt -lX11
button.c:3:10: fatal error: 'Xm/Xm.h' file not found
#include <Xm/Xm.h> /*Motif include file*/

1 error generated

How can this be possible if open-motif is correct installed ?
there are only two other motif packages.
1. linux-c6-openmotif
2. linux-c7-motif

Attention : i found another error when compiling another script.
X11/Intrinsic.h NOT FOUND


Last edited by Sennenmut; 11-29-2019 at 06:28 PM.. Reason: addition
# 2  
The first thing to do is to search the filesystem for the file(s) and note the locations (full path) to the files.

Please do this and post the results back.

# 3  
hi , i got it.

Problem solved.

# 4  
Hello Sennenmut,

Good that you were able to solve the problem by your own. But after working on few posts in this thread and suddenly declaring that you have solved the problem will not help anyone.

I would like to request you to please do add your solution which helped you fix your problem in this thread do that future users could be benefited too. Cheers and happy learning on this great site.

R. Singh
This User Gave Thanks to RavinderSingh13 For This Post:
# 5  
cc  -L/usr/local/lib   -I/usr/local/include  -o button button.c  -lXm -lXt -lX11

UNIX wins. ( not gnu)
# 6  
It is always wise to include your library and include paths when compiling a program in C.

Here is your first (you said not working) attempt:

 cc -o button button.c -lXm -lXt -lX11

Here is your working attempt:

cc  -L/usr/local/lib   -I/usr/local/include  -o button button.c  -lXm -lXt -lX11

The only difference is that you have included your paths, which is standard. If you do not include the paths, how will cc know where to search for include files and libraries?

This is why you should always search your file system when you encounter such a compile-time error and then, as you have done, include the correct paths.
This User Gave Thanks to Neo For This Post:
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #367
Difficulty: Medium
The Single UNIX Specification specifies vi, so every conforming UNIX system must have it.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Bash find version of an installed application but if none is found set variable to App Not Installed

Hello Forum, I'm issuing a one line bash command to look for the version of an installed application and saving the result to a variable like so: APP=application --version But if the application is not installed I want to return to my variable that the Application is not installed. So I'm... (2 Replies)
Discussion started by: greavette
2 Replies

2. What is on Your Mind?

PHP Fatal Errors During SSL Cert Management - PHP Fatal error: xc_fcntl_mutex failed

Today, I noticed some errors in our SSL cert renewal log files, mostly related to domains where the IP address had changed. Concerned about this, rebuilt out SSL cert, which normally goes well without a hiccup. However, for today, for some reason which I cannot explain, there was a PHP error... (0 Replies)
Discussion started by: Neo
0 Replies

3. Programming

Fatal error: mcrypt.h: No such file or directory

Hi All, I am trying to include a mcrypt.h header but I am getting the below error: test01> gcc test1.c test1.c:5:20: fatal error: mcrypt.h: No such file or directory #include <mcrypt.h> ^ compilation terminated. As I cannot put my encryption program here, so have... (4 Replies)
Discussion started by: Shre
4 Replies

4. Solaris

fatal error: stdio.h: No such file or directory

Trying to compile a C program recievin this hello.c:1:19: fatal error: stdio.h: No such file or directory gcc is installed on the system. echo $PATH /usr/bin:/usr/sbin:/usr/gcc/4.5/include/c++/4.5.2/tr1 root@Sol11swtb01:/media/NO NAME/Programming/C/Testing# cd... (2 Replies)
Discussion started by: Fingerz
2 Replies

5. Shell Programming and Scripting

help with email to be triggered based on fatal error detection from batch run log file neded

Hi, I require need help in two aspects actually: 1) Fatal error that gets generated as %F% from a log file say ABClog.dat to trigger a mail. At present I manually grep the log file as <grep %F% ABClog.dat| cut-d "%" -f1>. The idea is to use this same logic to grep the log file which is... (1 Reply)
Discussion started by: zico1986
1 Replies

6. UNIX and Linux Applications

Grace installation Ubuntu 8.10 - Motif error

Hi, I am trying to install Grace version 5.1.22. The configuration script gives the error below: checking for a Motif >= 1002 compatible API... no configure: error: M*tif has not been found I had lesstif2 and lesstif2-dev installed when I first encountered the error. I installed... (0 Replies)
Discussion started by: apprentice
0 Replies

7. Solaris

Error- ld.so.1: expr: fatal: libgmp.so.3: open failed:No such file or directory

Hi Friends I have a compiler(Sun Forte,I believe) running in my Solaris 9 box. since y'day my development team is finding this error when they compile: ld.so.1: expr: fatal: libgmp.so.3: open failed: No such file or directory I ran a search for this file and found it in one of my file... (2 Replies)
Discussion started by: Hari_Ganesh
2 Replies

8. Solaris

ld: fatal: library -ltli: not found

Hi, I am on the following version: SunOS e105 5.8 Generic_117350-26 sun4u sparc SUNW,Sun-Fire-15000 I am running a makefile to build some Tuxedo servers. Following is a snippet of my output: BS-550.c: /home/sybase/sybase12/OCS-12_EBF10731/include/sybesql.c: ld: fatal: library... (0 Replies)
Discussion started by: vaibhav276
0 Replies

9. HP-UX

webservd: fatal: libgcc_s.so.1: version GCC_3.3’ not found

HI, We configured the webserver under the opt/SUNWwbsvr/https-pw-frontend/ in unix box. We have server start and stop command under the opt/SUNWwbsvr/https-pw-frontend/ Unexpectedly our password webserver’s(sun one webserver’s) are down, when I tried to start the server this is the error I'm... (1 Reply)
Discussion started by: srujana
1 Replies

10. AIX

MAN not found or not installed ??? Need help

Hello, I have installed my system AIX5.3 through NIM. The manual doesn't work. Do you have any idea ? Below my confid. There a specific fileset missing ? Thanks in advance for your help # man ls Manual entry for ls not found or not installed. # lslpp -l bos.rte.man Fileset ... (0 Replies)
Discussion started by: touny
0 Replies