I have forgot my root password. Solaris 10

Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers I have forgot my root password. Solaris 10
# 1  
Old 10-24-2019
I have forgot my root password. Solaris 10

hi everyone
i have forgot my root password and i have other user to login. can i get the password without restarting the server as that cant be afforded. . it is a Sparc architecture 2U blade server. it is old server mounted and functional since 2009. what should be the modus oprandee. i am novice to solaris .
plz guide what to check so that i can assess my chances of root password getting back etc

# 2  
Old 10-25-2019
One of the best (and easiest) ways to recover the root password when you have physical access to the server is to boot from a different disk or partition and then mount the disk or partition with the lost root password file and edit the password file. Normally, just make the password entry blank.

Another way is to boot from a different disk or partition and then mount the disk or partition with the lost root password file and edit the password file and change the userid to "0" of a user whom you know the root password. This will give you root access to that "other user" and you can then change the password of root with that user (since their userid is 0).

Then reboot with the original disk and clean up any changes you made, change passwords, etc.

Always remember, if you have physical access to a computer / disk and loose any passwords, you can mount the disk (where the lost password file resides) and edit it on another computer, assuming of course you have root access on the secondary computer and the disk does not have special access controls in place (most do not).
This User Gave Thanks to Neo For This Post:
# 3  
Old 10-25-2019
I think Solaris Sparc does not make a 2nd bootable partition (recovery partition) by default.
So you'll need to boot from a Solaris installation CD (usually the 1st CD in the package). Do not start the installation, but open a shell.
From there mount your disk device to /a
Then your crypted root password can be deleted or changed in /a/etc/shadow
You have to know (or guess) your disk device. Look it up before, on your alive system with
df /

If it's like /dev/dsk/c0t0d0s0 then it is a physical disk, that you can mount when booted from CD.
If it's a Solaris volume manager disk then recovery might be more complicated; try the Oracle Web documentation.
If it's zfs then I have no experience...
# 4  
Old 10-25-2019
You need to get on the system one way or another as superuser (root). Then edit /etc/shadow exactly as MadeInGermany says to remove the hashed password field for user root.

Usually superuser access is achieved by booting from DVD (installation media) into single user:

boot cdrom -s

which will not take you into the installation routine but allow you a shell to make changes.

This is easier if you are running simple UFS filesystems.

If your filesystems are ZFS then post back here and we'll tell you how to do it.
# 5  
Old 04-14-2020
Hi. I had the same problem and this solution was really helpful. However, I was able to do this without an installation CD. From the login screen, I did a

then boot into failsafe mode
boot -F failsafe

. As a bonus, when it reboots, it tells you what drive the operating system is on and asks you if you would like to mount it to /a. Here is my whole procedure:

From the login screen:
Stop A
At the {1}ok prompt:
boot -F failsafe
Screen echoes that it has found the disk with the OS and do you wish to have it mounted read-write on /a. Choose:
Instead of using EDIT command, you can use VI by entering
Export TERM
Edit the password file:
vi /a/etc/shadow
Use ghjk to navigate to the hashed password (between 1st and 2nd colons), then x to delete the characters.
Save the file:
Exit the file:
Power the machine off, then back on.
This User Gave Thanks to Stellaman1977 For This Post:
# 6  
Old 04-15-2020
Thank you! I have never heard of the boot -F failsafe before.
Have read about it now: an Oracle article says it must exist as /platform/`uname -m`/failsafe.
I have access to an older Solaris 10 Sparc installation that does not have it. How to create it?
This User Gave Thanks to MadeInGermany For This Post:
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Can a root role change the root password in Solaris 10?

i do not have root on a solairs 10 server , however i do have the root role, i was wondering if I can change the root password as a a role with the passwd command? I have not tried yet. and do i have to use the # chgkey -p afterwards? i need to patch is why i am asking. thanks (1 Reply)
Discussion started by: goya
1 Replies

2. Web Development

Forgot MYSQL password root

I have VPS openSUSE 12.2 I forgot MYSQL password root when i run in CMD: > mysql Error Message Show : >> ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO) (6 Replies)
Discussion started by: CloudniX
6 Replies

3. UNIX for Dummies Questions & Answers

Forgot root password

i am a new user of unix . i lost my SGI unix server root password Any body please help me,how get password? (2 Replies)
Discussion started by: vasu.k82
2 Replies

4. Solaris

Solaris 8 - Asks for current root password when trying to change root password.

Hello All, I have several solaris boxes running Solaris 8. When changing root passwords on them, all will simply ask for the new root password to change and of course to re-type the new password. One of the systems however asks for the existing root password before it will display the new password... (8 Replies)
Discussion started by: tferrazz
8 Replies

5. Solaris

forgot password

hello friends, I am currently using solaris 10. I have lost the root password. Can you please give me a step by step procedure on how to set the password again. (11 Replies)
Discussion started by: nsharath
11 Replies

6. Red Hat

forgot root passwd

hi i have a RHEL 4 and have forgot root passwd tried to boot in by singel user and then changing the passwd but it's not letting me do that ......throwing some weird error as .......manipulation i also tried to make a new user from CLI but even though it's not letting me in from that user as... (12 Replies)
Discussion started by: techbravo
12 Replies

7. Solaris

Solaris root password

Bit of a strange problem I have never come across before.. I can log into the workstation going through the server as it is a trusted host but when I try and connect to the workstation through SSH or RSH directly it will not take the password, I changed the password when I logged in the machine... (5 Replies)
Discussion started by: Mr Pink
5 Replies

8. UNIX for Dummies Questions & Answers

I forgot my UNIX password!!

Hello, Is there a way to reset the "root" unix password, pretty much like you would do in linux by going into single user mode? :confused: :confused: Thank you in advance. (5 Replies)
Discussion started by: Mr Big
5 Replies

9. HP-UX

forgot password

i forgot my password on a HP-UX 9.xx machine. is there a possible way of changing it without knowing the root passwd? I would do it with a boot disk and chroot but I dont have a boot disk available.... any ideas? thanks!! Paul Tittel (1 Reply)
Discussion started by: paultittel
1 Replies

10. Linux

forgot password red hat ?

Dear Forum savants, I have a problem that I am not sure how to overcome. Two years ago I had a friend build me computer with a linux os (red hat) for learning purposes. It happens to have an oracle server on it as well... Anyway , because of personal reasons, I lost complete interest in... (5 Replies)
Discussion started by: jxh461
5 Replies
Login or Register to Ask a Question

Featured Tech Videos