Visit The New, Modern Unix Linux Community

UNIX tool on MacOS that can increase resolution of a file

Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers UNIX tool on MacOS that can increase resolution of a file
# 1  
UNIX tool on MacOS that can increase resolution of a file


I am searching for a native tool on MacOS that can increase the resolution of a group of image files whose aspect ratios (file width versus height) vary widely. There are numerous files so I don't wish to do this manually. Someone suggested the sips command with the resampling option but it appears this requires you to input a desired width and height. As found on the sips man page.

Is there some other UNIX command that can do what I wish? All I need to do (I think) is increase the number of pixels so that when the image is blown up then it appears smooth and not grainy or 'washed-out'.

thanks so much for your suggestions.

postscript - These image files are used in an iOS program and the problem appears on the large screen sizes of the ipad pro third generation.
# 2  
You can try ImageMagick on macOS:


Use ImageMagick® to create, edit, compose, or convert bitmap images. It can read and write images in a variety of formats (over 200) including PNG, JPEG, GIF, HEIC, TIFF, DPX, EXR, WebP, Postscript, PDF, and SVG. Use ImageMagick to resize, flip, mirror, rotate, distort, shear and transform images, adjust image colors, apply various special effects, or draw text, lines, polygons, ellipses and Bézier curves.

ImageMagick is free software delivered as a ready-to-run binary distribution or as source code that you may use, copy, modify, and distribute in both open and proprietary applications. It is distributed under a derived Apache 2.0 license.

ImageMagick utilizes multiple computational threads to increase performance and can read, process, or write mega-, giga-, or tera-pixel image sizes.

The current release is ImageMagick 7.0.8-60. It runs on Linux, Windows, Mac Os X, iOS, Android OS, and others.
# 3  
Thanks for the suggestion, however, after investigating that software more carefully it appears that it requires Xquartz/X11 and my understanding is that software is obsolete and doesn't play well with the current version of MacOS. It's a pity because otherwise it appears to be exactly what I need.

Could anyone suggest anything else?
# 4  
I run the latest version of Mojave so let me try to install and see what happens:

:tmp Tim$ brew install ImageMagick
Updating Homebrew...

# 5  
Seems to install OK on Mojave ...

end of log ..


=> Pouring imagemagick-7.0.8-59.mojave.bottle.tar.gz
  /usr/local/Cellar/imagemagick/7.0.8-59: 1,479 files, 23.4MB
==> `brew cleanup` has not been run in 30 days, running now...
Removing: /usr/local/Cellar/gettext/ (1,935 files, 16.9MB)
Removing: /Users/Tim/Library/Caches/Homebrew/mtr--0.92.mojave.bottle.tar.gz... (70.1KB)
Removing: /usr/local/Cellar/openssl/1.0.2r... (1,795 files, 12.1MB)
Removing: /Users/Tim/Library/Logs/Homebrew/mtr... (64B)
Removing: /Users/Tim/Library/Logs/Homebrew/rsync... (64B)
Pruned 0 symbolic links and 4 directories from /usr/local
==> Caveats
==> gettext
gettext is keg-only, which means it was not symlinked into /usr/local,
because macOS provides the BSD gettext library & some software gets confused if both are in the library path.

If you need to have gettext first in your PATH run:
  echo 'export PATH="/usr/local/opt/gettext/bin:$PATH"' >> ~/.bash_profile

For compilers to find gettext you may need to set:
  export LDFLAGS="-L/usr/local/opt/gettext/lib"
  export CPPFLAGS="-I/usr/local/opt/gettext/include"

==> libffi
libffi is keg-only, which means it was not symlinked into /usr/local,
because some formulae require a newer version of libffi.

For compilers to find libffi you may need to set:
  export LDFLAGS="-L/usr/local/opt/libffi/lib"

==> openssl
A CA file has been bootstrapped using certificates from the SystemRoots
keychain. To add additional certificates (e.g. the certificates added in
the System keychain), place .pem files in

and run

openssl is keg-only, which means it was not symlinked into /usr/local,
because Apple has deprecated use of OpenSSL in favor of its own TLS and crypto libraries.

If you need to have openssl first in your PATH run:
  echo 'export PATH="/usr/local/opt/openssl/bin:$PATH"' >> ~/.bash_profile

For compilers to find openssl you may need to set:
  export LDFLAGS="-L/usr/local/opt/openssl/lib"
  export CPPFLAGS="-I/usr/local/opt/openssl/include"

==> readline
readline is keg-only, which means it was not symlinked into /usr/local,
because macOS provides the BSD libedit library, which shadows libreadline.
In order to prevent conflicts when programs look for libreadline we are
defaulting this GNU Readline installation to keg-only.

For compilers to find readline you may need to set:
  export LDFLAGS="-L/usr/local/opt/readline/lib"
  export CPPFLAGS="-I/usr/local/opt/readline/include"

==> sqlite
sqlite is keg-only, which means it was not symlinked into /usr/local,
because macOS provides an older sqlite3.

If you need to have sqlite first in your PATH run:
  echo 'export PATH="/usr/local/opt/sqlite/bin:$PATH"' >> ~/.bash_profile

For compilers to find sqlite you may need to set:
  export LDFLAGS="-L/usr/local/opt/sqlite/lib"
  export CPPFLAGS="-I/usr/local/opt/sqlite/include"

==> python
Python has been installed as

Unversioned symlinks `python`, `python-config`, `pip` etc. pointing to
`python3`, `python3-config`, `pip3` etc., respectively, have been installed into

If you need Homebrew's Python 2.7 run
  brew install python@2

You can install Python packages with
  pip3 install <package>
They will install into the site-package directory

==> libtool
In order to prevent conflicts with Apple's own libtool we have prepended a "g"
so, you have instead: glibtool and glibtoolize.

# 6  
Install complete.

:tmp Tim$ magick logo: logo.gif
:tmp Tim$ identify logo.gif
logo.gif GIF 640x480 640x480+0+0 8-bit sRGB 256c 28576B 0.000u 0:00.000

Seems to work fine for me on macOS Mojave 10.14.6, the above created this logo:

This User Gave Thanks to Neo For This Post:

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #618
Difficulty: Medium
Python is strongly object-oriented in the sense that everything is an object including numbers, strings and even functions.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

Macos is the UNIX?

why,just beacuse that its the bottom layer uses a small amount of bsd code? In my opinion, macos and Unix are completely different. The directories are long directory structures. For example, /application, /system, /user, /volumes, etc. are completely different from the traditional /bin/ /sbin... (5 Replies)
Discussion started by: malaizhichun
5 Replies

2. Shell Programming and Scripting

Variable resolution in File content

I have a file File1 containing lines like below apple ${FRUIT}-Color orange ${FRUIT}-Color banana ${FRUIT}-Color Now, in my shell I'm reading the file like below while read FRUIT DESC; do echo $FRUIT $DESC; done < File1 which outputs - apple ${FRUIT}-Color orange ${FRUIT}-Color... (3 Replies)
Discussion started by: nexional
3 Replies

3. Solaris

How to increase history number in UNIX?

Hi All, when i use history command i got the last 1000 command i want to increase this to 10000 how can i do that (4 Replies)
Discussion started by: hosneyxxosman
4 Replies

4. OS X (Apple)

USB File Transfer MacOS 10.6.5 to Android 2.2?

I'm trying to get a MacBook Air (MBA) running 10.6.5 to recognize a Samsung Galaxy S (Android 2.2) vis the USB interface for simple file transfers back and forth. Nothing works so far. I've tried many things! :wall: I noticed when I connect my phone to the MBA, there is a message in system.log... (2 Replies)
Discussion started by: Neo
2 Replies

5. AIX

how to increase the space unix directores

Hi have IBM aix. unix my directories are full when i use $ df -k filesystem kbytes used avail capacity mounted on /dev/root 288880 288880 288880 100% / /proc 0 0 0 ... (4 Replies)
Discussion started by: raosurya
4 Replies

6. UNIX for Advanced & Expert Users

Increase the counter in UNIX

HI! All Iam facing an issue with split comman in unix Prifix=Z_PRICE_NEW`date "+%Y%m%d%H%M%S"` split -5000 Product.txt $Prifix find . -name "$Prifix*" -print | { while read FILE; do mv $FILE $FILE.txt done } when is execute the comman the command is working fine and generating the... (2 Replies)
Discussion started by: mohdtausifsh
2 Replies

7. UNIX for Dummies Questions & Answers

How to increase buffer size in Unix

The "top" command shows that my buffer size is always at 137M, which I think has reached to the maximum. However, Ido have lots of Inative memory? Is it possible to increae the buffer size? and what is the command for that? Further, this is the buffer for writing to the hard disk? (3 Replies)
Discussion started by: ziabegg
3 Replies

8. UNIX for Advanced & Expert Users

How to increase the buffer size in Unix

When I checked with top command, I found tht my buffers are always 137M, which means that they are sort of overloaded. My Inactive memory is 520M. Is it possible to increaase the buffer size and what would be the command for that? (0 Replies)
Discussion started by: ziabegg
0 Replies

9. UNIX Desktop Questions & Answers

how do I increase the character size in the Unix Box

do anybody has knowledge how do i increase the character size in the UNIX box (1 Reply)
Discussion started by: subir23
1 Replies

10. UNIX for Advanced & Expert Users


I am interested in knowing if anyone out there has been using the BSD UNIX that underlies MacOS X. Is this an "industrial strength" version of UNIX? Can I run X-Windows on such a machine? How about TeXing, pythoning, PERLing or using other useful UNIX goodies near and dear to my shrunken... (1 Reply)
Discussion started by: ncmathsadist
1 Replies

Featured Tech Videos