CONFIG_HID=y and logitech usb mouse B185 doesn't work in 5.3.0-RC2


 
Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers CONFIG_HID=y and logitech usb mouse B185 doesn't work in 5.3.0-RC2
# 1  
Old 07-30-2019
CONFIG_HID=y and logitech usb mouse B185 doesn't work in 5.3.0-RC2

trying to make the best for me with 5.3.0-RC2, everthing's fine, the dell vostro 3558 does what it should - but - and here's the question: how do I get a logitech m185 (wireless mouse) to work; I googled around but couldn't fiind anything usefull; the best I get when using solaar (depreciated?) is:

Code:
solaar: error: Logitech receiver not found

I tried every option in the HID section of the kernel .config to change to yes, even tried to turned off USB_HIDBP as suggested in the web

I first thought it is the 2.0 USB port that makes troubles, but it isn't; machine doesn't recognize a TRUST wireless model neither, so it is deeper in the kernel - HID_USB=y ; . Dmesg says when plugging in:

Code:
    usb 2-3: USB disconnect, device number 2
[ 1324.058445] usb 2-3: new full-speed USB device number 7 using xhci_hcd
[ 1324.200689] usb 2-3: New USB device found, idVendor=046d, idProduct=c534, bcdDevice=29.01
[ 1324.200693] usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1324.200695] usb 2-3: Product: USB Receiver
[ 1324.200697] usb 2-3: Manufacturer: Logitech
[ 1324.203798] logitech-djreceiver 0003:046D:C534.0006: hidraw0: USB HID v1.11 Keyboard [Logitech USB Receiver] on usb-0000:00:14.0-3/input0
[ 1324.265150] logitech-djreceiver 0003:046D:C534.0007: hiddev1,hidraw3: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:14.0-3/input1
[ 1324.322014] logitech-djreceiver: probe of 0003:046D:C534.0007 **failed with error 7**

couldn't find out what error 7 is, too little angles or what?

On stock 5.2.4. it runs perfectly but as I built from linux-zen (where mouse runs normally, too) the zcat .... > .config is the problem; this should overtake the actual kernel configuration, isn't it? I had to correct the UFS-write and debugging support 3 times.

Touchpad works fine, the Unified Logic HID is built and installed, so I really don't know what to do now???

Miranda

Last edited by Neo; 07-30-2019 at 10:19 AM.. Reason: changed quote tags to code tags
# 2  
Old 07-30-2019
Get a mouse which is supported.

Smilie
# 3  
Old 08-14-2019
[SOLVED] witth rc4

It's 5.3-rc4 now and with option LOGITECH_DJ=y mouse does what it should.

Same old story, we're having the ideas and do the basic development of lota, lota, lota firm-, soft- and hardware; we are selling it to closed-source-based-systems - because of a lack of material sourroundigs (that's the reason why I didn't buy a new mouse Smilie - mostly far under the worth of it (!!!) --- after 5 years or so on the market for so(u)c(k) we get it back to make it again compatible with linux and it's probably not a good impression for thoose competitors what our programmers get to see what has been done with the original firmware and drivers, p.E. just look at the gst-plugins!

For me aequivalents are not right, not measurement-question in relation to personal state of programmers but a question of potential of the good. Normally it is a corrupt capitalism withough remorse -

So one hand has the material stuff, others don't believe in; other have their ideals, that ones not able to appreciate; wrong, wrong
Code:
make buildworld -j4

, BSD says and I bet we can wait for good 'til we get the most important thinggs for Haiku from the old BeOS back!
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. Slackware

Replace PS/2 Trackball with USB optical mouse

Running Slackware 13.37 original without updates. Need to replace my trackball with optical mouse temporarily. There is no xf86config file anylonger but xorg.conf file is produced automatically. I see 2 "xorg.conf" files which can be and were modified on installation: 1) /etc/X11/xorg.conf-vesa... (2 Replies)
Discussion started by: slak0
2 Replies

2. Ubuntu

Does /dev/ttyUSB* causing my usb 3G Dongle doesn't work when plug-in

Hi, Is someone knows how or maybe the caused why my USB 3G dongle doesn't work when plug-in after boot the /dev/ttyUSB* I wonder how this /dev/ttyUSB1-4 works, i had a 3G USB dongle for my internet connection before i used lucyd lynx this the same USB dongle works fine when i plug-in after... (2 Replies)
Discussion started by: jao_madn
2 Replies

3. SuSE

USB mouse stops working

I have 64bit 11.1 installed on a clone. The Logitech LX3 mouse stops working sometimes, forcing a reboot. The LED under the mouse goes dark when this happens. A normal ps/2 mouse works fine, and I am certain the LX3 mouse is not defective as I have an identical one on a XP system that I swapped to... (6 Replies)
Discussion started by: stansaraczewski
6 Replies

4. HP-UX

HP-UX 11.11: X doesn't recognize mouse and keyboard

hi folks, i've got a blank hp visualize C3000 workstation and installed HP-UX 11.11. When I want to start X, I get the following error message: # X Fatal server error: Couldn't open X pointer device! Is one attached? I've connected an mouse and a keyboard with an usb/ps2 connector.... (5 Replies)
Discussion started by: grisu
5 Replies

5. UNIX for Dummies Questions & Answers

Script doesn't work, but commands inside work

Howdie everyone... I have a shell script RemoveFiles.sh Inside this file, it only has two commands as below: rm -f ../../reportToday/temp/* rm -f ../../report/* My problem is that when i execute this script, nothing happened. Files remained unremoved. I don't see any error message as it... (2 Replies)
Discussion started by: cheongww
2 Replies

6. UNIX for Dummies Questions & Answers

Mouse can not work in Solaris 10

Dear frends, My mouse in Solaris 10 machine has just failed today. The mouse itself is physically Ok, I can use it in my colleagues' Unix. In my own box, the cursor is just floating in the centre of screen. Any suggestions? Any method to check / modify hardware in solaris 10? thanks! (2 Replies)
Discussion started by: Dunhill_Zhao
2 Replies

7. Solaris

Mouse can not work in Solaris 10

Dear friends, My mouse can not work in my Solaris 10 machine. The mouse itself is OK, i can use it without problems in my colleagues' Unixs. I outstationed for a few weeks, after came back, it can not work already. The cursor will float in the centre of my screen and can never move,... (1 Reply)
Discussion started by: Dunhill_Zhao
1 Replies

8. Slackware

how to activate USB mouse

:confused: I am using Linux for a while and now changed to slackware for my study and it is not as good as redhat everytime when you add this or that it needs either configure modules or recompile kernel Now I changed from PS/2 mouse to USB trouble starts it refuse to work I know I can... (3 Replies)
Discussion started by: slackware
3 Replies

9. UNIX for Dummies Questions & Answers

USB mouse needs reinstalled every time???

Help! My mouse gave up the ghost, so I connected a USB wheel mouse, and chose it from the list in Suse's Yast2. Also installed it in Windows 98 on the same machine. It works fine in both linux and Windows 98, except for this fact: I have to reinstall it every time I boot into Linux.... (1 Reply)
Discussion started by: Sonshyne5
1 Replies
Login or Register to Ask a Question

Featured Tech Videos