SunBlade 150 can't start openwin: /usr/openwin/bin/xinit: Server error.


Login or Register for Dates, Times and to Reply

 
Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers SunBlade 150 can't start openwin: /usr/openwin/bin/xinit: Server error.
# 1  
SunBlade 150 can't start openwin: /usr/openwin/bin/xinit: Server error.

Hi.

I have a Microsystems SunBlade 150

Code:
shell# cat /etc/release
Solaris 8 2/02 s28s_u7wos_08a SPARC

shell# uname -a
SunOS HOSTNAME 5.8 Generic_108528-14 sun4u sparc SUNW,Sun-Blade-100

shell# prtconf -F
/pci@1f,0/SUNW,m64B@13:m640

When I join to the only account the server try to launch de Windows Manager (openwin) but this error show:

Code:
/usr/openwin/bin/xinit: Server error.

I login with root and try to start X Window Manager (openwin) manually using:

Code:
shell# cd /usr/openwin/bin/
shell# ./openwin
VUIDFORMAT: Invalid argument

Fatal server error:
Failed to initialize core devices

/usr/openwin/bin/xinit: Server error

I try this second option manually:

Code:
shell# /usr/openwin/bin/openwin -dev /dev/fb

/usr/openwin/bin/xinit: Connection refused (errno 146): unable to connect to X Server
/usr/openwin/bin/xinit: No such process (errno 3): Server error.

For second option I try to "reinstall Solaris 8" using the "original CD's" but when the CD Boot and I select the language and Keyboard, the system tru to launch a window manager but the same error appear "/usr/openwin/bin/xinit: Server error". So, I can't reinstall all the system to Smilie

Last edited by siegroup; 07-16-2019 at 01:06 PM.. Reason: add more info...
# 2  
What happens when you run:

Code:
/usr/bin/startx

or

Code:
/usr/openwin/bin/startx

?

Or even:

Code:
/usr/openwin/bin/xinit  /usr/openwin/bin/xterm

Please list the entire directory:

Code:
ls -l /usr/openwin/bin/

and

Code:
ls -l /usr/bin/*x*

Thanks.
# 3  
Hmmmmm........sounds like an interesting one. Also, sounds like a hardware issue to me.

The bit of your post that worries me is:
Quote:
For second option I try to "reinstall Solaris 8" using the "original CD's" but when the CD Boot and I select the language and Keyboard, the system tru to launch a window manager but the same error appear "/usr/openwin/bin/xinit: Server error". So, I can't reinstall all the system to Smilie
Windows won't launch unless it can address ALL the devices it uses; graphics card, monitor, keyboard and mouse.

I'd be inclined to power down, unplug and re-plug any all of those devices. I'd be giving the mouse a long hard look.
If you have another system, borrow devices from that one until it will boot from installation media. You don't need to proceed with any re-installation after you've determined what the problem is.
# 4  
Sun's Xserver needs keyboard and mouse connected - otherwise it does not start.
Also the correct graphics driver must be installed. That means it should be included in the imstall image. (If not, install a later OS - the later the OS, the more drivers are included. Solaris 9 or 10 should have it.)
You can install the OS without an Xserver:
Code:
boot cdrom - nowin

and install the graphics driver later.
(BTW the generic graphics drivers are bad - after installation should be updated/patched.)
See also
https://docs.oracle.com/cd/E19253-01...112/index.html
# 5  
Hi @Neo @ hicksd8 and @MadeInGermany thanks for your time and attention.

The problem was the Computer Hardware, because I did many tests with and without keyboard and mouse, and using another keyboard and mouse, but every time the same problem. So yesterday another Computer Hardware arrived, and all works good.

So, in conclution the first Computer Hardware have problems in the USB Ports or Chip Graphics.

I have installed now Solaris 8 Smilie

Taking advantage of the thread ... is there a way to use the autocomplete in Unix? .... within Linux the autocomplete is done with the 'Tab' key.

Last edited by siegroup; 07-18-2019 at 01:52 PM..
This User Gave Thanks to siegroup For This Post:
# 6  
Thanks for the feedback!
This User Gave Thanks to MadeInGermany For This Post:
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #314
Difficulty: Easy
Pointers were not used in the original C programming language and were added later in in C++.
True or False?

9 More Discussions You Might Find Interesting

1. Hardware

seeking QUIET hardware Sparc Solaris 8/Openwin

I have several applications locked to Solaris 8 (and older) and have been very happy with my Sparcs and Ultras but am getting tinnitus problems from fans and disks. Any tips on a quiet thin client (with decent graphics, not video or gaming level but 24bit and multi monitor would be useful) that... (0 Replies)
Discussion started by: batchman
0 Replies

2. Solaris

Why X-server doesn't read /usr/openwin/lib/locale/C/OWfontpath???

Hi all! Solaris 10. Why did X-server stop to read OWfontpath? Any suggestions. Thanks. (0 Replies)
Discussion started by: wolfgang
0 Replies

3. Solaris

TTY Issue with Sunblade 150

I purchased a Sunblade 150 from Ebay. It had 512MB RAM and 80GB hard disk. I recently purchased additional RAM and another 80GB disk, and installed them. The RAM goes through POST without issues. I just can't get beyond the OK prompt. I am using the serial console. I have been unable to... (5 Replies)
Discussion started by: Geekasaurus
5 Replies

4. UNIX for Dummies Questions & Answers

openwin use old serial mouse

Solaris 10 on an Ultra 45, there are two serial ports (com A and B) And I need to be able to use an old serial trackball mouse in the openwin dt enviornment. Do I have any options? Even if I have to buy an external device for conversion? Want to configure openwin to use an old serial pointer device... (0 Replies)
Discussion started by: ajp7701
0 Replies

5. UNIX for Dummies Questions & Answers

OpenWin error

I have a client who is using Solaris 8 and on login the system tris to open windows but then generates the following error failed to open /usr/openwin/AcceleratedX/etc/Siteinfo Fatal Server error Failed to configure the xserver Help Please! Thanks (0 Replies)
Discussion started by: alvinc77
0 Replies

6. Solaris

Can SunBlade 150 support 2 x 160GB hard disk

Hi all, I am a newbies here, Have question regards large hard disk install in SunBlade system. Can SunBlade 150 support 2 x 160GB (internal IDE) ? Want to make sure before buy the hard disks. Anyone had experiences configure large hard disk in SunBlade 150 before ? In the SunBlade 150... (2 Replies)
Discussion started by: ong.kianseng
2 Replies

7. Post Here to Contact Site Administrators and Moderators

/usr/openwin/bin/xinit: unable to connect to Xserver

Hi Gents, I have downloaded Sol 8 2/04 from Sun's web page and I have tried to install it into a V890. I can boot from a CD 1of 2 without any problem. After the selection of the language and the Locale, the TWM (Sol Install Console window) cannot starts up. The following are the errors... (0 Replies)
Discussion started by: mmakhol
0 Replies

8. UNIX for Dummies Questions & Answers

OpenWin Locked up

I have a server that is on solaris 9 and openwin is locked. The mouse won't respond and I can't seem to kill the openwin pid on the server.. Is there a command line to kill openwin from the server side? (2 Replies)
Discussion started by: jphorton
2 Replies

9. UNIX for Dummies Questions & Answers

Openwin Error

1.I was trying to use Exceed to run Solaris "openwin" on my Windows 95. I got an error : /usr/openwin/bin/openwin & 28522 $ /dev/fb: No such file or directory Graphics Adapter device /dev/fb is of unknown type Fatal server error: InitOutput: Error loading module for /dev/fb Does... (1 Reply)
Discussion started by: b5fnpct
1 Replies

Featured Tech Videos