Today (Saturday) We will make some minor tuning adjustments to MySQL.

You may experience 2 up to 10 seconds "glitch time" when we restart MySQL. We expect to make these adjustments around 1AM Eastern Daylight Saving Time (EDT) US.


Installing tmux on RHEL 6.5


Login or Register to Reply

 
Thread Tools Search this Thread
# 1  
Installing tmux on RHEL 6.5

Hi,
I am trying to install tmux on vm allocated to me in my company . i am very new to linux. I have the root access on it.

Can someone please provide the exact steps to get it installed.
I tried:
1. Using yum, i get the below message.

# yum install tmux
Loaded plugins: security
Error: Cannot retrieve repository metadata (repomd.xml) for repository: epel. Please verify its path and try again
[1]+ Terminated yum install tmx


2. Copying the tmux from git.

I have copied the tmux-master to the server , but don't what to do with it.


I have heard great reviews from few developers, i want to use it but stuck now Smilie
# 2  
Code:
cd /tmp
git clone https://github.com/tmux/tmux.git
cd tmux
sh autogen.sh
./configure && make

This User Gave Thanks to Neo For This Post:
# 3  
Thanks for the reply. I tried again and was able to install but getting this error:

# tmux
tmux: error while loading shared libraries: libevent-2.1.so.6: cannot open shared object file: No such file or directory

I installed tmux-2.9 and libevent-2.1.10-stable
The file is there , not sure why getting this error

# find . -name "libevent-2.1.so.6"
./lib/libevent-2.1.so.6

If you suggest me opening a new thread , i can do , no problem.
Appreicate your help
# 4  
You have to do a clean configure and make after you install the dependent libs.
# 5  
getting this error:
Code:
# git clone GitHub - tmux/tmux: tmux source code
Initialized empty Git repository in /tmp/tmux/.git/

Code:
error: Failed connect to github.com:443; Operation now in progress while accessing https://github.com/tmux/tmux.git/info/refs

fatal: HTTP request failed

How to work around this issue?

--- Post updated at 04:01 PM ---

I did the tarbar download and followed the steps you gave and getting the below error:

Code:
[tmux-master]# ./configure && make
...
configure: error: "libevent not found"

# 6  
fixed the issue by creating an alias.

Code:
https://unix.stackexchange.com/questions/17907/why-cant-gcc-find-libevent-when-building-tmux-from-source/17918

# 7  
Great to hear you got it working.

Thanks for posting back your solution.
Login or Register to Reply

|
Thread Tools Search this Thread
Search this Thread:
Advanced Search

More UNIX and Linux Forum Topics You Might Find Helpful
Installing RHEL over Windows 7 or 8
rhopson
Hi, Sorry if this is an incorrect place for this question but I haven't been able to find any answers by searching the forums or on google. I am in the market for a new HP Z420 workstation and HP wants a lot more money for one with the HP Linux Installer kit vs. the exact same configuration in...... Red Hat
2
Red Hat
Error throwing while installing vsftpd package in rhel 6. using rhel 6 dvd.
redhatlbug
Hi all, Im studying rhcsa as of now, so yum installation and dependencies are messing me to not workit out. i have dual os, win 7 & rhel 6. i have tried this installation of vsftpd package with rhel 6 dvd in VM rhel 6 in win 7 as well as host rhel 6.still the same issue. below error...... Red Hat
6
Red Hat
Problem installing PSP on rhel 5.2 64
pabloli150
hi, i have a problem when i try to install Proliant support pack into a server with rhel 5.2 sv556:#/tmp/psp# ./hpsum -silent ./hpsum: error while loading shared libraries: libfreetype.so.6: cannot open shared object file: No such file or directory i have already installed library...... Red Hat
3
Red Hat
problem installing rhel 6
shamapraveen
I have dexx xps 14.I was installing rhel6.But the installation hanged at following step initializing hardware detection................. installion didnt go further... Red Hat
2
Red Hat
Bug hits while installing RHEL 5.5
fugitive
I have one R710 Dell Box, when i try to install the RHEL on the system the installation stops with following error "Assertion (heads < 256) at disk_dos.c:486 in function probe_partition_for_geom() failed." I 'm unable to ignore/cancel the same and have hard boot the server. ...... Red Hat
0
Red Hat

Featured Tech Videos