Visit The New, Modern Unix Linux Community


Compiling automake-1.15 in Solaris 10 SPARC


 
Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers Compiling automake-1.15 in Solaris 10 SPARC
# 1  
Compiling automake-1.15 in Solaris 10 SPARC

Hi there.


I have unzipped automake-1.15.tar.gz into a directory on my HDD that has Solaris 10 SPARC OS installed inside a SUN/Oracle SPARC server.
I can configure automake-1.15 successfully but when I try to compile automake-1.15 using 'make command, I have the following error message..


Code:
 # gmake 

"/export/home/Repo/automake-1.15/t/wrap/aclocal-1.15" 
Can't locate /export/home/Repo/automake-1.15/bin/aclocal in @INC (@INC contains: /usr/perl5/5.8.4/lib/sun4-solaris-64int /usr/perl5/5.8.4/lib /usr/perl5/site_perl/5.8.4/sun4-solaris-64int /usr/perl5/site_perl/5.8.4 /usr/perl5/site_perl /usr/perl5/vendor_perl/5.8.4/sun4-solaris-64int /usr/perl5/vendor_perl/5.8.4 /usr/perl5/vendor_perl .) at /export/home/Repo/automake-1.15/t/wrap/aclocal-1.15 line 29.
gmake: *** [aclocal.m4] Error 2


I dont know how to resolve this problem. What shall I do next?



thanks
# 2  
Code:
"/export/home/Repo/automake-1.15/t/wrap/aclocal-1.15"

Code:
Can't locate /export/home/Repo/automake-1.15/bin/aclocal in @INC

Code:
(@INC contains: 
/usr/perl5/5.8.4/lib/sun4-solaris-64int 
/usr/perl5/5.8.4/lib
/usr/perl5/site_perl/5.8.4/sun4-solaris-64int 
/usr/perl5/site_perl/5.8.4 /usr/perl5/site_perl 
/usr/perl5/vendor_perl/5.8.4/sun4-solaris-64int
 /usr/perl5/vendor_perl/5.8.4 /usr/perl5/vendor_perl .) 
at /export/home/Repo/automake-1.15/t/wrap/aclocal-1.15 line 29.


Seems like you might be missing /export/home/Repo/automake-1.15/bin/aclocal in your list of included directories.

Is that how you read the error message?
# 3  
I have tried to research this and I do know that @INC has something to so with PERL5 . But I dont know what I should do next.

I do have Perl584 installed as standard on Solaris 10 SPARC OS, I know that but how do I include the directory


/export/home/Repo/automake-1.15/bin/aclocal
into @INC. I am stuck
# 4  
I have also tried to add the following line into the file ../export/home/Repo/automake-1.15/t/wrap/aclocal-1.15
after the BEGIN statement


Code:
push (@INC,'/export/home/Repo/automake-1.15/bin');

but It still doesnt succeed. I get the following error


Code:
(@INC contains:  /usr/perl5/5.8.4/lib/sun4-solaris-64int

Code:
 /usr/perl5/5.8.4/lib

Code:
 /usr/perl5/site_perl/5.8.4/sun4-solaris-64int

Code:
 /usr/perl5/site_perl/5.8.4

Code:
 /usr/perl5/site_perl

Code:
 /usr/perl5/vendor_perl/5.8.4/sun4-solaris-64int

Code:
 /usr/perl5/vendor_perl/5.8.4

Code:
 /usr/perl5/vendor_perl .
 /export/home/Repo/automake-1.15/bin/)  at /export/home/Repo/automake-1.15/t/wrap/aclocal-1.15 line 29.

What else can I do?
# 5  
OK I found out that for some reason the ./configure process did not write the files aclocal and automake to the ./bin/ directory Smilie
I had to edit the aclocal.in and automake.in files so the gmake compiler would pick up the aclocal file.


The gmake compiler has now done this successfully and has also picked up the modules in director./lib/Automake/ successfully. However now I have come across another problem on my terminal. Here it is

Code:
CDPATH="${ZSH_VERSION+.}:" && "/export/home/Repo/automake-1.15/t/wrap/aclocal-1.15" 
called too early to check prototype at /export/home/Repo/automake-1.15/bin/aclocal line 525
'@am_AUTOM4TE@: not found
 gmake: *** [aclocal.m4] Error 1

What do I do next. Is it worth me uploading my aclocal file here for examination?

--- Post updated at 02:03 PM ---

By the way my system has Perl5.8.7 installed into /usr/local/ (an upgrade from perl5.8.4 installed as Standard by Solaris 10 SPARC OS during Solaris 10 installation.
This User Gave Thanks to alphatron150 For This Post:

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #947
Difficulty: Medium
Malware a portmanteau for malicious hardware.
True or False?

8 More Discussions You Might Find Interesting

1. Solaris

How to read this Solaris version:-Solaris 8 HW 5/03 s28s_hw2wos_06a SPARC?

Hi Guys, Could you please tell me how to read this Solaris version:- Solaris 8 HW 5/03 s28s_hw2wos_06a SPARC Thanks. (3 Replies)
Discussion started by: manalisharmabe
3 Replies

2. UNIX for Dummies Questions & Answers

can I emulate solaris/sparc on virtualbox? Or other emulator to run solaris for sparc in my win7 PC?

Hi Gurus can I emulate solaris/sparc on virtualbox? Or other emulator to run solaris for sparc in my win7 PC? regards, Israel. (9 Replies)
Discussion started by: iga3725
9 Replies

3. Infrastructure Monitoring

compiling netsnmp on solaris 8

Hello all Currently I am trying to install net-snmp-5.5 on a V480 Solaris 8 machine however things are hardly going smooth. I'm running configure will the following options. ./configure --prefix=/usr/local --with-mib-modules="smux ucd-snmp/diskio ucd-snmp/lmSensors host"... (2 Replies)
Discussion started by: krabu
2 Replies

4. Solaris

compiling Seamonkey 1.1.9 on Solaris 9 sparc

I have gotten tired of getting error messages from SeaMonkey about not being on the latest version. I have downloaded the source for SeaMonkey, and when I attempt to make it with "gmake -f client.mk build" , I get the following error message: configure: error: Library requirements (pango... (0 Replies)
Discussion started by: tderscheid
0 Replies

5. Programming

Compiling in Solaris

Hi, I'm new to Unix. I'm trying to compile a shared library in Solaris running on x86. I get "void value not ignored as it ought to be" error when trying "make". But it compiles fine in Fedora. How can this happen? I think both are using the same type of compiler. What can I do to get around... (8 Replies)
Discussion started by: runnerb
8 Replies

6. UNIX for Dummies Questions & Answers

Running Solaris Sparc Apps on X86 Solaris

I know that Sun make s a version of Solaris for Sparc platforms and also an x86 (Intel/AMD) release of Solaris. Can an application that runs on Solaris/Sparc also run on a PC running the x86 release of Solaris? Would a different release be required or any re-compling of the application? jim (1 Reply)
Discussion started by: stocksj
1 Replies

7. UNIX for Advanced & Expert Users

Solaris 7 Sparc 5

08-11-2005, 03:23 PM I posted the below thread in UNIX for dummies Questions and Answers. I thank the guy who posted a proposition to resolve my problem. I decided to repost the problem here. Who knows :) So, here it goes: Since a week ago I put myself many troubles. I decide to... (6 Replies)
Discussion started by: kisoun
6 Replies

8. UNIX for Dummies Questions & Answers

Solaris 7 Sparc 5

First of all, I want to salute everybody. Since a week ago I put myself many troubles. :) I decide to install Solaris 7, in a sun sparcstation 5, with raid5. And I don't know almost anything about unix systems, not only Solaris. :) I want to install mysql, apache, php4. I'm not... (4 Replies)
Discussion started by: kisoun
4 Replies

Featured Tech Videos