Sub-folder in share disappears when mounting to other server

Login or Register for Dates, Times and to Reply

Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers Sub-folder in share disappears when mounting to other server
# 8  
I think this might be a limitation of Solaris that doesn't allow you to cascade NFS mounts.

Some Linux versions implement a crossmnt option in /etc/exports to specifically allow this kind of 'route through' of NFS mounts.

I'm still thinking about this one.
# 9  
Have you considered using solaris cluster on server 1 and server 2 with VIP address ?
Do you have shared storage (FC, ISCSI ?)

If i correctly understood your problems / story, i would suggest back to the drawing board...

Is this what are you trying to do :

        |            |
        |   SERVER1  |
        |            |
        |/nfs/share1 ---------------*
        *------------*              |
                                    |   *---------------------------------------*
                                    |   |                                       |
                                    |   |       SERVER 3                        |
                                    |   |                                       |
                                    *--->server1:/nfs/shareX/share1 [nfs mount] |
                                *------->server2:/nfs/shareX/share2 [nfs mount] |
                                |       |/nfs/shareX/[nfs export]------------------->-->--> [various number of nfs clients]
                                |       |                                       |
                                |       *---------------------------------------*
        *------------*          |
        |            |          |
        |   SERVER2  |          |
        |            |          |
        |/nfs/share2 -----------*

These 2 Users Gave Thanks to Peasant For This Post:
# 10  
@Peasant: Yes, that's what i'm looking for!
What's the advantage of solaris cluster?
No shared storage.

@hicksd8: there's no file/folder /etc/exports

For info: the data on server 1 and 2 are all temporary images (between 25.000 and 50.000 / day - .tiff, .eps or .ps files) and will be deleted after +/- 14 days, so no need to make it complicated and no need for backups. Smilie
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #567
Difficulty: Medium
The ternary if-then-else operator generally has the following syntax: E ? X : Y where E is a Boolean expression and if true, the statement is assigned the value Y.
True or False?

10 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

Mounting a samba share

Hi, I need to mount a directory from a Windows server to a CentOS box. The Windows server used is Windows Server 2003, and the path to the directory that I want to mount on CentOS is C:\Tomcat6\webapps\NASApp\logs. I am not sure of the correct way to mount this on CentOS, as most of the... (2 Replies)
Discussion started by: anaigini45
2 Replies

2. UNIX for Beginners Questions & Answers

Mounting Windows Share to Linux Server

Hi Folks - I need to mount a Windows Share to a Linux server. What is the best/easiest way to do this? Is this 'how-to' guide accurate: How to Share Files Between Windows and Linux Or is there a better method you could share? Thanks! (8 Replies)
Discussion started by: SIMMS7400
8 Replies

3. Solaris

Mounting 2012R2 NFS Share on Solaris 10

Hi all, new here. I'm attempting to mount an NFS share I've created on a 2012r2 esx VM on my solaris 10 vm, I'm using the following command: mount 2012box:/sharename /mnt and I get the following result: nfs mount: mount: /mnt: Operation not supported Both vms can ping one... (3 Replies)
Discussion started by: Meshuggener
3 Replies

4. UNIX for Dummies Questions & Answers

[Solved] error while mounting windows share on linux

Hi whan i am trying to mount a windows share on linux i received the following error can some one help me with thsi # mount -t cifs \\\\servername\testdata -o username=xw27,password=*es*feed /test Mounting the DFS root for a particular server not implemented yet No ip address specified... (5 Replies)
Discussion started by: robo
5 Replies

5. Solaris

mounting windows share folder

please help me,,i need step to mount windows share folder,,i try samba and nfs and it didnt work (in my linux server the command is fine),,can somenone give me an example for this to be done? (0 Replies)
Discussion started by: Cellscript
0 Replies

6. IP Networking

Problem Mounting NFS share

I have one machine "The server" ip:, it runs ubu 8.04(LTS) and - I have a folder (/shareme) that I want to share with other linux machines on my LAN. - The server runs NFS server and common and portmap and so do the other machines on my LAN. - The server has the export file with the... (2 Replies)
Discussion started by: fcron
2 Replies

7. UNIX for Advanced & Expert Users

Help mounting Windows share in UNIX

We recently upgraded one of our engineering servers, and now the lone UNIX box that houses older CAD files can not connect to it. I have tried every variation of mount I can find, but to no avail. Help is appreciated. Here are the specs: Server: Windows 2003 x64 with Unix Services for Windows... (8 Replies)
Discussion started by: shatterstorm
8 Replies

8. UNIX for Dummies Questions & Answers

Mounting an NFS share: Kickstart Postinstall

For my kickstart install I use an NFS share on another machine in order to install the packages. For the most part, all configuration required after each time I reimage is set up in the kickstart file, but this one portion is giving me issues. I'm trying to mount an NFS share in the kickstart post... (0 Replies)
Discussion started by: Colton
0 Replies

9. Solaris

Mounting CIFS share

Is it possible to mount a samba share on a solaris system? I know this is possible with Linux using a fstype of smbfs. I am trying to aviod having to share the same directories via cifs and nfs on a solaris box to windows and solaris clients. (3 Replies)
Discussion started by: mhm4
3 Replies

10. Windows & DOS: Issues & Discussions

Mounting a windows share on AIX

Hi, How can I mount a Windows share (over samba) on an AIX machine? I know there is a utility called smbmount on Linux, but alas, I cannot find out how to the same thing on AIX. anyone have any ideas? thanks! (3 Replies)
Discussion started by: szahir1
3 Replies

Featured Tech Videos