Visit Our UNIX and Linux User Community


How to install older package version on Ubuntu 18.04?


 
Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers How to install older package version on Ubuntu 18.04?
# 1  
Old 03-27-2019
How to install older package version on Ubuntu 18.04?

Hello, I'm running Ubuntu 18.04 and I would like to install libboost-python version 1.46. Currently I have installed version 1.65:
Code:
wakatana@local-machine:~$ dpkg -l | grep libboost-python
ii  libboost-python-dev                        1.65.1.0ubuntu1                              amd64        Boost.Python Library development files (default version)
ii  libboost-python1.65-dev                    1.65.1+dfsg-0ubuntu5                         amd64        Boost.Python Library development files
ii  libboost-python1.65.1                      1.65.1+dfsg-0ubuntu5                         amd64        Boost.Python Library

If I search for available libboost-python packages there is 1.46 version available:
Code:
wakatana@local-machine:~$ apt-cache policy libboost-python*
libboost-python1.58-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
libboost-python1.62-dev:
  Installed: (none)
  Candidate: 1.62.0+dfsg-5
  Version table:
     1.62.0+dfsg-5 500
        500 http://sk.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
libboost-python1.60-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
libboost-python1.54-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
libboost-python1.48-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
libboost-python1.52-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
libboost-python1.46-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
libboost-python1.50-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
libboost-python1.42-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
libboost-python1.65-dev:
  Installed: 1.65.1+dfsg-0ubuntu5
  Candidate: 1.65.1+dfsg-0ubuntu5
  Version table:
 *** 1.65.1+dfsg-0ubuntu5 500
        500 http://sk.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libboost-python1.63-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
libboost-python1.57-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
libboost-python1.61-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
libboost-python1.55-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
libboost-python1.49-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
libboost-python1.53-dev:
  Installed: (none)
  Candidate: (none)
  Version table:
libboost-python-dev:
  Installed: 1.65.1.0ubuntu1
  Candidate: 1.65.1.0ubuntu1
  Version table:
 *** 1.65.1.0ubuntu1 500
        500 http://sk.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
libboost-python1.62.0:
  Installed: (none)
  Candidate: 1.62.0+dfsg-5
  Version table:
     1.62.0+dfsg-5 500
        500 http://sk.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
libboost-python1.65.1:
  Installed: 1.65.1+dfsg-0ubuntu5
  Candidate: 1.65.1+dfsg-0ubuntu5
  Version table:
 *** 1.65.1+dfsg-0ubuntu5 500
        500 http://sk.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status
 ###############################################################
wakatana@local-machine:~$ apt-cache policy libboost-python-dev
libboost-python-dev:
  Installed: 1.65.1.0ubuntu1
  Candidate: 1.65.1.0ubuntu1
  Version table:
 *** 1.65.1.0ubuntu1 500
        500 http://sk.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
        100 /var/lib/dpkg/status

wakatana@local-machine:~$ apt-cache madison libboost-python-dev
libboost-python-dev | 1.65.1.0ubuntu1 | http://sk.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages
 ###############################################################
wakatana@local-machine:~$ apt-cache search libboost-python-dev
libboost-python-dev - Boost.Python Library development files (default version)
wakatana@local-machine:~$ apt list libboost-python-dev
Listing... Done
libboost-python-dev/bionic,now 1.65.1.0ubuntu1 amd64 [installed,automatic]
 ###############################################################
wakatana@local-machine:~$ apt search libboost-python-dev
Sorting... Done
Full Text Search... Done
libboost-python-dev/bionic,now 1.65.1.0ubuntu1 amd64 [installed,automatic]
  Boost.Python Library development files (default version)

Problem is that I'm unable to install older version. I've tried various ways:
Code:
sudo apt-get install libboost-python=1.46-dev
sudo apt-get install libboost-python1.46-dev
sudo apt-get install libboost-python1-dev=1.46
sudo apt-get install libboost-python1-dev=1.46-dev
sudo apt-get install libboost-python-dev=1.46
sudo apt install libboost-python=1.46-dev
sudo apt install libboost-python1.46-dev
sudo apt install libboost-python1.46-dev:
sudo apt install libboost-python1-dev=1.46
sudo apt install libboost-python-dev=1.46
sudo apt install libboost-python-dev=1.46-dev

But with no luck:
Code:
wakatana@local-machine:~$ sudo apt-get install libboost-python=1.46-dev
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package libboost-python
###############################################################
wakatana@local-machine:~$ sudo apt-get install libboost-python1.46-dev
Reading package lists...
Building dependency tree...
Reading state information...
Package libboost-python1.46-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libboost-python1.46-dev' has no installation candidate
###############################################################
wakatana@local-machine:~$ sudo apt-get install libboost-python1-dev=1.46
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package libboost-python1-dev
###############################################################
wakatana@local-machine:~$ sudo apt-get install libboost-python1-dev=1.46-dev
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package libboost-python1-dev
###############################################################
wakatana@local-machine:~$ sudo apt-get install libboost-python-dev=1.46
Reading package lists...
Building dependency tree...
Reading state information...
E: Version '1.46' for 'libboost-python-dev' was not found
###############################################################
wakatana@local-machine:~$ sudo apt install libboost-python=1.46-dev
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package libboost-python
###############################################################
wakatana@local-machine:~$ sudo apt install libboost-python1.46-dev
Reading package lists...
Building dependency tree...
Reading state information...
Package libboost-python1.46-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libboost-python1.46-dev' has no installation candidate
###############################################################
wakatana@local-machine:~$ sudo apt install libboost-python1.46-dev
Reading package lists...
Building dependency tree...
Reading state information...
Package libboost-python1.46-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libboost-python1.46-dev' has no installation candidate
###############################################################
wakatana@local-machine:~$ sudo apt install libboost-python1-dev=1.46
Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package libboost-python1-dev
###############################################################
wakatana@local-machine:~$ sudo apt install libboost-python-dev=1.46
Reading package lists...
Building dependency tree...
Reading state information...
E: Version '1.46' for 'libboost-python-dev' was not found
###############################################################
wakatana@local-machine:~$ sudo apt install libboost-python-dev=1.46-dev
Reading package lists...
Building dependency tree...
Reading state information...
E: Version '1.46-dev' for 'libboost-python-dev' was not found
###############################################################

I guess following format is OK because it prints the message that libboost is already installed
Code:
wakatana@local-machine:~$  sudo apt install libboost-python-dev=1.65.1.0ubuntu1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libboost-python-dev is already the newest version (1.65.1.0ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

But 1.46 equivalent did not worked for me:
Code:
wakatana@local-machine:~$ sudo apt install libboost-python-dev=1.46.1.0ubuntu1
Reading package lists...
Building dependency tree...
Reading state information...
E: Version '1.46.1.0ubuntu1' for 'libboost-python-dev' was not found
###############################################################
wakatana@local-machine:~$ sudo apt install libboost-python-dev=1.46.0.0ubuntu1
Reading package lists...
Building dependency tree...
Reading state information...
E: Version '1.46.0.0ubuntu1' for 'libboost-python-dev' was not found
###############################################################
wakatana@local-machine:~$ sudo apt install libboost-python-dev=1.46.0ubuntu1
Reading package lists...
Building dependency tree...
Reading state information...
E: Version '1.46.0ubuntu1' for 'libboost-python-dev' was not found
###############################################################

I was also searching for *.deb package to install it using
Code:
dpkg -i

but I've not found version 1.46 on those sites
Ubuntu - Package Search Results -- libboost-python
Search Ubuntu's packages : Ubuntu

How can I install version 1.46 and do not break existing package manager configuration?
Why there is no version 1.46 on mentioned sites?
Thanks
# 2  
Old 03-27-2019
See this page for complete instructions:

Boost Getting Started on Unix Variants - 1.46.1
This User Gave Thanks to Neo For This Post:

Previous Thread | Next Thread
Test Your Knowledge in Computers #301
Difficulty: Easy
Slackware was originally derived from the Software Linux System (SLS).
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

Global zone has an older version of package: pkg://Solaris/system/library

I try to install php-56 in a zone, but I have the following problem: pkg install php-56 Creating Plan (Running solver): \ pkg install: No solution was found to satisfy constraints maintained incorporations: None Creation Plan: dependency error (s) in proposed packages: Not... (0 Replies)
Discussion started by: ymk369
0 Replies

2. Ubuntu

Install and configure ntp rpm on Ubuntu 13.10 version

Hello, I am new to ubuntu Server OS and so trying to setup and ntp service on couple of servers. I see ntp rpm is not installed. # dpkg --get-selections | grep -v deinstall | grep ntp ntpdate install # so I tried to installed ntp rpm using... (5 Replies)
Discussion started by: bobby320
5 Replies

3. Ubuntu

Installation of older version of rsyslog

Hi, I am trying to downgrade the version of rsyslog to the older version (i.e) and when i issue the below command to check the packages i dont see the required package (i.e) and when i try to install it is complaining about package not found. Please advise on how to install the... (1 Reply)
Discussion started by: prash358
1 Replies

4. UNIX for Dummies Questions & Answers

Can't install rpm package with --prefix in new path.Error: package is not relocatable

Hello, i have downloaded an rpm package "hadoop-0.20.205.0-1.amd64.rpm" in /usr/local/ directory. I'm trying to install the rpm package in a new path/location (/usr/local/hadoop-0.20.205), but i can't. I did: 1st try: Didn't work sudo rpm -i --prefix=/usr/local/hadoop-0.20.205... (1 Reply)
Discussion started by: g_p
1 Replies

5. Linux

How install a new package without remove old package?

Dear all, I would like to install a new version of package without remove old version on Centos and vice versa. Please give me advice! thanks much, (2 Replies)
Discussion started by: all4cfa
2 Replies

6. Ubuntu

How to Install TCSH package in Ubuntu 11?

I am trying to install tcsh package in ubuntu 11 When i tried to invoke the tcsh,i was prompted to contact administrator to install tcsh package. Since i am also the admin on my system its my job to install tcsh :D I have downloaded tcsh package named "tcsh-6.17.00.tar", since i don not have... (12 Replies)
Discussion started by: animesharma
12 Replies

7. Shell Programming and Scripting

For loop in older version of ksh

When I am trying to use below code of for loop on older version of ksh it not working,and I just want to use only FOR loop ----------------- for i in (1..5) do echo $i done ----------------- please suggest.it really stoping me. FYI: i want to do this only by for loop (2 Replies)
Discussion started by: RahulJoshi
2 Replies

8. Ubuntu

unable to install package on Ubuntu

Hi all, I am working on Ubuntu 7.10 and I want to install libssl-dev_0.9.8a-7ubuntu0.13_i386.deb. So tryied it with apt-get command but getting the following error-- Then I downloaded .deb file and attempt to install it with package installer but again unable to install it and getting the... (3 Replies)
Discussion started by: smartgupta
3 Replies

9. UNIX for Dummies Questions & Answers

Would like to install x86 desktop Ubuntu over AMD64 Ubuntu server

My intention was to build a dual boot XP Pro 64 and Ubuntu media server. I had installed the AMD64 version of Ubuntu 8.10 server and thought that I would be able to install Apache server. I need a GUI to work in. I tried to boot and install Mythbuntu 32 bit 8.10, but my machine now won't recognize... (0 Replies)
Discussion started by: docflyboy
0 Replies

10. UNIX for Dummies Questions & Answers

.profile has been replaced and need to get the older version

Hi All, .profile has been replaced with a new one. I need to know the variables used in the older version of .profile. I have a session opened using the old .profile. Is there a way that I can get the exact file. I had some luck by using set command. But is there any way that I can get the... (5 Replies)
Discussion started by: shash
5 Replies

Featured Tech Videos