BMW GT1 DIS - SCO 5.0 and Oracle 7 Root HDD Clone - IBM T30

Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers BMW GT1 DIS - SCO 5.0 and Oracle 7 Root HDD Clone - IBM T30
# 1  
Old 03-10-2019
BMW GT1 DIS - SCO 5.0 and Oracle 7 Root HDD Clone - IBM T30

Greeting All
Diag tool HDD clone SCO 5 + Oracle 7 DB ( IBM T30 )

I am new to this forum and my knowledge on computers OS is average .

I have just acquired a factory diag tool for BMW/RR/MINI from a retired mechanic. Its runs on a IBM T30 laptop with a Unix/Oracle DB system. Sco 5 Unix and Oracle 7DB.

The tool is working find and since he did not have the original DVD , I am wondering if it is possible to clone the internal HDD so I can have a safe copy incase it gets damaged.

I pulled out the HDD and its is a 60GB disc. Attach the pic and below link of the start up and shutdown process i just loaded . ( Under youtube search BMW Software GT1 Startup )

Any pointers on what is possible would be much appreciated.

# 2  
Old 03-10-2019
Well if you find the exact same hard disk, and find any means to plug it onto your T70 you may use the dd utility to make an exact copy ... it works also if the disk is bigger only you loose the difference...
This User Gave Thanks to vbe For This Post:
# 3  
Old 03-10-2019
Thanks VBE for the quick reply . The issue is there is no way to get to command line during the startup or shutdown process. To startup all you do is power the IBM T30 laptop with all interface connected and it goes thru the SCO and Oracle 7 startup and the BMW GT1 menu appears. To shutdown all you do is once you end all diagnostic back to Main menu , you enter Ctrl+Alt+F1 and type "shut" at the logon promot. It then goes thru the shutdown process and powers off the T30.

Is there a way to safely interrupt the startup and go into single user mode and do a DD command. There is no time the system even goes to command line .

# 4  
Old 03-11-2019
I don't know the IBM T30 nor the SW system (SCO / Oracle 7) you have in front of you, but any *nix system allows for booting into "single mode" which is a root terminal session. Early in the boot process it offers a menu option, or a key (combination) must be pressed, to get there.
You could try to boot from another medium, "live" CD, or USB stick.
You could perform a "discectomy" (surgically remove) the HD and connect it as a secondary device to another computer, and do the copy there.

Last edited by RudiC; 03-11-2019 at 10:56 AM..
This User Gave Thanks to RudiC For This Post:
# 5  
Old 03-11-2019
There are several issues you will have to deal with.
The first: do you have the root password? you will not be able to start the machine in single user mode without it.
Second: this machine has an IDE hard drive which will be difficult to replace.
Third: what is the actual release of SCO? The release number should be 5.0.? where ? is probably 5 through 7.

This manual may help
This User Gave Thanks to jgt For This Post:
# 6  
Old 03-11-2019
Originally Posted by RudiC
You could try to boot from another medium, "live" CD, or USB stick.
You could perform a "discectomy" (surgically remove) the HD and connect it as a secondary device to another computer, and do the copy there.
This is what i was also thinking i.e boot a Ubuntu 16.04LTS USB stick on another laptop computer with both drives connected ( current T30 IDE 60GB and new IDE Drive ).

I assume you must used same controller type i.e IDE on the other computer and not USB slots with old and drive attached ? or does it matter. ? I have a HP laptop with 4 usb port. ( I will get some enclosures and cables to house this IDE HDD)

I will give this a go if its possible using Ubuntu DD cmd to disc copy the SCO 5.0.5/Oracle 7 HDD.

Last edited by RudiC; 03-12-2019 at 03:51 AM..
# 7  
Old 03-12-2019
The good news is that you can replace the IDE disk with a SATA disk or SSD. The bad news; neither is likely to fit in the T30 case.
It has occurred to me that your notebook is not the original hardware for the following reasons:
SCO 5.0.5 was superseded by 5.0.6 prior to 1999, and 5.0.5 does not reliably run on pentium 4 systems.
You can switch to a SATA drive, as long as the motherboard bios supports the drive in legacy mode (emulating an iDE controller.)
This User Gave Thanks to jgt For This Post:
Login or Register to Ask a Question

Previous Thread | Next Thread

8 More Discussions You Might Find Interesting

1. AIX

IBM AIX Internal HDD vs SAN HDD and Oracle

Hi Folks, I am facing an issue with the performance. P4 with 1 processor and 16 GB RAM and SAN HDD = Oracle report takes 25 minutes P5 with 2 processors and 16 GB RAM internall HDD with LPAR = Oracle Report takes 1 hour 15 minutes ( please note I have assigned all the max processors and... (7 Replies)
Discussion started by: filosophizer
7 Replies

2. SCO

Dd (raw) image of SCO 5.0.6 mount as second hdd

Hi all I have read about mounting crashed HDD from a sco system in this forum. However this I received an image on raw format of the crashed system that was using an IDE HDD. Which method should I mount my image? IDE scsi or USB? The image is stores in an external connected through USB . Also... (4 Replies)
Discussion started by: OrangeKenny
4 Replies

3. HP-UX

How to clone a 382-workstations hdd?

Hi there, I got a pretty old HP 382 workstation, and the hdd is pretty LOUD ... ;) So I thought I clone it to an much quiter one. I tried this: - removed the loud hdd - connected it to an system running knoppix 7.0.4 (hdd is recognized with UFS filesystem; Clonezilla couldn't handle the... (9 Replies)
Discussion started by: pelegrine
9 Replies

4. Ubuntu

Can't successfully clone an HDD in Ubuntu, please help

Hi guys, I am total newbie to Linux / Ubuntu but trying it to solve the problem I have. I have an OKI printer with bad HDD and trying to clone one from the same HDD from working printer. Board it goes on has a Fiery chipset and system used is Linux based / related - to the best of my knowlege. I... (12 Replies)
Discussion started by: Unlimitedbt
12 Replies

5. SCO

Sco 5.06 How To Mount A 2nd Hdd Help Help!!!!

Hi guys, I have this problem , One of our client's hdd went down and we cannot boot up the machine , I've installed a new hdd with a fresh copy of SCO 5.0.6 same as the one in the old HDD, i think the data still good in the old HDD. My question!!! How can i access the data from the fresh... (4 Replies)
Discussion started by: josramon
4 Replies

6. UNIX for Advanced & Expert Users

SCO 5.0.5 installation on 80GB HDD

Hello, I have a P4, 2.4GHz, 256MB ASROCK mainboard: I am trying to install sco 5.0.5 on an 80gb hdd IDE . I have tried the following techniques: 1. using the updated wd btld image- no success 2. defbootstr biosgeom 3. use interactive divvy, make adjustments using dkinit/dparam during... (0 Replies)
Discussion started by: pude
0 Replies

7. SCO

SCO 5.0.7 and Serial ATA HDD question

Hi guys, I have this quick question , is it posible to isntall SCO 5.0.7 on a serial ATA and if it is can you tell me how or maybe a website that has some info about this. I'm not using any raid, just one HDD. Thanks a lot (0 Replies)
Discussion started by: josramon
0 Replies

8. UNIX for Advanced & Expert Users

SCO UNIX HDD full backup

HI ALL, I need to backup HDD with SCO UNIX. I need to have a full functionaly backup of this hard disk. Does anybody have any tool or subsription how to do it. I tried some SW, but after when I tried to use this copy of my original disk "can not find a root directory". Thanks in advance. (1 Reply)
Discussion started by: jardas
1 Replies
Login or Register to Ask a Question

Featured Tech Videos