Pkgadd issue


Login or Register to Reply

 
Thread Tools Search this Thread
# 1  
Old 1 Week Ago
Pkgadd issue

Good Afternoon,
I have 3 video driver packages in a directory that need to be installed. on a SunBlade 2500 running Solaris9. When I try running
Code:
pkgadd -d /Recovery/CloneDrivers/SUNWpfbcf

for example, I get
Code:
pkgadd: ERROR: no packages were found in </var/spool/pkg>


Permissions are 755, owner is root. I've tried navigating to the directory and then
Code:
pkgadd SUNWpfbcf

but get the same error.


Any idea what's happening?

Last edited by vbe; 1 Week Ago at 11:25 AM.. Reason: replace icode with code tags...
# 3  
Old 1 Week Ago
AFAIR there are two package formats, one is a one-file, and the other is a directory (one can convert to each other with the pkgtrans command).
The one-file package you install with
Code:
pkgadd -d /path/to/pkgfile

Your package seems to be the directory format, then it should be
Code:
pkgadd -d /Recovery/CloneDrivers SUNWpfbcf

Or just
Code:
pkgadd -d /Recovery/CloneDrivers

and it should ask for all (dir-format-)packages in there.

Last edited by MadeInGermany; 1 Week Ago at 03:59 PM..
These 2 Users Gave Thanks to MadeInGermany For This Post:
jim mcnamara (1 Week Ago) Stellaman1977 (1 Week Ago)
# 4  
Old 1 Week Ago
Thanks!!! This one worked:
Code:
pkgadd -d /Recovery/CloneDrivers

It then asked which package I wanted to install (and that all three is the default. Interesting, last year when we hammered out this process, I installed them from the CDROM and I don't recall having to do it this way.
Login or Register to Reply

|
Thread Tools Search this Thread
Search this Thread:
Advanced Search

More UNIX and Linux Forum Topics You Might Find Helpful
Non-interactive pkgadd not working. mohtashims Shell Programming and Scripting 0 12-27-2016 12:13 PM
Pkgadd with firefox jkoval Solaris 1 02-07-2014 05:28 PM
pkgadd changes permissions of /etc funwithdolphin Solaris 1 10-30-2009 06:53 AM
pkgadd question venhart Shell Programming and Scripting 2 03-10-2009 04:22 AM
Pkgadd error lbreddy Solaris 6 01-29-2009 09:06 AM
pkgadd woes AndyD Solaris 6 09-06-2008 06:10 PM
pkgadd? Reloader Solaris 2 09-01-2008 07:13 PM
Pkgadd problem hcclnoodles Solaris 9 05-16-2008 04:51 PM
pkgadd help mokkan Solaris 1 04-08-2008 11:08 AM
pkgadd issues Sowser UNIX for Advanced & Expert Users 3 09-04-2007 01:43 PM
pkgadd issues GLJ@USC UNIX for Dummies Questions & Answers 3 07-03-2007 02:37 PM
pkgadd melanie_pfefer Solaris 6 01-09-2007 03:45 AM
PKGADD error Bags UNIX for Advanced & Expert Users 2 05-15-2006 06:29 PM
pkgadd alsande UNIX for Dummies Questions & Answers 4 03-27-2004 03:25 AM
Pkgadd / gnutar finster UNIX for Dummies Questions & Answers 4 09-15-2003 02:01 AM