Echo/kill pgrep

Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers Echo/kill pgrep
# 1  
Old 10-10-2018
Echo/kill pgrep

Hi folks. I'm wondering why the following doesn't work and hoe to fix it...

I can:
# pgrep foo

I can:
# echo | pgrep foo

But I can't
# kill | pgrep foo
kill: usage: blah blah

So why does echo pipe correctly but kill doesn't?

Last edited by Scott; 10-10-2018 at 06:18 AM.. Reason: Code tags, please...
# 2  
Old 10-10-2018
kill requires at least one argument (one or more PIDs).
kill [-s signal|-p] [-q sigval] [-a] [--] pid...

echo doesn't require any arguments (and wouldn't appear to serve any purpose in your example).

You could use kill $(pgrep foo). Or, you could just use pkill foo instead.
# 3  
Old 10-10-2018
The pipe symbol on the left means input.
But you want to pass the output to the kill command.
Then, the kill command works with arguments, not with an input stream. So you need the xargs program to convert the input stream to arguments.
pgrep foo | xargs kill

As mentioned, if pgrep does not find anything then kill complaints of missing arguments.
Therefore, and for the sake of simplicity:
pkill foo

# 4  
Old 10-10-2018
ahhhh. I like pkill.

Many thanks.
# 5  
Old 10-11-2018
echo to etc file

Hi there.

I would like to add a mount line to a cluster of mini servers, quite a few of them. I need to do this remotely with pssh.

The problem being ssh sudo echo snd ssh sudo fprint both produce permission denied. I know sudo echo works locally, so it's quite rightly prevented over ssh. This isn't a password problem as I have copied shared keys.

So, the question is, how can I do this quite wrongly using ssh? (!)
I can only use pssh, I could use a script if I can take an ip list from file, or I could use python. I cannot add any software to the nodes. Or at least I really don't want to.

Many thanks.

------ Post updated at 07:44 PM ------

Just thought I'd try pssh <ops> "sudo chmod 0777 /etc/fstab" worked fine, then I could echo the mount line.

So, there you go!
# 6  
Old 10-11-2018
You have made /etc/fstab world-writable and had better correct that before something else overwrites it by accident, or an attacker takes advantage of the situation! 777 is not the magic sledgehammer to fix all problems!

echo is not prevented over ssh. As you discovered, file permissions were preventing you. The correct thing to do would be to obtain the required permissions.
# 7  
Old 10-11-2018
Cluster vs Super

Hi there.

I'm currently playing around with a small cluster of mini boards running Debian. Or Raspbian to be precise. Each node is given a datafile and renders animation frames. This is as much a cluster as it c be, I'm using one as a header, I've written some scripts and code to automate certain tasks, but every node is totally isolated save it's wifi connection to the same network.

So I'm wondering what os' there are around that could use all these nodes as one. 12x4 cores could be fun to play around with, and may possibly save time as a lot of duplicated file checking would be avoided.

If I can get this working I'm prepared to sink a bit of cash into the project and add a load more nodes. So, what do you think my options would be?

Many thanks.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Pgrep not showing desired output

I am searching for a process that should be up and running. Im using the following command ps -ef | grep elasticsearch to get elastic+ 1673 1 0 Jan29 ? 05:08:56 /bin/java -Xms4g -Xmx4g -Djava.awt.headless=true -XX:+UseParNewGC -XX:+UseConcMarkSweepGC... (1 Reply)
Discussion started by: Junaid Subhani
1 Replies

2. Shell Programming and Scripting

Pgrep for processes which are not associated with a terminal in Ubuntu

I would like to find all of the PIDs of processes which are not associated with a terminal and started by CRON. When I do the ps aux | less command, I see in the TTY field a lot of processes with ? character I would like to get those processes ID, is there a way to do that with pgrep? ... (1 Reply)
Discussion started by: ASF Studio
1 Replies

3. Shell Programming and Scripting

Ssh and pgrep not working

I have setup SSH keys . Trying to grep to get PID of remote jvm's . this is what am doing ssh -q 'PID1=pgrep -fl testapp1|awk "{print $1}";PID2=pgrep -fl testapp2|awk "{print $1}" ' echo $PID1, $PID2 it throws error"sh: -fl: command not found" ---------- Post updated... (1 Reply)
Discussion started by: kondagadu
1 Replies

4. Shell Programming and Scripting

Kill an specific process ID using the KILL and GREP commands

Good afternoon I need to KILL a process in a single command sentence, for example: kill -9 `ps -aef | grep 'CAL255.4ge' | grep -v grep | awk '{print $2}'` That sentence Kills the process ID corresponding to the program CAL255.4ge. However it is possible that the same program... (6 Replies)
Discussion started by: enriquegm82
6 Replies

5. HP-UX

pgrep doesn't perform full command line pattern matching

Hi! I need to get PID of some particular process and I wonder if I can use pgrep tool for this purpose. The problem is that pgrep doesn't perform pattern matching on the whole command line, even if I use -f key. Parsing output of ps command is not quite convenient... Also deamon, which PID I need... (2 Replies)
Discussion started by: Sapfeer
2 Replies

6. UNIX for Dummies Questions & Answers

PGREP Arguments

I'm trying to figure out how to use pgrep to pull the arguments of a process. Given: root 308 1 0 00:00 ? 00:00:00 /bin/sh /some/random/path/ -flag /another/path/blahI can get the pid (308) using this command: pgrep shHowever, what if I wanted to pull by ""... (4 Replies)
Discussion started by: mrwatkin
4 Replies

7. Programming

pgrep returns 256

Hi Everyone, I have a strange behaviour In my c program i use this line: int retval = system("pgrep encoder"); while i expect retval to contain 0,1,2,3 i get 256. did i do something wrong? thanks, Alex (2 Replies)
Discussion started by: alex889
2 Replies

8. AIX

pgrep substitute for porting a linux script to AIX 5.x

Hi, I'm trying to get this script to work on an AIX 5.3 box, I couldn't get pgrep for AIX, I also realize that ps works differently on the IBM boxes. Could anybody just give me the specifics of a work around for my problem, I'll adjust the whole script: #!/bin/bash # #to do: #... (3 Replies)
Discussion started by: thebytegrill
3 Replies

9. Programming

kill(0,-9) don't kill the process

Hi all i have simple c program , when i wish to kill the app im using kill(0,-9) , but it seams this command don't do any thing and the program. just ignore it . what im doing wrong here ? im using HP-UX ia64 Thanks (9 Replies)
Discussion started by: umen
9 Replies

10. UNIX for Advanced & Expert Users

When kill doesnt work, how to kill a process ?

Hi All, I am unable to kill a process using kill command. I am using HP-UX system. I have tried with kill -9 and i have root privilages. How can i terminate this daemon ? ? ? Regards, Vijay Hegde (3 Replies)
Discussion started by: VijayHegde
3 Replies
Login or Register to Ask a Question

Featured Tech Videos