Visit The New, Modern Unix Linux Community


Behaviour of echo commands used by Linux admins


 
Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers Behaviour of echo commands used by Linux admins
# 1  
Behaviour of echo commands used by Linux admins

version info : Fedora 28 (Kernel version: 4.16.12-300)
shell : bash

Using echo command , if I redirect a text like "Chocolate" to a file , all the contents in the file are overwritten as shown below.

Code:
[root@john215 ~]# cat /tmp/someTest 
Hello world 
One more Hello world 
myLine3 
 
[root@john215 ~]# echo Chocolate > /tmp/someTest 
[root@john215 ~]# cat /tmp/someTest 
Chocolate 
[root@john215 ~]# file /tmp/someTest 
/tmp/someTest: ASCII text

But, I have seen Linux system admins using echo commands like below to scan for new LUNs.

Why is "/sys/class/scsi_host/host1/scan" file not being overwritten with "- - -" or "1" by the echo commands below ?

Code:
 
# echo "1" > /sys/class/fc_host/host/issue_lip 
# echo "- - -" > /sys/class/scsi_host/host1/scan

Source:

1.8. Scanning Storage Interconnects - Red Hat Customer Portal


Code:
# file /sys/class/scsi_host/host1/scan 
/sys/class/scsi_host/host1/scan: writable, regular file, no read permission

# 2  
This is due sysfs being pseudo filesystem, as procfs is as well.

It's actually an interface from kernel space to user space which allows you to manipulate various options regarding your hardware or operating system values.
Options such as fibre rescan, ip4 forwarding etc are all controlled by user using those pseudo file systems.
A lot of those options have real backed configuration files (such as /etc/sysctl.conf) which will apply those on boot.

That file system is created after system is booted (or on request) and populated with your device files.
For instance, if you add additional fibre card, a sysfs will be populated with additional hierarchy for that card.

An actual echo command is predetermined, if you issue anything else error will be written.

Take the following example from my PC at home :
Code:
root# echo "- - -" > /sys/class/scsi_host/host1/scan
root# tail -f  /var/log/messages
kernel: [ 6598.240883] ata2: hard resetting link
kernel: [ 6598.555362] ata2: SATA link down (SStatus 0 SControl 300)
kernel: [ 6598.555382] ata2: EH complete
root# echo "gibberish" > /sys/class/scsi_host/host1/scan
-su: echo: write error: Invalid argument

Hope that helps
Regards
Peasant.
These 2 Users Gave Thanks to Peasant For This Post:
# 3  
Please cat those two sys files and post the output in reply.

Thanks.
# 4  
Thank You very much Peasant.
Hi Leo
Will try cat those files when I reach home. If I remember correctly, i couldn't cat those files even as root.
file command's output from my above post says no read permission too.
# 5  
@kralkic,
You may try below method.

Step 1 : In boot file you can add the option
Code:
radeon.runpm=0

in the call to the current kernel (usually after ro quiet splash).
Step 2 :
Code:
$echo OFF >/sys/kernel/debug/vgaswitcheroo/switch

Ref: https[://]codeflu[.]blog/2013/04/25/disabling-discrete-amd-graphics-card-in-linux/#comment-280

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #714
Difficulty: Medium
Machine learning is a well known method for mitigating the Von Neumann performance bottleneck
True or False?

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Strange behaviour on my Linux Server.

Hi, I keep getting this error when i run my script: No matter how many times i run this rm -rf /siebel/sfs/tmp/dump it succeeds when i expect it only the first time to succeed becoz i expect the second to fail as the directory should be gone in the first run. i had earlier mentioned... (5 Replies)
Discussion started by: mohtashims
5 Replies

2. UNIX for Dummies Questions & Answers

Echo out running commands

Is there any way in a script to print out the commands being ran? In DOS script, there is the "@echo on" and "@echo off". so I have a script like this: #!/bin/ksh echo "hello there. moving files." <turn on echoing here> cp thisfile.txt thatfile.txt cp whatfile.prop whyfile.prop <turn... (2 Replies)
Discussion started by: ronron5477
2 Replies

3. Shell Programming and Scripting

echo and grep commands

Hey im new in this...anything will be helpful... The user will input the word or phrase .... I want to search the user input in file (by lines) but not all then with this line search on another file ( with the specific line) and show to the user. Example: file1.txt ======= a aa aaa... (2 Replies)
Discussion started by: Sundown
2 Replies

4. UNIX for Dummies Questions & Answers

Having a hard time with the sed/echo commands?

Hello, well what I'm trying to do is to remove underscores from filenames and leaving empty spaces instead: arturas@Universe:/windows/Center/training$ ls big_file failas su shudu arturas@Universe:/windows/Center/training$ a=big_file arturas@Universe:/windows/Center/training$ mv $a `echo... (8 Replies)
Discussion started by: arcelivez
8 Replies

5. Linux

Linux/Weblogic Admins?

Please forgive me if I've chosen the wrong forum... but I'm just wondering how likely it is to find a Linux sys admin with a vast BEA Weblogic skillset or vice versa (a Weblogic admin with vast Linux admin skills)? The reason I ask is because our Linux Sys Admin is leaving for a position with... (1 Reply)
Discussion started by: rm -r *
1 Replies

6. Shell Programming and Scripting

Advice using cut & echo combination commands

Hi, I am cutting data from a fixed length test file and then writing out a new record using the echo command, the problem I have is how to stop multiple spaces from being written to the output file as a single space. Example: cat filea | while read line do field1=`echo $line | cut -c1-2` ... (6 Replies)
Discussion started by: dc18
6 Replies

7. Shell Programming and Scripting

SSH, Remote Commands and echo, oh my!

So, HostB has a SSH trust via pre-shared keys from HostA. HostA> ssh HostB hostname HostB HostA> ssh HostB echo `hostname` HostA HostA> ssh HostB 'echo `hostname`' `hostname` HostA> ssh HostB "echo `hostname`" HostA HostA> ssh HostB echo $PS1 user@HostA:$PWD HostA> ssh HostB... (12 Replies)
Discussion started by: Wrathe
12 Replies

8. Shell Programming and Scripting

Wierd behaviour setting stty echo

Hi all, Encountered a wierd behaviour which I am unable to understand. I have a function doing the follow: function RETRIEVE_PASSWORD { if (( $DC_ACCOUNT )) then clear printf "\nEnter Password for ${ConfiguredUser}" printf... (1 Reply)
Discussion started by: srage
1 Replies

9. UNIX for Dummies Questions & Answers

Longer commands and strange behaviour on ksh

Hi, I was trying to customize this archaic HP-UX box. only shell available is ksh and that too seems to be pretty old and doesn't completely conform to what I read on the web about ksh. Anyway here are my issues: - I wanted to have a dynamic title on xterm or dtterm. I put the following lines... (2 Replies)
Discussion started by: anurags
2 Replies

Featured Tech Videos