Telnet failed to localhost.

Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers Telnet failed to localhost.
# 1  
Old 01-20-2018
Telnet failed to localhost.


I am trying telnet to localhost 514. But the connection is refusing.

Port does not appear in netstat. IP table service is also off.

Last edited by Nishit; 01-20-2018 at 05:07 PM.. Reason: Add more information
# 2  
Old 01-20-2018
What TCP service do you expect to be listening on port 514 on localhost?
# 3  
Old 01-20-2018
I want to collect logs from different hosts, therefore I am checking is the port 514 is open or not.
# 4  
Old 01-20-2018

Port 514 is the port for the syslog service, as you seem to have already determined. However, in those instances where a local logging service is configured to listen for incoming connections on port 514 it almost always uses UDP rather than TCP, so you can't test this by attempting to telnet to the port.

Exactly how you'd configure this all to work depends on your exact version of UNIX/your Linux distribution, what software you're using for logging, and of course if there is some external firewall that could be in the way even if your own local firewall definitely is not. But the best way to test it is to try to generate a logged event on a remote system that you have configured to log to your syslog server, and see if something gets logged or not.
This User Gave Thanks to drysdalk For This Post:
# 5  
Old 01-21-2018
removed ... inadequate.

Last edited by RudiC; 01-21-2018 at 07:22 AM..
# 6  
Old 01-21-2018
You could try using netcat (or nc) instead with the -u option:
if nc -u localhost. 514 2>/dev/null <<< $'\n'; then
  echo udp port open
  echo udp port closed

Last edited by Scrutinizer; 01-21-2018 at 08:07 AM..
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Tcl / expect need to attempt telnet if failed ssh

Morning and Happy New Year to all. I am in a situation where I need to connect to a list of devices that are using either telnet or ssh. I want to try to telnet, if I receive any of the following I want to attempt ssh : "Connection refused" "Connection timed out" timeout expiration ... (3 Replies)
Discussion started by: popeye
3 Replies

2. Shell Programming and Scripting

Cannot find localhost

I get a "not found" error from this localhost/choice.php ethan@meow:~$ ping PING ( 56(84) bytes of data. 64 bytes from icmp_seq=1 ttl=64 time=0.025 ms 64 bytes from icmp_seq=2 ttl=64 time=0.036 m and this ethan@meow:~$ mysql -u... (4 Replies)
Discussion started by: Meow613
4 Replies

3. Debian

Waiting for localhost.

I am getting the message - waiting for localhost. Here are some diagnostic steps I have tried .... root@meow:/home/ethan# cat /var/www/cgi-bin/httpd.conf ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/jkj ServerName Listen xx.xx.xx.xx:80 Listen ... (1 Reply)
Discussion started by: Meow613
1 Replies

4. Solaris

Timeout: No Response from localhost

Hi All! I having an issue when trying to run snmpwalk, so the following command it returns an error: bash-3.00# /usr/sfw/bin/snmpwalk -v 2c -c public localhost sysDescr.0 Timeout: No Response from localhost bash-3.00# I have checked also: bash-3.00# svcs -a | grep sma online ... (2 Replies)
Discussion started by: fretagi
2 Replies

5. UNIX for Advanced & Expert Users

DIG uses localhost

Hi, I have these entries in the /etc/esolv.conf: ------------ domain xxxxxx search yyyyyy nameserver nameserver aaaaaaaaaaaaaaaa nameserver bbbbbbbbbbbbbbbb ------------- When I use 'dig' or 'nslookup' command, like 'dig' it uses the localhost as the server. I... (2 Replies)
Discussion started by: chaandana
2 Replies

6. UNIX for Dummies Questions & Answers

Can't Open Display localhost:0.0

I'm trying to connect to my linux server but I'm having some major problems. The server had OEL 5 installed and my local pc is running Windows XP. I'm using PuTTy to connect to the server with Xming running on my loacl machine. I login as root and run the following command - export... (5 Replies)
Discussion started by: garethnsolomons
5 Replies

7. Shell Programming and Scripting

Webpage to Telnet via Perl and Expect: Telnet problem?

Somewhat long story: I have a simple Perl CGI script that uses Expect to Telnet to a device and grab some data, and then spits it back to Perl for display on the Webpage. This works for many devices I've tried, but one device just fails, it keeps rejecting the password on this device, only... (1 Reply)
Discussion started by: jondo
1 Replies

8. Ubuntu

fail to telnet localhost 106

Hi folks, Ubuntu 7.04 server amd64 On running; $ telnet localhost 106 Trying telnet: Unable to connect to remote host: Connection refused $ netstat -an | grep 106 $ sudo netstat -an | grep 106 both no printout Pls advise where shall I check and how to fix... (22 Replies)
Discussion started by: satimis
22 Replies

9. UNIX for Advanced & Expert Users

localhost problem!

hello guys, this morning when I start my pc (gentoo) I get some strange errors about localhost. "Could not determine the server's fully qualified domain name, using for ServerName" ... Apache the same for my aplications, I have to use the full address of my pc instead of... (1 Reply)
Discussion started by: georgeplus
1 Replies

10. Linux


Hello, I am ltrying to find the config file to modify a parameter for apache (I guess). Here, when sending mail using php web form I get a copy of all mail sent from that form, but here is a sample of what I get : From : apache@localhost.localdomain To : Subject : Mail ... (2 Replies)
Discussion started by: qfwfq
2 Replies
Login or Register to Ask a Question

Featured Tech Videos