Solaris 10 issue installing libraries


Login or Register for Dates, Times and to Reply

 
Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers Solaris 10 issue installing libraries
# 1  
Solaris 10 issue installing libraries

Solaris 10 sparc - currently trying to install gpg, first trying to install the pre-requisite libraries. Facing errors installing some of the libraries, same error being faced with each.

The configure command passes successfully for each but when running make command errors such as below are experienced, this particular error was seen when running make for libgcrypt-1.5.0 but experience it with other libraries also.

Can anyone help or advise on what possible steps next to find and correct cause of the issue ?

I have attached the full output from the make command also.



Code:
libtool: link: gcc -shared -Wl,-z -Wl,text -Wl,-h -Wl,libgcrypt.so.11 -o .libs/libgcrypt.so.11.7.0  .libs/libgcrypt_la-visibility.o .libs/libgcrypt_la-misc.o .libs/libgcrypt_la-global.o .libs/libgcrypt_la-sexp.o .libs/libgcrypt_la-hwfeatures.o .libs/libgcrypt_la-stdmem.o .libs/libgcrypt_la-secmem.o .libs/libgcrypt_la-missing-string.o .libs/libgcrypt_la-module.o .libs/libgcrypt_la-fips.o .libs/libgcrypt_la-hmac256.o .libs/libgcrypt_la-ath.o  -Wl,-z -Wl,allextract ../cipher/.libs/libcipher.a ../random/.libs/librandom.a ../mpi/.libs/libmpi.a ../compat/.libs/libcompat.a -Wl,-z -Wl,defaultextract  -R/usr/local/lib -R/usr/local/lib -L/usr/local/lib /usr/local/lib/libgpg-error.so -lsocket -lc   
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(mpih-add1-asm.o): symbol <unknown>: offset 0xfe66b015 is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(mpih-add1-asm.o): symbol <unknown>: offset 0xfe66b01b is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(mpih-add1-asm.o): symbol <unknown>: offset 0xfe66b01f is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(mpih-add1-asm.o): symbol <unknown>: offset 0xfe66b023 is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(mpih-lshift-asm.o): symbol <unknown>: offset 0xfe66b533 is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(mpih-lshift-asm.o): symbol <unknown>: offset 0xfe66b539 is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(mpih-lshift-asm.o): symbol <unknown>: offset 0xfe66b53d is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(mpih-lshift-asm.o): symbol <unknown>: offset 0xfe66b541 is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(mpih-rshift-asm.o): symbol <unknown>: offset 0xfe66b58e is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(udiv-asm.o): symbol <unknown>: offset 0xfe66b5e9 is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(udiv-asm.o): symbol <unknown>: offset 0xfe66b5ef is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(udiv-asm.o): symbol <unknown>: offset 0xfe66b5f3 is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(udiv-asm.o): symbol <unknown>: offset 0xfe66b5f7 is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(mpih-add1-asm.o): symbol <unknown>: offset 0xfe6b54e5 is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(mpih-lshift-asm.o): symbol <unknown>: offset 0xfe6b6505 is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(mpih-rshift-asm.o): symbol <unknown>: offset 0xfe6b6576 is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(udiv-asm.o): symbol <unknown>: offset 0xfe6b65dd is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(mpih-add1-asm.o): symbol <unknown>: offset 0xfe6c16de is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(mpih-lshift-asm.o): symbol <unknown>: offset 0xfe6c177e is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(mpih-rshift-asm.o): symbol <unknown>: offset 0xfe6c179e is non-aligned
ld: fatal: relocation error: R_SPARC_32: file ../mpi/.libs/libmpi.a(udiv-asm.o): symbol <unknown>: offset 0xfe6c17be is non-aligned
collect2: ld returned 1 exit status
*** Error code 1
make: Fatal error: Command failed for target `libgcrypt.la'
Current working directory /var/spool/pkg/libgcrypt-1.5.0/src
*** Error code 1
The following command caused the error:
fail= failcom='exit 1'; \
for f in x $MAKEFLAGS; do \
  case $f in \
    *=* | --[!k]*);; \
    *k*) failcom='fail=yes';; \
  esac; \
done; \
dot_seen=no; \
target=`echo all-recursive | sed s/-recursive//`; \
list='compat mpi cipher random src doc tests'; for subdir in $list; do \
  echo "Making $target in $subdir"; \
  if test "$subdir" = "."; then \
    dot_seen=yes; \
    local_target="$target-am"; \
  else \
    local_target="$target"; \
  fi; \
  (CDPATH="${ZSH_VERSION+.}:" && cd $subdir && make  $local_target) \
  || eval $failcom; \
done; \
if test "$dot_seen" = "no"; then \
  make  "$target-am" || exit 1; \
fi; test -z "$fail"
make: Fatal error: Command failed for target `all-recursive'
Current working directory /var/spool/pkg/libgcrypt-1.5.0
*** Error code 1
make: Fatal error: Command failed for target `all'


Moderator's Comments:
Mod Comment Please use CODE tags as required by forum rules!

Last edited by RudiC; 01-10-2018 at 06:47 AM.. Reason: Changed ICODE to CODE tags.
# 2  
Hi,

I suspect that the issue here is that whilst you're using the GNU C compiler gcc, you're using the native Sun linker ld rather than GNU ld. If you make sure that the GNU linker is in your path before the native Solaris linker (or if you specifically point your Makefile or configure script at the GNU linker rather than the Sun one), that should hopefully solve the problem. That's my guess, anyway, based on the errors you're getting.
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #629
Difficulty: Easy
In PHP, False == 0;
True or False?

9 More Discussions You Might Find Interesting

1. Solaris

Solaris: ldd doesn't find libraries in exported environment variable LD_LIBRARY_PATH

I have given the relevant details below. Why are the libraries in /export/home/builds/pc9x_root/960/build/powrmart/pmbuild/bin/SunOS.64.r are invisible to ldd? %setenv ... (3 Replies)
Discussion started by: old_as_a_fossil
3 Replies

2. UNIX for Dummies Questions & Answers

Libraries load issue

I am trying to upgrade Autosys to r11.3.5 how ever while running the setup i am getting below error , I went through some of the Known errors , found to command the export LD_ASSUME_KERNEL parameter , which i did however didnot work . Could some pleae look into this asap. Starting all... (1 Reply)
Discussion started by: rakesh_411
1 Replies

3. Solaris

Facing issue while installing weblogic on Solaris 11

Hi, i am facing issue while installing weblogic on solaris..its giving me invalid argument error. solaris is intstalled on my VM. uname -a SunOS Vishal 5.10 Generic_137138-09 i86pc i386 i86pc screenshot attached. (5 Replies)
Discussion started by: Vishal Baghla
5 Replies

4. Solaris

Error opening PAM libraries : solaris 10 on vmware workstation

Hi Admins, I am facing an issue with Solaris 10 sitting on vmware workstation... When I start it, it gives me an error : "Error opening PAM libraries, contact system administrator" Also I can reach it via putty, but none of the id/passwd working. I did revert pam.conf. But still no... (2 Replies)
Discussion started by: snchaudhari2
2 Replies

5. Solaris

Issue while installing: Solaris 10 SPARC Recommended Patch Cluster (2009.10.23)

Hello, As explained, I've encountered an issue while installing Solaris 10 SPARC Recommended Patch Cluster (2009.10.23). Actually, patch no 120011-14 stops with the following error: ERROR: attribute verification of </var/run/.patchSafeMode/root/usr/bin/passwd> failed file type <f>... (6 Replies)
Discussion started by: a.mauger
6 Replies

6. Solaris

How to manage the shared libraries on Solaris 10?

Please tell me how to manage the shared library on solaris 10! which file to configure the library path? which environment variable contains these paths ? how to define the new library path? thanks all! (2 Replies)
Discussion started by: quyetbm
2 Replies

7. UNIX for Advanced & Expert Users

solaris 8 libraries compatible solaris 10

Hello, For a company I have to check if it is possible to migrate there environment from a solaris 8 to solaris 10. Is there a tool with which I can check if the libraries running now on the 8 are compatible with the 10? Kind regards (3 Replies)
Discussion started by: chelle007
3 Replies

8. Solaris

Postprocess issue installing Solaris 9 Branded Zone

Hello, I am attempting to install a newly configured Solaris 9 zone using the flash archive image provided on the sun website. Each time I run the install I get a failure during the Postprocess: Creating mount points. Following is the log: Log File: /var/tmp/s9-zone.install.25457.log... (0 Replies)
Discussion started by: brialt1
0 Replies

9. UNIX Desktop Questions & Answers

Issue with installing solaris 10 OS on sparc 5

Rebooting with command: boot cdrom -s Boot device: /pci@1f,0/pci@1,1/ide@3/cdrom@2,0:f File and args: -s Evaluating: boot cdrom -s Can't open boot device If any one knows please advise. I have changed the CDrom but it did not help. (1 Reply)
Discussion started by: ark
1 Replies

Featured Tech Videos