Can't delete a file in the trash on OSX 10.11.6

Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers Can't delete a file in the trash on OSX 10.11.6
# 1  
Old 12-19-2016
Can't delete a file in the trash on OSX 10.11.6

I use a Mac running OSX El Capitan = UNIX user the hood. After rearranging files on an external hard drive, I ended up with a folder in the trash containing a file called "~INITPicker 2.0". I cannot empty the trash, and so delete the file. I even tried terminal, using the rm file command and recursively remove folder command, all to no avail. I cannot re-name the offending file, as it tells me I can't. I think the problem is with the tilde in the name. Can any clever soul tell me how to delete this file using terminal (the Mac's command line utility)?

Any guidance gratefully received.
# 2  
Old 12-19-2016
Did you reboot your Mac and tried again?
# 3  
Old 12-19-2016
Yes, I re-booted. Still no luck.
# 4  
Old 12-19-2016
Try the terminal solution again and put the filename in quotation marks:

rm "~INITPicker 2.0"

# 5  
Old 12-19-2016
DukeNuke2, first of all, many thanks for taking the time to respond to my squawk.

Here's a record of my trial:

in the trash, folder xx, inside that folder ee, inside that ~InitPicker 2.0.

djCUDA:.Trash macuser$ cd ~/.Trash/xx/ee/
djCUDA:ee macuser$ rm "~INITPicker 2.0"
rm: ~INITPicker 2.0: No such file or directory
djCUDA:ee macuser$ ls
␀INITPicker 2.0
djCUDA:ee macuser$

I should have added that when I try to empty the trash via the Mac menu, I get the following errors:

unexpected error occurred -50   /*error in user parameter list*/
xx is in use
ee is in use

Just noticed that the first character in the offending file is not a tilde, but NUL.

Can this help diagnosis? How do I type a NUL?

ADDENDUM after copy and paste from ls

djCUDA:ee macuser$ rm "␀INITPicker 2.0"
rm: ␀INITPicker 2.0: Invalid argument
djCUDA:ee macuser$

Last edited by djfilms; 12-19-2016 at 02:55 PM..
# 6  
Old 12-19-2016

Read this thread:

File name starts with esc character.

I'm not a OSX expert but, as with generic Unix/Linux, if all else fails, nuke the inode. The inode is the only route that the OS can find the file. If the inode doesn't exist, neither does the file.

Read Corona688's post#2.

If Corona688 is on here today with luck he may well chip in.

---------- Post updated at 07:29 PM ---------- Previous update was at 07:16 PM ----------

And don't forget you can have the same inode number on different filesystems. So make absolutely sure which filesystem you are operating on.

sent from my HTC smartphone
These 2 Users Gave Thanks to hicksd8 For This Post:
# 7  
Old 12-19-2016
Did you try booting into Safe Mode (hold shift key down during bootup)?
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

XFCE Desktop - trash, cannot execute file, command prompt here missing.

Hi there, I am using the xfce4 is already the newest version (4.12.5). thunar is already the newest version (1.8.4-1). The distribution is Linux kali 4.19.0-kali1-amd64 #1 SMP Debian 4.19.13-1kali1 (2019-01-03) x86_64 GNU/Linux However, the problem is: When I when I click on any program to... (2 Replies)
Discussion started by: alvinoo
2 Replies

2. Shell Programming and Scripting

File Locking with fcntl on Darwin Mac OSX

Hello I have a Perl script that works on non-darwin Mac OS X environments and I think I have narrowed down the issue to a file locking problem. In other linux environments, the flock struct is defined differently. I have adjusted this via the reference for Mac OS X fcntl(2) man page. The... (4 Replies)
Discussion started by: flagman5
4 Replies

3. Solaris

trash can in solaris

one quick question please.. is Solaris have a RECYLE BIN,or TRASH to retrive deleted files accidently ? (0 Replies)
Discussion started by: Sojourner
0 Replies

4. Homework & Coursework Questions

Delete restore and empty trash

Use and complete the template provided. The entire template must be completed. If you don't, your post may be deleted! 1. The problem statement, all variables and given/known data: A set of Linux shell scripts is required to allow users to ‘remove' files without them really disappearing... (1 Reply)
Discussion started by: mr100perecent
1 Replies

5. UNIX for Dummies Questions & Answers


Hello, I deleted a file accidentally using rm-f inside a folder. Is there any option/command to retrive the file or is it possible to recover from trash? or once the file is deleted, it is gone completely?? (2 Replies)
Discussion started by: sydney2008
2 Replies

6. Linux

Emptying Trash

Hi all i hope someone can help me, in gnome if you right click on trash, you get another menu appear 'Empty Trash' what i want to do is be able to edit this command so that it secure deletes the trash, where is that command? so i can edit it. thanks in advance for any help, Dave (shred -z -u ) (0 Replies)
Discussion started by: dave123
0 Replies

7. Filesystems, Disks and Memory

unix executable file problem on MAC OSX ??? please help

I've got this problem. My computers and external hard drives are converting many of my files to a Unix Executable File which has a grey terminal looking icon. I don't understand what is causing this to happen. It is happening to a large number of my image file of different formats and also... (1 Reply)
Discussion started by: chadb
1 Replies

8. Solaris

Script for automatic deletion of trash file of mail server

Hi, I have a mail server with limited space and operating system is sun solaris 8 (sparc). I do not have provisions to increase the space for home directory. So i have to delete files from /home/username/mail/trash which are more than 10 days old automatically. So my script should be like... (1 Reply)
Discussion started by: crown2100bd
1 Replies

9. UNIX for Dummies Questions & Answers

file permisions 2000 to OSX

Could anyone tell me how or point me in the right direction on how to save files from a 2000box to a OSX server with the correct file permissions. File goes over and the only person that has r/w permissions is the owner everyone else is read only. HELP!!! (2 Replies)
Discussion started by: mom
2 Replies
Login or Register to Ask a Question

Featured Tech Videos