Login or Register to Ask a Question and Join Our Community


Can't delete a file in the trash on OSX 10.11.6


 
Thread Tools Search this Thread
Top Forums UNIX for Beginners Questions & Answers Can't delete a file in the trash on OSX 10.11.6
# 22  
Old 12-21-2016
I've used it on many different Unix OS's. As I said, I'm talking generics here.

This page:

https://www.unix.com/man-page/osx/8/clri/

from this forum seems to indicate 'clri' is on OSX too. Perhaps not.

---------- Post updated at 12:52 PM ---------- Previous update was at 12:48 PM ----------

See this too:

Is it possible to delete, let alone see, a file called "␀" on Windows 8? - Servers

Personally I don't know OSX enough to even attempt this. Repeat, I'm just talking generically and would not recommend non-pro's to even look at it.

You need to thoroughly understand how Unix filesystems work internally. You can blow your whole system up, just like that!
# 23  
Old 12-21-2016
I have no clri on my OSX. I guess the command was replaced by something else... I'll check if I find the time! Thanks anyway and maybe someone else comes up with another idea.
# 24  
Old 12-21-2016
According to the link I posted (about Windows 8), clri existed in OSX 10.6
Scroll down the page.

Whether a MAC can boot a 10.6 media DVD, mount the hard disk filesystem, and then use clri to nuke the inode, I have no clue. (It's the kind of thing I'd do on other OS's though.)
# 25  
Old 12-21-2016
For me it's not worth to try it out... In the next few days the system will be nuked completly anyway Smilie. I guess all my needed drivers and Logic plugins are now available on 10.12.X and I can go to the latest and greatest Mac OS (with all the new problems) and have sooo much fun Smilie.
# 26  
Old 12-21-2016
DukeNuke2, Here's the result of what you suggested.

Code:
djCUDA:ee macuser$ ls *T* | od -bc
0000000   342 220 200 111 116 111 124 120 151 143 153 145 162 040 062 056
           ␀  **  **   I   N   I   T   P   i   c   k   e   r       2   .
0000020   060 012                                                        
           0  \n                                                        
0000022

The file is very old, and so is probably from a pre-UNIX version of the Mac OS.

---------- Post updated at 08:56 AM ---------- Previous update was at 08:53 AM ----------

Gull04, The OS won't let me re-name the file. IT tells me I "can't use that filename, try fewer letters and no punctuation".When I try calling it "x", I get the same message.

regards, David

---------- Post updated at 08:59 AM ---------- Previous update was at 08:56 AM ----------

Hicks8, Here's the result of your suggestion:

Code:
djCUDA:ee macuser$ rm -i *
remove ␀INITPicker 2.0? Y
rm: ␀INITPicker 2.0: Invalid argument

Again, it doesn't like the NUL as the first character.

regards, David

---------- Post updated at 09:03 AM ---------- Previous update was at 08:59 AM ----------

Quote:
Originally Posted by DukeNuke2
I created a file with the same name as the OP and tried to delete it with every trick in the book. No luck! The problem is the "NUL" character at the begining which is a 3 byte character and nothing seems to work for that. I found a website which claims that this is a Mac OS 10.11.X only problem. Now I'm also stuck with that file... But in the next few days I will do a complete new install of 10.12.X and so I'm not concerned much, yet! Smilie

But I'm glad if someone is able to find a solution!
DN2, many thanks for your continued examination of this problem. I'm reluctant to install OSX 10.12 because of all my plug-ins, but I may be forced to choose between error messages on emptying the trash and updating the OS and hoping nothing breaks (yeah, right....].

regards, David

---------- Post updated at 09:07 AM ---------- Previous update was at 09:03 AM ----------

Hicks8, I looked at the post you reference, and note that I'm not the first to have this problem. Still no solution, alas.

regards, David

---------- Post updated at 09:10 AM ---------- Previous update was at 09:07 AM ----------

DukeNuke2,

The offending file is in my trash. If I re-install OS X 10.11, will my existing user account be over-written, and so the trash associated with the account will be deleted, along with my rogue file?
# 27  
Old 12-21-2016
A re-install will only be successfull, if you do a complete new install and use timemachine to restore all files, except the files in question. For my new install I will do exactly that. Everything new and even no timemachine restore. Will take at least 2-3 days until that is done but I guess it is about time to do it anyways and have a fresh start...
# 28  
Old 12-21-2016
DN2, good luck!!!

regards, David
This User Gave Thanks to djfilms For This Post:
Login or Register to Ask a Question

Previous Thread | Next Thread

9 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

XFCE Desktop - trash, cannot execute file, command prompt here missing.

Hi there, I am using the xfce4 is already the newest version (4.12.5). thunar is already the newest version (1.8.4-1). The distribution is Linux kali 4.19.0-kali1-amd64 #1 SMP Debian 4.19.13-1kali1 (2019-01-03) x86_64 GNU/Linux However, the problem is: When I when I click on any program to... (2 Replies)
Discussion started by: alvinoo
2 Replies

2. Shell Programming and Scripting

File Locking with fcntl on Darwin Mac OSX

Hello I have a Perl script that works on non-darwin Mac OS X environments and I think I have narrowed down the issue to a file locking problem. In other linux environments, the flock struct is defined differently. I have adjusted this via the reference for Mac OS X fcntl(2) man page. The... (4 Replies)
Discussion started by: flagman5
4 Replies

3. Solaris

trash can in solaris

one quick question please.. is Solaris have a RECYLE BIN,or TRASH to retrive deleted files accidently ? (0 Replies)
Discussion started by: Sojourner
0 Replies

4. Homework & Coursework Questions

Delete restore and empty trash

Use and complete the template provided. The entire template must be completed. If you don't, your post may be deleted! 1. The problem statement, all variables and given/known data: A set of Linux shell scripts is required to allow users to ‘remove' files without them really disappearing... (1 Reply)
Discussion started by: mr100perecent
1 Replies

5. UNIX for Dummies Questions & Answers

Trash

Hello, I deleted a file accidentally using rm-f inside a folder. Is there any option/command to retrive the file or is it possible to recover from trash? or once the file is deleted, it is gone completely?? (2 Replies)
Discussion started by: sydney2008
2 Replies

6. Linux

Emptying Trash

Hi all i hope someone can help me, in gnome if you right click on trash, you get another menu appear 'Empty Trash' what i want to do is be able to edit this command so that it secure deletes the trash, where is that command? so i can edit it. thanks in advance for any help, Dave (shred -z -u ) (0 Replies)
Discussion started by: dave123
0 Replies

7. Filesystems, Disks and Memory

unix executable file problem on MAC OSX ??? please help

I've got this problem. My computers and external hard drives are converting many of my files to a Unix Executable File which has a grey terminal looking icon. I don't understand what is causing this to happen. It is happening to a large number of my image file of different formats and also... (1 Reply)
Discussion started by: chadb
1 Replies

8. Solaris

Script for automatic deletion of trash file of mail server

Hi, I have a mail server with limited space and operating system is sun solaris 8 (sparc). I do not have provisions to increase the space for home directory. So i have to delete files from /home/username/mail/trash which are more than 10 days old automatically. So my script should be like... (1 Reply)
Discussion started by: crown2100bd
1 Replies

9. UNIX for Dummies Questions & Answers

file permisions 2000 to OSX

Could anyone tell me how or point me in the right direction on how to save files from a 2000box to a OSX server with the correct file permissions. File goes over and the only person that has r/w permissions is the owner everyone else is read only. HELP!!! (2 Replies)
Discussion started by: mom
2 Replies
Login or Register to Ask a Question

Featured Tech Videos