How to know whether my perodic thread is working fine


Login or Register for Dates, Times and to Reply

 
Thread Tools Search this Thread
# 1  
Question How to know whether my perodic thread is working fine

Dear All,


I am using xenomai-2.4 along with linux kernel 2.6
In my application having following threads.

8ms perodic thread (RT TASK)
1ms perodic thread(RT TASK)
16ms perodic thread(RT TASK)
256ms perodic thread(RT TASK)

22 - pthread are condition based it may execute or else in semwait.


Here i want to prove my perodic threads are exceute with this elapsed time (like 1ms .., 8ms) whatever may be the load of CPU.

kindly tell me way i have to prove my perodic threads are working fine ( when overload the CPU) because my application use 143 MB of memory.
# 2  
collectl - http://collectl.sourceforge.net/

collectl has the ability to monitor threads in either top more or rolling output. if these are short-lived, you can always set a monitoring interval to < 1 sec! In fact, if you know the process name and issue the following command:

collectl --top --procfile cxxx --protopt t -i:0.01

it will look for all processes with the string xxx anywhere in their command line as well as any threads with that name once every 0.01 seconds!

-mark
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Science: Mathematics
Difficulty: Hard
L'Hôpital was the mathematician who created the homonymous rule that uses derivatives to evaluate limits with indeterminations.
True or False?

9 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

sed command not working inside ksh script but works fine outside

Hi, I am a bit confused ,why would a sed command work fine outside of ksh script but not inside. e.g I want to replace all the characters which end with a value and have space at end of it. so my command for it is : sed -i "s/$SEPARATOR /$SEPARATOR/g" file_name This is working fine in... (8 Replies)
Discussion started by: vital_parsley
8 Replies

2. Shell Programming and Scripting

Getting Command not found error Even though Script is working fine

Hi friends, I am using below script to do some work. But even though script is working fine but while executing it i am getting command not found error. :( Here is the script :- #!/bin/sh Names="name.txt" ###main##### for LINE in `cat ${Names}` do ... (3 Replies)
Discussion started by: harpal singh
3 Replies

3. Shell Programming and Scripting

Script not working in cron but working fine manually

Help. My script is working fine when executed manually but the cron seems not to catch up the command when registered. The script is as follow: #!/bin/sh for file in file_1.txt file_2.txt file_3.txt do awk '{ print "0" }' $file > tmp.tmp mv tmp.tmp $file done And the cron... (2 Replies)
Discussion started by: jasperux
2 Replies

4. Shell Programming and Scripting

Sed script not working properly on Solaris (works fine on AIX)?

Hi, I have a problem with a SED script that works fine on AIX but does not work properly on a Solaris system. The ksh script executes the SED and puts the output in HTML in tables. But the layout of the output in HTML is not shown correctly(no tables, no color). Can anyone tell if there is... (7 Replies)
Discussion started by: Faith111
7 Replies

5. Shell Programming and Scripting

Getting issue while running it from cron while manually working fine

Hello, I am working one one script where I am using the below code which is using to connect with MKS client when I run my script manually it works effiecently i.e. it connects with MKS client but when I run it from CRON it doesn't connect. 1)Can some one tell when it is running from cron... (1 Reply)
Discussion started by: anuragpgtgerman
1 Replies

6. Programming

Thread Not Working

Hy, In my current knowledge, i write the code for multiply 3x3 matrix to it self . . . Problem is that pthread_create function is not working. Here is my code :wall::wall::wall::wall: Please help me to this problem ! Thanks (4 Replies)
Discussion started by: UsmanUrRehman
4 Replies

7. Solaris

Thread Dump not working

Hello, I'm running a kill –QUIT on few process IDs (OS: Solaris) but the Thread Dump is empty. Can you please help me get it back on? Since I'm quite new to this, I'm not aware of the checks. Please let me know for the info required to debug this issue. Thanks! (3 Replies)
Discussion started by: DevendraG
3 Replies

8. Solaris

GUI not working... CLI is working fine

Hello, I have X4500 running Solaris 10. I can access it through CLI but I cannot see the GUI. When I reboot it, the GUI works till all the files are loaded (ie., the initial boot sequence) and it prompts me to enter username and password and there it ends. The screen just has a blinking cursor... (4 Replies)
Discussion started by: bharu_sri
4 Replies

9. Shell Programming and Scripting

NAWK Script not working fine

Hello to all can any one help me out with a nawk script. Actually i am having a shell script which uses nawk pattern searching and it is not parsing the file properly. I have been debugging it since long time, but nt able 2 find the root cause.. If any one can help me out with this one .. (3 Replies)
Discussion started by: dheeraj19584
3 Replies

Featured Tech Videos