Issue with "rsh" on RedHat

Tags
advanced, issue, quot, redhat, rsh

 
Thread Tools Search this Thread
# 8  
Old 1 Week Ago
Hi Guys,

Thanks for the pointers, I'll check them out as soon as I get into the office in the morning.

Regards

Gull04
# 9  
Old 1 Week Ago
On some systems, rsh is a "remote" shell. On other systems, rsh is a "restricted" shell. On SunOS, I think you'll find that depending on how $path (if you are using a csh derivative shell) or $PATH (if you are using a Bourne shell (sh) derivative) is set in your environment, rsh may be a link to sh (and treated as a restricted shell) instead of being a link to ssh (and treated as a remote shell).

What shell are you using as your login shell for the account that is having problems on SunOS? What output do you get from the command:
Code:
printf 'PATH="%s"\npath="%s"\n' "$PATH" "$path"

This User Gave Thanks to Don Cragun For This Post:
Neo (1 Week Ago)
# 10  
Old 1 Week Ago
Hi Don,

The problem isn't on the Solaris (Whole Root Zone) server, all the other Unix servers can execute the command without issue.

This Redhat 7.4 server is the only one on the estate exibiting a problem, the rsh action fails only when a parameter like uname is passed. A simple rsh to the box works fine - I know that this uses rlogin and have been investigating further this morning.

I will spend more time on this today and will go through the earlier posts to check what people have suggested, here's your request;

Code:
isd250# su - autoupd
$
$ printf 'PATH="%s"\npath="%s"\n' "$PATH" "$path"
PATH="/usr/bin::/usr/bin:/usr/ucb:/etc:/usr/sbin:."
path=""
$ grep autoupd /etc/passwd
autoupd:x:26488:1:Autoupdate user:/export/home/autoupd:/usr/bin/rksh
$

Regards

Gull04
This User Gave Thanks to gull04 For This Post:
Neo (1 Week Ago)
# 11  
Old 1 Week Ago
Quote:
Originally Posted by gull04
It all hangs and you have to "ctrl C" to break out, but by doing;
Code:
[root@fbakirmsir1 autodoc]#  rsh -l autoupd 10.3.100.95
Last login: Thu Jan 10 14:20:32 from fbakirmsir1
$ uname -s
SunOS
$ uname -a
SunOS isd250 5.10 Generic_150400-46 sun4v sparc sun4v
$ exit
rlogin: connection closed.
[root@fbakirmsir1 autodoc]#

So, if i get that right: rsh hangs until you press CTRL-C when called from a script (?) but works when issued manually, from the commandline.

First suspicion is that there is a difference in the environment of the script and your interactive enivronment, so how about dumping the respective environments (via an inserted set > /some/file) and cast a diff on them? Also - as this will not be shown by this method - check for eventual aliases and the like. This is basically the same idea as Don Cragun had, but generalised to other settings than PATH.

Or - you will have to test that - does it always not work for the first time and work for the second (and subsequent) time(s)? Such behavior usually results from something being loaded/configured "on demand" but not completely being able to fulfill the current sessions request - the current session will fail but any subsequent session will work. (Sorry for being so vague but i don't know your system well enough to come up with any more concrete ideas).

I hope this helps.

bakunin
This User Gave Thanks to bakunin For This Post:
Neo (1 Week Ago)
# 12  
Old 1 Week Ago
Hi Folks,

I said at the begining of this thread that it should have been posted in the Unix for Dummies section and as it transpired that was correct.

When we build servers like these there is a process, it is a bit convoluted - but it delivers the desired end result. But that would appear to be when one person works on it.

The problem turned out to be the firewall had been turned back on by one of our offshore people, I had already stopped the service as per the build standard and created all the support users, one of them had - whilst setting up his environment decided to have a look around the server and contrary to what he was supposed to do. He started the firewall because he assumed that the server would need it!

Turning off the firewall resolved the problem, but didn't get me back the missing day!

Many thanks for all the suggestions and assistance on this.

Regards

Gull04
These 3 Users Gave Thanks to gull04 For This Post:
Don Cragun (1 Week Ago) Neo (1 Week Ago) RudiC (1 Week Ago)
# 13  
Old 1 Week Ago
Quote:
Originally Posted by gull04
Hi Don,

The problem isn't on the Solaris (Whole Root Zone) server, all the other Unix servers can execute the command without issue.

This Redhat 7.4 server is the only one on the estate exibiting a problem, the rsh action fails only when a parameter like uname is passed. A simple rsh to the box works fine - I know that this uses rlogin and have been investigating further this morning.

I will spend more time on this today and will go through the earlier posts to check what people have suggested, here's your request;

Code:
isd250# su - autoupd
$
$ printf 'PATH="%s"\npath="%s"\n' "$PATH" "$path"
PATH="/usr/bin::/usr/bin:/usr/ucb:/etc:/usr/sbin:."
path=""
$ grep autoupd /etc/passwd
autoupd:x:26488:1:Autoupdate user:/export/home/autoupd:/usr/bin/rksh
$

Regards

Gull04
Hi Gull04,
I'm glad to hear that you found the problem and got it fixed.

However, note the part of your $PATH setting marked in red above...
First, you don't need /usr/bin in $PATH twice. Having it there twice will only serve to slow down starting up any utility that is not found in /usr/bin or whatever directory you shell assumes is specified by have two <colon>s together in $PATH.

And, maybe more importantly, the standards don't say what happens when you have two <colon>s together in $PATH. The unspecified directory denoted by the two adjacent <colon>s between the first two instances of /usr/bin in your path could be treated as an error (silently ignored but slowing down starting up any utility that is not found in /usr/bin), could be treated as a request to use the current working directory (effectively moving . from the end of your $PATH setting to instead be in second position), or as a request to use / at that position (with the effect varying greatly depending on what is being executed and what utility is being invoked). My (unsupported by any experimentation) guess would be that using / might be the most likely action a shell might take and the most likely to cause hard to track down intermittent anomalies at some point in your future. Any or all of the effects listed above could also vary from shell to shell.

I strongly suggest that you find out what is setting $PATH this way and fix it. I wish you good luck in finding the cause.

Cheers,
Don
These 2 Users Gave Thanks to Don Cragun For This Post:
gull04 (1 Week Ago) Neo (1 Week Ago)
# 14  
Old 1 Week Ago
Quote:
Originally Posted by gull04
The problem turned out to be the firewall had been turned back on by one of our offshore people, I had already stopped the service
In addition to what Don Cragun already said: how on earth can a user get the privileges necessary to turn on the firewall?? In a long (and rather depressing) life as a systems administrator i learned that admins should be like gods: i am your root - thou shalt have no others besides me!

In AIX there is a file /etc/nologin, which, when in place, prevents any login. (It is deleted automatically upon reboot, so it can't be forgotten.) Maybe there is something alike in RHEL, which you could incorporate to your deployment process to prevent these things? If not: how about killing getty instead? That would also prevent new logins until a final reboot, which should perhaps be the last step in a customisation process anyway.

I hope this helps.

bakunin
These 2 Users Gave Thanks to bakunin For This Post:
gull04 (1 Week Ago) Neo (1 Week Ago)

|
Thread Tools Search this Thread
Search this Thread:
Advanced Search

More UNIX and Linux Forum Topics You Might Find Helpful
Bash script - Print an ascii file using specific font "Latin Modern Mono 12" "regular" "9" jcdole Shell Programming and Scripting 1 4 Days Ago 06:37 AM
"Unable to Detect Newly added HDD - Redhat 5" Sricharan21 Red Hat 1 11-09-2016 01:43 PM
Using "mailx" command to read "to" and "cc" email addreses from input file asjaiswal UNIX for Dummies Questions & Answers 2 10-11-2014 10:32 PM
""Help Me!""Beginner awk learning issue csrohit Shell Programming and Scripting 6 03-05-2012 04:55 AM
how to use "cut" or "awk" or "sed" to remove a string timmywong Shell Programming and Scripting 8 02-12-2012 12:55 PM
DELL M910 with RedHat Linux 5.5 getting "Buffer I/O error on device sdd" devyfong Red Hat 7 08-19-2011 04:07 AM
awk command to replace ";" with "|" and ""|" at diferent places in line of file shis100 Shell Programming and Scripting 7 03-16-2011 09:59 AM
"if" and "then" statement is not working in RedHat Afi_Linux Red Hat 10 01-28-2011 04:26 AM
rsh server "script..." which $PATH is used ? Browser_ice AIX 1 08-14-2009 06:11 PM
Where to set the right "Apache" to run after reboot on a RedHat 5 machine ?! mehdi1973 UNIX for Advanced & Expert Users 4 07-27-2009 09:38 AM
xx=`date +"%a %b %d"`;rsh xxx grep "^$XX" zzz ? Browser_ice AIX 2 06-13-2009 09:39 AM
"No Drives Found" error during Redhat Linux AS 4 installation pieman8080 Red Hat 2 10-13-2008 12:05 PM
Explain the line "mn_code=`env|grep "..mn"|awk -F"=" '{print $2}'`" Lokesha UNIX for Dummies Questions & Answers 4 12-20-2007 01:52 AM
Failed to check status code in "rsh" command nir_s Shell Programming and Scripting 9 07-03-2006 10:05 AM