Storedge A1000 Controller Firmware question


 
Thread Tools Search this Thread
Top Forums UNIX for Advanced & Expert Users Storedge A1000 Controller Firmware question
# 1  
Old 12-19-2005
Data Storedge A1000 Controller Firmware question

Hello everyone. I'm trying to setup two A1000s connected to a single host w/ a dual port adapter. The host is a V480.

Do I need to have thesame firmware version on both controllers for the A1000s? If so, where can I download the latest and greatest firmware? I tried to google for it and searched relentlessly at sun's website without success.

Please help.
# 2  
Old 12-20-2005
Having the same firmware would be better - searching sunsolve.sun.com for A1000 and firmware (under advanced search - using only symptoms and resolutions) will show which patch you should be looking for (112125 for Solaris 2.6 and 7, 112126 for 8 and above). Go to the patch finder and put one of those numbers in to get the patch.
# 3  
Old 12-20-2005
Right now I have one controller up to Firmware Level 03.01.04.68 and the other to Firmware Level 03.01.04.81.

I tried to install patch 112126-09, but it fails. I know I have RM6 installed, but it still fails.
# 4  
Old 12-20-2005
What error do you get?

The other thing I'm surprised about is that you can just pop a patch on any time. You did follow the special instructions for the patch and had the server in a quiet state, correct?
# 5  
Old 12-20-2005
What do you mean, quiet state? Do you mean, I need to be in a certain run level?
# 6  
Old 12-20-2005
can you communicate with the A1000? try the commands in /usr/lib/osa/bin whether the raid manager can talk to the storage. have you rebooted after the installation of the rm6? the rm6 initialize some driver at boot time. are you using the latest 6.22.1 raid manager and the patch 112126 is for that 6.22.1 only. which solaris release are you using, the rm6 is only supported on s8 and s9. looking into the patch readme there are also special instructions:
-----------------------------
These special instructions only apply if upgrading from a patch prior to
112126-06

If the raid controller firmware version is not 03.01.04.75 or greater,
the firmware in this patch must be loaded by using the RM6 maintenance
application before actually using the arrays.

All arrays connected to the host where this patch is installed must have
the same firmware level.

If LUNs are missing after upgrading, perform /usr/lib/osa/bin/hot_add to
regain access to missing LUNS.

Once this patch has been installed, the system will need to be re-booted
to insure the new rdriver is loaded.

greetings PRESSY
# 7  
Old 12-20-2005
can you communicate with the A1000? yes

try the commands in /usr/lib/osa/bin? yes

fwutil and raidutil, etc....

have you rebooted after the installation of the rm6? yes

more than once

are you using the latest 6.22.1 raid manager and the patch 112126 is for that 6.22.1 only?

Yes, we installed RM 6.22.1. However, patch 112126 is not installed. I entered patchadd -p | grep 112126 and there was no output.

which solaris release are you using, the rm6 is only supported on s8 and s9?

# uname -a
SunOS hostname 5.9 Generic_118558-09 sun4u sparc SUNW,Sun-Fire-480R

One of the A1000 controllers has a higher firmware level than 03.01.04.75, but the other does not. Here is the output:

# raidutil -c c3t5d0 -i
LUNs found on c3t5d0.
LUN 0 RAID 0 69967 MB
LUN 1 RAID 0 69967 MB
LUN 2 RAID 5 139934 MB
LUN 3 RAID 5 139934 MB
LUN 4 RAID 5 139934 MB

Vendor ID Symbios
ProductID StorEDGE A1000
Product Revision 0301
Boot Level 03.01.04.00
Boot Level Date 04/05/01
Firmware Level 03.01.04.68
Firmware Date 06/22/01
raidutil succeeded!

# raidutil -c c2t5d0 -i
LUNs found on c2t5d0.
LUN 0 RAID 0 69967 MB
LUN 1 RAID 0 69967 MB
LUN 2 RAID 5 139934 MB
LUN 3 RAID 5 139934 MB
LUN 4 RAID 5 139934 MB
LUN 5 RAID 0 69967 MB

Vendor ID Symbios
ProductID StorEDGE A1000
Product Revision 0003
Boot Level 03.01.04.00
Boot Level Date 04/05/01
Firmware Level 03.01.04.81
Firmware Date 10/17/03
raidutil succeeded!

We've decided to move on with our project. We really need this machine up and running as soon as possible.

LUNs has been configured on both A1000 and disksuite mirrored one a1000 to the other.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Hardware

Sun T5220 Firmware question

Hello all, I've been researching this to no avail, I have a T5220 running firmware 7.2.2.e (139442-06) However, the issue I have is that I want to update the firmware yet Oracle maintains 3 different sets of firmware for the T5220: 7.2.x = (139442-14) Being the latest at 7.2.11.a;... (4 Replies)
Discussion started by: seckure
4 Replies

2. Solaris

how to create luns in A1000

hi friends how we can create luns in A1OOO storage ..plzhelp its very urgent when ever i am connect to A1000 raid controller through laptop with console cable with the help of hyperterminal..i isued serial port parameters which i mentioned below.. Set serial port parameters to: �... (1 Reply)
Discussion started by: tv.praveenkumar
1 Replies

3. Solaris

A5200 vs A1000

I'm currently planning to improve my skills on sun disk array and deciding whether to go with sun disk array A5200 or A1000. I have found a few good systems with decent price but still can't seem to find out which one to choose. For the host system, I have 1 ultra 5 and 1 e220r system. I will most... (5 Replies)
Discussion started by: agfa_109
5 Replies

4. Filesystems, Disks and Memory

Poor read performance on sun storedge a1000

Hello, i have a a1000 connected to an e6500. There's a raid 10 (12 disks) on the a1000. If i do a dd if=/dev/zero of=/mnt/1 bs=1024k count=1000 and then look at iostat it tells me there's a kw/s of 25000. But if i do a dd of=/dev/zero if=/mnt/1 bs=1024k count=1000 then i see only a... (1 Reply)
Discussion started by: mbrenner
1 Replies

5. Solaris

How can i connect storedge A1000 to E250box?

Hello Experts, I am using E250 on that solais 10 5/08 installed. I am unable to see disks. I connected 2 disks in that storage of 18gb each. When I run format command it is showing that 2 disks one is operating system and another one is 6MB. I checked probe-scsi and probe-scsi-all at ok... (6 Replies)
Discussion started by: younus_syed
6 Replies

6. Solaris

A1000 Solaris 10 on Blade 1000

I have a SUN Blade 1000 running Solaris 10 and an A1000 array. I know that this combo is not supported by SUN but will it work? The raid manager software is installed and it says that the firmware needs to be upgraded -it is at I think level 2.05 something. I can see all the disks in a... (13 Replies)
Discussion started by: tribbles
13 Replies

7. Solaris

Using Enterprise 4500 with storedge D100 and storedge A5200

Sorry if this seems trivial. i have been given a task at work to configure a sun processing server "enterprise 4500" so it can work with the a storage server "storedge A5200" and "storedge D1000" the truth is i have never worked on a sun server before. i need a guideline (step by step) as to... (5 Replies)
Discussion started by: lawalidowu
5 Replies

8. UNIX for Dummies Questions & Answers

A1000 Battery Question

After searching and finding the link to the A1000 pdf ( http://192.18.99.138/805-7147/805-7147.pdf ) my questions are: 1) I have a battery failure on a A1000. I know that caching is disabled and it reports to see log. After reading the manual I have learned that the battery is a data-cache... (2 Replies)
Discussion started by: finster
2 Replies

9. UNIX for Advanced & Expert Users

Raid A1000 with E450 and E250.

Hi, I'm facing problem in connecting a Raid A1000 to E250 and E450. ( Both machines with Solaris 2.6 OS and patched, with different scsi-initiator-ids - 7 & 3 ). BTW, I'm not using this setup to access raid data from both machines simultaneously. There is Veritas Cluster Server monitoring... (1 Reply)
Discussion started by: shibz
1 Replies

10. UNIX for Dummies Questions & Answers

veritas/STOREDGE A1000

Hi, I am a Dba and very new to filesystems and stuff. I think that we have Veritas filesystems on my Sun SOlaris 5.8 box, how do I confirm this: all my filesystems are mounted like this: /dev/vx/dsk... Now we are also using disk arrays (storedge a1000) how do I access them from the system.... (1 Reply)
Discussion started by: knarayan
1 Replies
Login or Register to Ask a Question

Featured Tech Videos