Visit The New, Modern Unix Linux Community


Identifying onboard PCI device


 
Thread Tools Search this Thread
Top Forums UNIX for Advanced & Expert Users Identifying onboard PCI device
# 1  
Question Identifying onboard PCI device

Hi all,

I have customized tool that displays PCI device information (something similar to the linux - "lspci") . Now, I need to display information only on "plug-in" cards. Are there any ways to distinguish between "on-board" PCI device and a PCI "plug-in" card.

Thanks,
Dhilip
# 2  
Waht hardware and OS are you talking about?
# 3  
CPU & Memory

The hardware is a Intel server board. The OS that I'm using is SVR4.2 MP-RAS UNIX.

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #262
Difficulty: Easy
During the Second World War, Alan Turing worked for the Government Code and Cypher School (GC&CS) at Bletchley Park, Britain's codebreaking centre that produced Ultra intelligence.
True or False?

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Have troubles with bash script: xubuntu systemd.link onboard

Hey there. I'm new in write bash scripts in fact this is my first one so please be patient ;). Also english is not my native language but i hope you understand me anyway. I installed xubuntu on my mothers laptop and every time a new version update gets installed the keyboard doesn't work... (9 Replies)
Discussion started by: Apop85
9 Replies

2. Hardware

Seeking advice on onboard graphic card

Hi all, I'm prepared building a new PC for testing ONLY. I don't game. Neither I'll do graphic editing on the new box. There are about 30 VMs installed running VirtualBox as virtualizer but not all of them running at the same time. Most VMs are servers. I do configuration on terminal with... (4 Replies)
Discussion started by: satimis
4 Replies

3. Red Hat

Unable To Activate Ethernet Network Device in RHEL 5.5 - e100 device eth0 does not seem to be presen

Hi All, Could anyone please help to resolve the below problem. I installed RHEL5.5 in my desktop.But when i try to activate the ethernet connection then it gives me the error. I spent 2 days for the above and go through with several suggestion found by googling. But no luck. ... (0 Replies)
Discussion started by: Tanmoy
0 Replies

4. Red Hat

Find out which eth or device belongs to interface "port 1 PCI 4"

Hi, I┤ve given only this info to configure a network interface : "port 1 PCI 4" I┤ve been searching for any kind of relationship in the system which allow me to find the etc that must be configured... Please, could anybody help me? rhxx:#/root# lspci |grep -i "PCI BRIDGE" 00:01.0 PCI... (0 Replies)
Discussion started by: pabloli150
0 Replies

5. AIX

unknow pci device as seen by lsslot or lscfg

on a p5 520, running aix 7.1 with the latest TL and SP.. had a 133 MHz Sun PCI 1G or quad 4 x 100 Meg Ethernet card installed.. but it shows unknown type using using lscfg or lsslot Is there addtional drivers to be installed ??? did the same thing on a SYMBIOS Ultra320 diff... (2 Replies)
Discussion started by: ppchu99
2 Replies

6. Red Hat

Enter Bios and disable onboard NICS?

Hi, I have to get into BIOS and disable onbaord NICS for an IBM server, can someone please help me out. I tried hitting F1 when reboot to get into BIOS, but it seems like a setup screen and I dont see any option to disable NICS? Thanks Sam (0 Replies)
Discussion started by: sam4919
0 Replies

7. Solaris

Ultra 10 Creator 3D: enabling onboard VGA

Hello, I have an Ultra 10 Creator 3D working fine with a Sun monitor, but I'd like to use it with a VGA flat panel (it would be great if I could use both screens simultaneously). As I've read in a previous thread (https://www.unix.com/sun-solaris/14875-creator-3d-video-adapter.html) this box... (1 Reply)
Discussion started by: ama
1 Replies

8. SCO

Anyone know how to fix a pci device unknow message

Hi I just buy a new PCI 66 scsi smart array 5300 compaq card, and when I instaled it on an ML350 on the slot pci 66 doesn't works, on bios say unknow pci device, i put it on another ml 330 server and it's the same, finally i tested it on an ML530 server wi┐hich has one of that kind of card and it... (0 Replies)
Discussion started by: jactroo
0 Replies

9. AIX

Onboard Sound

Is there a command to make the onboard sound beep? (0 Replies)
Discussion started by: dig1tal
0 Replies

10. Programming

PCI device probe and find

:confused: Hi, everybody. Pleeeeese HLP!!! I write PCI device driver for bridge controller PCI-VME bus in freeBSD 2.2. And firs run function probe(): static char* probe(tag, type). Whuy probe() don't work for my vendorID and deviceID (bridge controller and videoadapter). But... (1 Reply)
Discussion started by: Alex_T
1 Replies

Featured Tech Videos