rm -rf not working on AIX 6.1


 
Thread Tools Search this Thread
Top Forums UNIX for Advanced & Expert Users rm -rf not working on AIX 6.1
# 1  
Old 01-29-2010
rm -rf not working on AIX 6.1

Hi Guys,

I have never seen this happen before, but created a directory as a user when installing some software, software install fails so I try and remove the directory as root and get an error. There is no processes using the folder see output:

Code:
ls -l
total 446336
-rwxr-----    1 u0008862 staff           124 Jan 26 13:11 .profile
-rw-------    1 u0008862 staff          3606 Jan 29 06:44 .sh_history
drwxr-xr-x    4 u0008862 staff           512 Jan 29 06:36 NParchive-dist
-rwxr-xr-x    1 u0008862 staff         42235 Jan 29 05:39 RainStor-4.0.0.0.AIX6.powerpc.sh
-rw-r--r--    1 u0008862 staff     228423680 Jan 29 06:15 RainStor-4.0.0.0.AIX6.powerpc.tar
drwxr-sr-x    2 u0008862 staff           512 Jan 29 06:27 bak
drwxrwx---    2 root     system          512 Jan 26 00:19 lost+found
lb424p038_pub[/home/u0008862] > rm -rf NParchive-dist
rm: 0653-611 Directory NParchive-dist/lib is not empty.
rm: 0653-611 Directory NParchive-dist/sbin/oa6/admin is not empty.
rm: 0653-611 Directory NParchive-dist/sbin/oa6 is not empty.
rm: 0653-611 Directory NParchive-dist/sbin is not empty.
rm: 0653-611 Directory NParchive-dist is not empty.
lb424p038_pub[/home/u0008862] > id      
uid=0(root) gid=0(system) groups=2(bin),3(sys),7(security),8(cron),10(audit),11(lp)
lb424p038_pub[/home/u0008862] > rm -rf NParchive-dist
rm: 0653-611 Directory NParchive-dist/lib is not empty.
rm: 0653-611 Directory NParchive-dist/sbin/oa6/admin is not empty.
rm: 0653-611 Directory NParchive-dist/sbin/oa6 is not empty.
rm: 0653-611 Directory NParchive-dist/sbin is not empty.
rm: 0653-611 Directory NParchive-dist is not empty.
lb424p038_pub[/home/u0008862] > fuser NParchive-dist
NParchive-dist:


Last edited by pludi; 01-29-2010 at 09:18 AM.. Reason: code tags, please...
# 2  
Old 01-29-2010
Could it be your directory is on a NFS mounted file system?
# 3  
Old 01-29-2010
Yes thank you I cant believe I didnt notice that using an IBM loan box didnt think they would give us our storage on a non-posix file system!
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. UNIX for Beginners Questions & Answers

AIX 4.3 - Need help - Printers not working

I am running an old IBM P-Series server running AIX 4.3 (I know a dinosaur). The OS has not been updated. We had a hard drive failure last weekend, and I was able to get most of the system back up, however, I have 3 line printers and 3 label printers that I can not get working. I have tried... (2 Replies)
Discussion started by: Patrick.Crocker
2 Replies

2. Shell Programming and Scripting

Syntax Error in AIX but working in UX

MENU_INTRO(){ date="`date`" HOSTNAME="`hostname`" if ; then cols=$2 else cols=2 fi clear now=`date +%A,%B-%d-%Y@%H:%M:%S` echo " -: INFORMIX DBA MENU :- " echo... (1 Reply)
Discussion started by: fedora132010
1 Replies

3. Shell Programming and Scripting

Find command not working on AIX

Hello, I am running find command in an AIX Server to find last 7 days modified directories/files. >cd /usr/openv/netbackup/db/class >ls -l total 0 drwxr-xr-x 3 root system 256 May 28 2014 Catalog-Backup drwxr-xr-x 3 root system 256 Sep 18 2012 ... (4 Replies)
Discussion started by: rahul2662
4 Replies

4. UNIX for Dummies Questions & Answers

Ssh stopped working AIX

I Was able to ssh into the AIX box. now i cannot When I run the command to start it it comes back that is was started, but still does not work. Here is a shot i what i see # server:/> lslpp -l | grep ssh openssh.base.client 4.3.0.5201 COMMITTED Open Secure Shell Commands ... (2 Replies)
Discussion started by: fierfek
2 Replies

5. AIX

rssh not working in AIX 6.1

edit by bakunin: double post SNIPped. Hi, I have a similar problem with my AIX 6.1. In AIX 5.3, I have successfully implemented rssh for the caging of my SFTP users. Since we just upgraded to AIX 6.1 TL6 SP7, the rssh does not work. The SFTP works when the user's shell is set to ksh, but... (1 Reply)
Discussion started by: eddie.lee
1 Replies

6. AIX

suid not working on AIX ?

Hello, I'm running AIX 6.1 box. I tried to use suid on binary file but it doesn't work. (I set suid on /usr/bin/sleep and tried to run it as user1(sleep owner is bin) - and program still runs as user1. It shoud run as bin isn't it ? - This test run as expected on Linux box) Filesystem is... (3 Replies)
Discussion started by: vilius
3 Replies

7. Shell Programming and Scripting

*/5 not working in AIX

Hi Guys, I tried to schedule a script for every 5 mins. i tried */5 but it is not working. Is writing every 5 mins is the only way to do it? like below 05,10,15,20,25,30,35,40,45,50,55 05-08 Thanks And Regards, Magesh (11 Replies)
Discussion started by: mac4rfree
11 Replies

8. AIX

HACMP 5.4 with AIX 5300-10 not working

I have two IBM_9110-51A boxes OS - fresh installs 5764-G03 TL 5300-10-00 disks dated 5/2009 HACMP - fresh installs HACMP for AIX 5L Base V5.4 5765-F62 dated 7/2006 Bottom line for smit output attempting 2 node cluster config ... (2 Replies)
Discussion started by: DrKillPatient
2 Replies

9. AIX

prtconf command not working in Aix 5.3

put prtconf command,after show this error message: bash-3.00# prtconf /usr/sbin/prtconf: msize=msize + 12544^J12544: syntax error pleae help me...........waiting for replay by mohan.s Aix sysadmin (deleted email, rule violation) (2 Replies)
Discussion started by: smohan62
2 Replies

10. AIX

^P Not working on AIX.

I'm working on an AIX box, and I generall prefer emacs command line editing in ksh. Most control-commands are working, except not control-P (Recall previous command). ksh set - o emacs ^p Does not result in the expected outcome. does anyone know why this might be? (0 Replies)
Discussion started by: akbar
0 Replies
Login or Register to Ask a Question

Featured Tech Videos