Ksh Create Thread


 
Thread Tools Search this Thread
Top Forums UNIX for Advanced & Expert Users Ksh Create Thread
# 1  
Old 05-28-2009
Question Ksh Create Thread

I think I know the answer but I'll ask and see if someone with more expertise can share new light on this topic: Does Ksh have the capability to create new threads (not processes) and/or offer some multiplexing on named pipes?

Thanks for your assistance!
~sreyes27
# 2  
Old 05-29-2009
The short answer is - no for ksh93, ksh88, pdksh.
# 3  
Old 05-29-2009
Bug RE: Ksh Create Thread

That's what I thought. Thanks.
~sreyes27
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Forum Support Area for Unregistered Users & Account Problems

Unable to create new thread

Hi. I registered, but when trying to post, I get ... "Sorry, you do not have enough Bits to post a new thread" Google & Forum search showed some hits, but no solution. Please advide. Thanks! (1 Reply)
Discussion started by: gehe
1 Replies

2. Forum Support Area for Unregistered Users & Account Problems

I am still meet a problem when I want to reply or create a new thread

Hi, Scott, I am still meet a problem when I want to reply or create a new thread in "Shell Programming and Scripting" Forum, It reminds that: To create new threads in this forum your post count must be 10 or greater. You currently have 2 posts. To my surprise, I posted a thread in "Shell... (4 Replies)
Discussion started by: weichanghe2000
4 Replies

3. Shell Programming and Scripting

Create Log File in ksh itself

Hi, I want to create a log file for a running ksh , and the log file absolute path I want to give in ksh itself. To elaborate this - Say I have a ksh - timer.ksh and I want to create a log timer_log.log when I run, to trace this. I am aware of the fact that this can be done using redirection... (4 Replies)
Discussion started by: vinay4889
4 Replies

4. UNIX for Advanced & Expert Users

Pthread attr setting doesn't work before thread create?

Hello everyone, I created a test program for pthread priority set. Here's the code, very simple, 60 lines only. I've tried this prog on my Fedora 13(on vbox), and on my 6410 arm linux 2.6.36. Both the same result. Both environments are using root privileges. Can any body tells me why the... (15 Replies)
Discussion started by: ss1969
15 Replies

5. Post Here to Contact Site Administrators and Moderators

How to Create a New Thread

please tell me how can i post a new post. i am not getting any option to post a new question. any suggestion is highly appreciated. thanks, Arpit (1 Reply)
Discussion started by: thearpit
1 Replies

6. Programming

Unable to create a UDP client from thread?

I try to initial a UDP client from threading, but it doesn't work? why? These codes from the textbook #define ECHOMAX 255 /* Longest string to echo */ #define TIMEOUT_SECS 2 /* Seconds between retransmits */ #define MAXTRIES 5 /* Tries before giving up */... (3 Replies)
Discussion started by: sehang
3 Replies

7. Programming

how to create variable for all thread in c++

hello I have this code #include <sys/types.h> #include <unistd.h> #include <iostream> #include <pthread.h> #include<cstring> using namespace std; int var1=0; void doSomething() { var1 = 5; cout<<"Do S :"<<var1<<endl; sleep(1); var1 =7; (4 Replies)
Discussion started by: vip_a1
4 Replies

8. Shell Programming and Scripting

How to create file in ksh scripting with permission(rw-rw-rw)

Hi, Please provide your inputs.. Thanks in Advance, Mansa (1 Reply)
Discussion started by: mansa
1 Replies

9. Programming

create a thread from a returning function

hi all, my requirement is to create a thread by calling another function. i.e i dont call pthread_create directly from main, but by calling another function (createThd - below ), from main. Example: void *thread_function(void *arg) { /* thread function */ int i; rc =... (3 Replies)
Discussion started by: wolwy_pete
3 Replies

10. HP-UX

create thread C with JNI function with JAVA

Hello, J create a thread C with a JNI function via JAVA. J have the following message (but not in each time): Someone has an idea ? Thank. Unexpected Signal : 4 occurred at PC=0x78C103E0 Function= Library=(N/A) NOTE: We are unable to locate the function name... (0 Replies)
Discussion started by: AUBERT
0 Replies
Login or Register to Ask a Question

Featured Tech Videos