Visit Our UNIX and Linux User Community


Starting X in NetBSD


 
Thread Tools Search this Thread
Special Forums UNIX Desktop Questions & Answers Starting X in NetBSD
# 1  
Old 02-25-2002
Starting X in NetBSD

Hi I have NetBSD and i am having a trouble Starting X. It keeps asking me for the config file and I run the text confing file but it messes up. I really want to be able to run the Graphical Setup. I read about the Graphical setup from a book but they didn't tell how to start it. help please!?
# 2  
Old 02-26-2002
Have you tried running the command "startx"?
# 3  
Old 02-26-2002
Are you using XFree86 3.3.6 or XFree86 4.x.x?
# 4  
Old 02-26-2002
i am running XFree86 and I think i have to configure the config file. But when ever i try to there is some error like: "screen cannot be found" or something.
# 5  
Old 02-26-2002
But which version of XFree86 are you running.

For example, with the distribution of FreeBSD you can install XFree86 3.3.6 or you can compile a newer version, XFree86 4.1.0. The configuration for each version is different from each other and it is important to know the version of XFree86 that you are trying to run.

If you don't know the version of XFree86, then it might be narrowed down by what Unix flavor that you are using.
# 6  
Old 02-27-2002
Try running the command "uname -a" to let us know what system you're using. Also, for configuration, try running the command "xf86config" as root. And please try to capture somehow the actual error you're getting. It'll help pinpoint the problem a lot better.
# 7  
Old 02-28-2002
ok i used the uname -a command and found out that i am running "NetBSD 1.5.2". The X that I am using is the standard one that comes with the system install. I have been messing around with the xconfig and i get this error: " Fatal server error: no screens found"

Previous Thread | Next Thread
Test Your Knowledge in Computers #413
Difficulty: Medium
The AT&T 3B1, also known as the PC7300 or UNIX PC, was a desktop workstation computer based on the Motorola MC68010 microprocessor, running an operating system from Convergent Technology (based on Unix System V Release 2).
True or False?

8 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

How to grep a line not starting with # from a file (there are two lines starting with # and normal)?

e.g. File name: File.txt cat File.txt Result: #INBOUND_QUEUE=FAQ1 INBOUND_QUEUE=FAQ2 I want to get the value for one which is not commented out. Thanks, (3 Replies)
Discussion started by: Tanu
3 Replies

2. BSD

NetBSD on OLD laptop

I want to install NetBSD on the Compaq LTE 5000. ("Of course it runs NetBSD!!") But the laptop does NOT have a CD-ROM drive. How can I solve?? Thanks for any reply! :) PS: I hope i'm posting in the right item... (2 Replies)
Discussion started by: mghis
2 Replies

3. Virtualization and Cloud Computing

NetBSD on VirtualBox

Hello, guys! I use Ubuntu 9.04 as desktop operating system and I want to make some tests on NetBSD. I tried to install as a virtual sistem on VirtualBox but it doesn't want to install. You can see the error in the attached file. Do you guys have any clue about what the problem could be? (3 Replies)
Discussion started by: Sergiu-IT
3 Replies

4. UNIX for Dummies Questions & Answers

netbsd

which better freebsd and netbsd for server unix (0 Replies)
Discussion started by: salehudinayubi
0 Replies

5. BSD

netbsd

i have install netbsd but don't have gui?what happen?i want to a mount external usb hard drive but failure?what should i do? (5 Replies)
Discussion started by: ibnusina202003
5 Replies

6. BSD

NetBSD Ports

They put NetBSD on a Dreamcast. Thats just awesome. What can't they put it on!? (1 Reply)
Discussion started by: Phobos
1 Replies

7. UNIX for Dummies Questions & Answers

bash in netbsd

i recently downloaded and installed bash on my netbsd box (1.5.2) and set my shell and my root shell using user mod to change the shell, command executed under root. bash is installed from my user home directory (home/joe) and i moved the bash executable to /bin/ and everything is fine, except i... (6 Replies)
Discussion started by: norsk hedensk
6 Replies

8. UNIX Desktop Questions & Answers

NetBSD Troubles

HI, I just installed NetBSD i386 v. latest. I am having a few problems: For some reason X just won't start!? Another is I can't access My CDROM or Floppy. Thanks in advance! (3 Replies)
Discussion started by: vertigo
3 Replies

Featured Tech Videos