Visit The New, Modern Unix Linux Community


Jar command nor working in centos


 
Thread Tools Search this Thread
Special Forums UNIX Desktop Questions & Answers Jar command nor working in centos
# 1  
Linux Jar command nor working in centos

Hi All,


I have a jar file and I want to extract that jar file. I am using command

Code:
jar xf Sample_Pack.jar

After pressing enter this command returns no error and is not even executed.

Pls help
# 2  
I created a completely empty jar file and I got no output until I used "jar tvf":
Code:
$ touch fubar.jar
$ jar xf fubar.jar
$ jar xvf fubar.jar
$ jar tvf fubar.jar
java.util.zip.ZipException: zip file is empty
        at java.util.zip.ZipFile.open(Native Method)
        at java.util.zip.ZipFile.<init>(ZipFile.java:214)
        at java.util.zip.ZipFile.<init>(ZipFile.java:144)
        at java.util.zip.ZipFile.<init>(ZipFile.java:115)
        at sun.tools.jar.Main.list(Main.java:1004)
        at sun.tools.jar.Main.run(Main.java:245)
        at sun.tools.jar.Main.main(Main.java:1177)
$

Just because the command is silent and yields no results does not mean that the command did not run. My guess is that your jar file, like mine, has nothing in it that can be extracted.

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

Test Your Knowledge in Computers #287
Difficulty: Medium
AIX 7.2 was initially released on December 1, 2013.
True or False?

9 More Discussions You Might Find Interesting

1. Red Hat

Log rotation not working in Centos 7.2

All, I am facing an issue as log rotation not working for me as expected for tomcat in centos 7.2. I configured log rotation command in crontab */5 * * * * root /usr/sbin/logrotate /etc/logrotate.conf >/dev/null 2>&1 I am trying to rotate below tomcat logs owned by application... (0 Replies)
Discussion started by: shekar777
0 Replies

2. Red Hat

Network Teaming not working in RHEL/CentOS 7

I was testing Networking Teaming (activebackup) with a VM hosted on VmWare Workstation and VirtualBox, and the result is, if the active interface is down, the system is not using the backup interface. Tested on both CentOS / RHEL 7 Please find below the command I have used to configure teaming.... (0 Replies)
Discussion started by: atanubanerji
0 Replies

3. Red Hat

Os Open source dialer not working on Centos Asterisk platform

Hi We have one centos Server on Asterisk platform and using OS Open source dialer for dialing outbound connections.We are using eyebeam as a softphone for calling with Server ip 192.168.1.X.Today i found dialing issues with each client side phones.Not showing pause/resume button when browse... (0 Replies)
Discussion started by: Vaibhav.T
0 Replies

4. Shell Programming and Scripting

Want to write all the jar name in single with delimiter ":" in beween the jar name

Hi All, I am having 7 jar files in a dir. abc like listed below bash-3.00$ cd abc bash-3.00$ ls 123.jar 23wdawd.jar dfsa23.jar dsa.jar wew234.jar adsd234234.jar dfsda423.jarNow i want to assign all this jar files to a variable in the below format ... (6 Replies)
Discussion started by: natraj005
6 Replies

5. Emergency UNIX and Linux Support

New centos dedicated server - cant get mysql working

Hi all, I installed centos 5, with LAMP. httpd is working fine, ssh, ftp all working ok. But, when I try to use mysql its not, when I give the command mysql I get ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) (4 Replies)
Discussion started by: lawstudent
4 Replies

6. UNIX for Dummies Questions & Answers

CentOS using sudo command

Hi, this is my first time posting here and am new to linux/unix. So here is my question. I have two user account and a root account. root user account 1:calchen1 user account2: calchen2 Now i want to use the sudo utility to allows user to run programs with the privileges of another... (1 Reply)
Discussion started by: coolcalin812
1 Replies

7. Red Hat

xen vnc not working in Centos

i configured XEN to use port 5902 and it worked. I installed vncserver on the host machine. Now when i connect to 5902 it redirects me to the centos machine not to the XEN guest. (0 Replies)
Discussion started by: mrjoli021
0 Replies

8. UNIX for Dummies Questions & Answers

jar command not being recognized

Hi, I'm trying to extract a war file via the jar command; however, when I issue: jar -xvf MyWarFile.war I'm recieving "jar: not found" I added /usr/bin to the path ...didn't work also tried /usr/bin/jar to the path...still doesn't work My JAVA_HOME/bin is also in the path. ... (1 Reply)
Discussion started by: orahi001
1 Replies

9. UNIX for Dummies Questions & Answers

jar command not running in Unix

Hi , I am working in Sun SOlaris 9 and trying to extract a particular jar file in my home. I am giving command "jar xv <filename>" But it just hangs and does nothing ? Any pointers why this is happenning ? or how can I see contents of a jar file? Thanks (2 Replies)
Discussion started by: hkapil
2 Replies

Featured Tech Videos