Thunar Crashes running XFCE 4.10 on Sparc64 , OpenBSD 5.3

Thread Tools Search this Thread
Special Forums UNIX Desktop Questions & Answers Thunar Crashes running XFCE 4.10 on Sparc64 , OpenBSD 5.3
# 1  
Old 09-13-2013
Thunar Crashes running XFCE 4.10 on Sparc64 , OpenBSD 5.3

I use XFCE 4.10 on OpenBSD 5.3; The use of Thunar produces a core dump, if I am logged in as a user, but if I log in as root, it works fine. Obviously it is a permissions issue, but what permission on what file?

Last edited by RichardET; 09-13-2013 at 07:54 PM.. Reason: my business
# 2  
Old 09-13-2013
It's very strange for a permissions issue to cause a core dump. Not impossible, but a program would need to be pretty badly designed if it crashed rather than just spewing 'permission denied opening such file' and quitting.

I'd suggest loading these core dumps in a debugger and seeing the backtrace.
This User Gave Thanks to Corona688 For This Post:
# 3  
Old 09-13-2013
Thunar works when I run the amd64 version of OpenBSD with xfce, but when I run my Sparc box, an old Blade 100, then Thunar no longer works properly. It's probably an OpenBSD issue, guess I will live with it, by not clicking on it! Or go FreeBSD, which on Sparc is all text based, cause xorg is not installed by default and the compiling from ports takes too many days on the old machine, and nothing is gained by it.
# 4  
Old 09-13-2013
Wait, is this a different problem or the same one?
# 5  
Old 09-14-2013
The problem seems to be in the /usr/local/bin/thunar-settings config file. If I delete this file, then thunar will work for me when I use xfce, BUT, still crashes occasionally. The interesting fact is that if I do not remove the settings file, but instead access thunar inside another DE such as fvwm2, then thunar works fine!!! Obviously this is an xfce issue, not a thunar issue. My system in this case is a Sun Blade 100, with OpenBSD 5.3;

Besides this bug with thunar, the system works as advertised.

Last edited by RichardET; 09-15-2013 at 04:02 PM.. Reason: Update on what I know.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Web Development

Apache2 Crashes

The Apache server suddenly stops. I am running Debian Jessie Here are some diagnostics: root@meow:/var/www# apachectl configtest AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using Set the 'ServerName' directive globally to suppress... (4 Replies)
Discussion started by: Meow613
4 Replies

2. UNIX and Linux Applications

Apcupsd crashes

I am trying to run apcupsd, but it will not retain contact the UPS root@meow:/home/ethan/UPS/gapcmon-0.8.9# /etc/init.d/apcupsd start Starting UPS power management: A copy of the daemon is still running. If you just stopped it, please wait about 5 seconds for it to shut down.... (0 Replies)
Discussion started by: Meow613
0 Replies

3. UNIX for Dummies Questions & Answers

[Solved] Custom actions in Thunar doesn't display at all.

I have came across a few websites stating some custom actions for Thunar - crunchbang ubuntu I tried inputting the stated commands to Thunar, but it doesn't display at all in mine. I tried "gksu thunar %f" ( Opens current folder with root permissions.) , but when I right click in a... (0 Replies)
Discussion started by: Hijanoqu
0 Replies

4. BSD

Compiling BOINC/Seti@Home for OpenBSD 5.3 Sparc64

I used to use x86 Linux clients for this years ago, but ceased all activity until last night. I have resurrected an old Sun Blade 100, which used to run Solaris 9, when I first owned it, in the 2003 period, but now is very much alive with 2 gig of new ram, and and extra 10 gig of drive space... (0 Replies)
Discussion started by: RichardET
0 Replies

5. Programming

C++ program crashes

Hi, Can anyone tell me why the below program is crashing? and where exactly it is crashing. What is the corrective measure to be taken to make it work fine? #include <iostream> #include <cstring> using namespace std; class CString { char* m_data; public: CString() :... (6 Replies)
Discussion started by: royalibrahim
6 Replies

6. Red Hat

7z crashes system

Can someone tell my why every time I try to use 7z it freezes my system? I can't move my mouse, I can't type, I can't kill my xsession. I then restart my system and everything returns to normal. When I try to use 7z my system again freezes. (11 Replies)
Discussion started by: cokedude
11 Replies

7. Solaris

Server crashes when not in use.

Production server crashes when there is no traffic on it. Can only recover by going to ALOM and reboot the server. This seems to happen about the same time every month. The only good thing is the server is not in production at the time of the crash. I have been unable to locate any information in... (5 Replies)
Discussion started by: Joeentech
5 Replies

8. BSD

Installing OpenJDK on a Netbsd Sparc64 Server

I am currently working on a project that involves running the lift framework on a sun sparc64 architecture. Due to limited support from more popular unix distros, I am running NetBSD 64-bit on the system. Before i can even tackle trying to install lift, I have to be able to install... (1 Reply)
Discussion started by: techen
1 Replies

9. UNIX Desktop Questions & Answers

Automatic reload of Thunar

I am using Thunar on FreeBSD 7.1 and XFCE. I would like the thunar window to reload automatically when a file has been added or deleted. Currently I press Ctrl-R, but perhaps a setting that I dont know of will do this automatically? (0 Replies)
Discussion started by: figaro
0 Replies

10. UNIX for Dummies Questions & Answers

Finding files through Thunar

I have xfce installed with thunar as the file manager. It would be very productive to have a tool that allows the user to find files, similar to catfish (which seems to have been developed by the Ubuntu team). Does such a utility exist for non-Ubuntu OS's? (0 Replies)
Discussion started by: figaro
0 Replies
Login or Register to Ask a Question

Featured Tech Videos