Solaris 10 - Compiling package from source? Different from pkgadd?

Thread Tools Search this Thread
Special Forums UNIX Desktop Questions & Answers Solaris 10 - Compiling package from source? Different from pkgadd?
# 1  
Old 07-28-2009
Solaris 10 - Compiling package from source? Different from pkgadd?

Hey everyone,

I'm using a SPARC based Solaris 10 5/09 machine and want to install PHP support to it. I already have mysql and apache( came with OS, just started the proccess) installed, so this is the last thing before I can get to learning development Smilie However, there's something I'm not sure about.

I downloaded php 5.2.10 from PHP: Downloads but this is the "source". I'm thinking this is not installed via the usual package installation with pkgadd, there might be a compilation step involved.( I assume this because I downloaded the companion cd and all the packages are separated from the source - *,tar.bz2, same as the file i have. Am i wrong?)
How do I compile the source package before I pkgadd them? And, since this is php, is there something altogether different that i need to worry about?

Thank you very much for the help,
# 2  
Old 09-08-2009
You can get a ready compiled and packaged version of PHP from:
Sunfreeware - Freeware Open Source Software for Sun Microsystem's Solaris.

This post would have got a quicker response had it been submitted in the Sun Solaris Operating System forum.
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Solaris

Pkgadd failures with Solaris 11

I have some simple package installations that have worked in previous versions of Solaris just fine. I can install the packages, then install newer versions right over the top without error. In previous versions I had to specify the -G option during the installation in order for this to work. ... (0 Replies)
Discussion started by: moondog25
0 Replies

2. Shell Programming and Scripting

Compiling source code issue

Need assistance in compile a source code with PERL flags Compile source code CDFconvert-2.2.3 which requires Fortran 90,Perl interpreter , Perl/TK module , NetCDF library , Gempak I have all the above required libraries . Issue is when compiling the source code it looks for local... (4 Replies)
Discussion started by: ajayram_arya
4 Replies

3. Programming

Compiling C++ source file

I am trying to compile a c++ source file print_options.cpp and getting lot of errors g++ -I/media/ios120/chrisd/research/tomso-branches/tomso_12_05 /media/ios120/chrisd/research/tomso-branches/tomso_12_05/libs/program_options/print_options.cpp In file included from... (2 Replies)
Discussion started by: kristinu
2 Replies

4. UNIX for Dummies Questions & Answers

environment variables for compiling from source

Hello, I was trying to istall Gdkpixbuff 2.26.1 in my laptop ubuntu 11.10, when I did: ./configure and I got these error message *** 'pkg-config --modversion glib-2.0' returned 2.33.1, but GLIB (2.30.0) was found! If pkg-config was correct, then it is best *** to remove the old version of GLib.... (1 Reply)
Discussion started by: yifangt
1 Replies

5. UNIX for Advanced & Expert Users

How to find dependancies of .dstream package (Solaris) & .rpm package( linux)

Friends, Please let meknow, How we can find the dependancies of .dstream package & .rpm package before installation ? For AIX, We can use the inutoc . command to create the .toc file for the bff package, What about Solaris & Linux ? (0 Replies)
Discussion started by: yb4779
0 Replies

6. Solaris

Variable not expanding during Solaris pkgadd

I'm having a little trouble with a Solaris package build/install. I have the following entries in my prototype file... # Interfaces file - all versions installed and auto linked to installation type... f none $OPTDIR/config/interfaces.DEV 0444 $OWNER $GROUP f none... (0 Replies)
Discussion started by: JerryHone
0 Replies

7. AIX

Compiling samba from source in AIX 5.3

Hello all. I have never had any issues like this when compiling applications from source. When I try to compile samba-3.5.0pre2, configure runs with no issues, but when the time comes to make, this happens: make: make 1254-025 There must be an existing description file or specify a target. ... (4 Replies)
Discussion started by: raidzero
4 Replies

8. Solaris

pkgadd missing on Solaris 11

Hi, This is not a question thread, but rather a solution to an issue I have encountered on Solaris 11. It turns out that pkgadd is not available by default on Solaris 11. The solution is to install it with: pkg install SUNWpkgcmdsI hope this will save people some time. Cheers, ... (4 Replies)
Discussion started by: JVerstry
4 Replies

9. Programming

Help with Compiling large source file using g++

HI All, I m compiling a 27 MB cpp file and compiler crashes. My enviroment : RH 9, compiler g++ how i m compiling g++ -fPIC -DWITH_OPENSSL -DWITH_COOKIES -c soapC.cpp it took almost 30 -32 to throw error like report bug etc. I will post the same error, but if can any body tell how to... (2 Replies)
Discussion started by: helpmeforlinux
2 Replies

10. HP-UX

bash...Not found through where(compiling source file)

Hi i have compiled and installed bash 3.2 on my hp-ux parisc its in path /usr/local/pkg/bash/bin/bash .....When im search for this bash (through whereis bash) im not findind but other which i hve done in same procedure( gettext,m4) ..Im able to find through whereis search option can any1... (3 Replies)
Discussion started by: vasanthan
3 Replies
Login or Register to Ask a Question