Plex install & trouble wth libc6

Tags
solved

 
Thread Tools Search this Thread
# 1  
Old 06-21-2017
Plex install & trouble wth libc6

Hello group,

Running Ubuntu 16.04 on a arm64 board computer, I'm following this guide from the manufacturer, which is supposed to let me use the Plex armhf version:


ESPRESSObin Wiki | Run PLEX Media Server on ESPRESSObin


So I'm getting to:
Code:
apt-get install curl gcc-4.9-base gcc-4.9-base:armhf libc6 libc6:armhf libcurl3 libgcc1 libgcc1:armhf

This is the error:
Code:
 [17:46 david@espressobin ~] > apt-get install curl gcc-4.9-base  gcc-4.9-base:armhf libc6 libc6:armhf libcurl3 libgcc1 libgcc1:armhf
Reading package lists… Done
Building dependency tree
Reading state information… Done
libgcc1 is already the newest version (1:6.0.1-0ubuntu1).
libc6 is already the newest version (2.23-0ubuntu7).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
 The following packages have unmet dependencies:
 libc6 : Breaks: libc6:armhf (!= 2.23-0ubuntu7) but 2.23-0ubuntu3 is to be installed
 libc6:armhf : Breaks: libc6 (!= 2.23-0ubuntu3) but 2.23-0ubuntu7 is to be installed
E: Unable to correct problems, you have held broken packages.

Can anyone give me an idea how to move forward? I've posted a similar question on the boards forum but it isn't as well populated as here.

Thanks!
# 2  
Old 06-21-2017
I think its saying those two libc's are mutually exclusive. Those instructions may be outdated. You certainly don't want to mess up a libc install, as that will thoroughly trash your system.
These 2 Users Gave Thanks to Corona688 For This Post:
dpreviti (06-21-2017) drl (06-22-2017)
# 3  
Old 06-21-2017
Huh, that may have worked.. kicking myself. I'll mark this done when I get home & can test it, but I think it's working.

I did this instead and then ./start.sh and it seems to be working!
apt-get install curl libcurl3 libgcc1 libgcc1:armhf
This User Gave Thanks to dpreviti For This Post:
Corona688 (06-21-2017)

|
Thread Tools Search this Thread
Search this Thread:
Advanced Search

More UNIX and Linux Forum Topics You Might Find Helpful
Problem wth spec chars in script elxa1 Shell Programming and Scripting 4 10-30-2017 04:40 PM
Couple of questions wth grep/sort tastybeer UNIX for Dummies Questions & Answers 6 11-18-2012 05:36 PM
A simple loop made difficult WTH campanellisj Shell Programming and Scripting 5 05-30-2012 08:00 AM
Help wth Net::FTP in script sometimes fails but wsftp always works csgonan Shell Programming and Scripting 3 03-24-2011 03:23 PM
How i can install Driver ATI on OpenBSD 4.8 & HARD OpenBSD1986 Fedora 0 03-05-2011 03:12 AM
Unable to find libstdc++-libc6.2-2.so.3 smartgupta Red Hat 2 06-17-2010 10:33 AM
wth...can't read my post gcampton Shell Programming and Scripting 0 11-27-2009 10:17 PM
Download & install JDK 1.6 rinkugarg UNIX for Dummies Questions & Answers 1 08-13-2009 07:58 AM
Install & configure Openssh In Solaris 8 Remi Solaris 6 01-15-2007 05:03 PM
Trying to lose XP & Install Suse 10.1 Nick7269 UNIX for Dummies Questions & Answers 1 06-06-2006 09:48 AM
Unable to install & configure Sendmail csaha Red Hat 2 02-03-2006 02:03 PM
PHP & Apache & MySQL install how-to ? perleo UNIX for Dummies Questions & Answers 4 09-02-2003 12:42 AM