Md0 raid don't see my folders


Login or Register for Dates, Times and to Reply

 
Thread Tools Search this Thread
# 1  
Md0 raid don't see my folders

I suddenly don't see my folders into /mnt/md0.
What can be reason?

Code:
 mdadm --detail /dev/md*
/dev/md0:
        Version : 1.2
  Creation Time : Fri Jan 18 09:54:27 2019
     Raid Level : raid1
     Array Size : 1953383488 (1862.89 GiB 2000.26 GB)
  Used Dev Size : 1953383488 (1862.89 GiB 2000.26 GB)
   Raid Devices : 2
  Total Devices : 2
    Persistence : Superblock is persistent

  Intent Bitmap : Internal

    Update Time : Fri Jan 18 10:03:38 2019
          State : active, resyncing
 Active Devices : 2
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 0

  Resync Status : 4% complete

           Name : myuser:0  (local to host myuser)
           UUID : 26f5fe1c:1c272ebe:74d72e1e:0360a892
         Events : 112

    Number   Major   Minor   RaidDevice State
       0       8       16        0      active sync   /dev/sdb
       1       8       32        1      active sync   /dev/sdc

Code:
cat /proc/mdstat
Personalities : [raid1] [linear] [multipath] [raid0] [raid6] [raid5] [raid4] [raid10]
md0 : active raid1 sdc[1] sdb[0]
      1953383488 blocks super 1.2 [2/2] [UU]
      [>....................]  resync =  4.5% (89573888/1953383488) finish=214.3min speed=144938K/sec
      bitmap: 15/15 pages [60KB], 65536KB chunk

unused devices: <none>


Last edited by RudiC; 01-18-2019 at 07:36 AM.. Reason: Changed [QUOTE] tags to [CODE].
# 2  
Quote:
Originally Posted by tomislav91
I suddenly don't see my folders into /mnt/md0.
What can be reason?
Sorry if this question seems silly, but i have seen sillier than that: did you mount the FS(es)? Look at the output of

Code:
mount | grep md0

# 3  
Quote:
Originally Posted by bakunin
Sorry if this question seems silly, but i have seen sillier than that: did you mount the FS(es)? Look at the output of

Code:
mount | grep md0

Code:
mount | grep md0
root@myuser:/mnt/md0# sudo mount /dev/md0 /mnt/md0
mount: /dev/md0: can't read superblock


Last edited by RudiC; 01-18-2019 at 07:34 AM.. Reason: Removed duplicate quote; changed [QUOTE] tags to [CODE].
# 4  
It seems to be syncing - sure that doesn't influence the superblock / mounting?
# 5  
I noticed something strange now. My md change number, look

Code:
 cat /proc/mdstat
Personalities : [raid1] [linear] [multipath] [raid0] [raid6] [raid5] [raid4] [raid10]
md127 : active (auto-read-only) raid1 sdb[0] sdc[1]
      1953383488 blocks super 1.2 [2/2] [UU]
        resync=PENDING
      bitmap: 12/15 pages [48KB], 65536KB chunk

unused devices: <none>

Code:
 sudo mkfs.ext4 -F /dev/md127
mke2fs 1.43.4 (31-Jan-2017)
/dev/md127 contains a ext4 file system
        last mounted on /mnt/md0 on Thu Oct 11 09:44:02 2018
Creating filesystem with 488345872 4k blocks and 122093568 inodes
Filesystem UUID: 5458e532-e0f1-4cf9-9cdd-d016d16c21fd
Superblock backups stored on blocks:
        32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
        4096000, 7962624, 11239424, 20480000, 23887872, 71663616, 78675968,
        102400000, 214990848

Allocating group tables: done
Writing inode tables: done
Creating journal (262144 blocks): done
Writing superblocks and filesystem accounting information:
done

Maybe to wait no to finish sync?




Moderator's Comments:
Mod Comment Please make sure to use [CODE] tags for data / output, not [QUOTE]!

Last edited by RudiC; 01-18-2019 at 08:08 AM.. Reason: Changed [QUOTE] tags to [CODE].
# 6  
You don't need to wait for it to finish syncing, no.

The device changing number may have been due to a reboot, i.e. one boot was a device you made, the next reboot was auto-assembled and the device number chosen automatically.

By running mkfs on it again you wiped out whatever was on it before.
# 7  
The question is, why was this raid1 array rebuilding?

It could be that the resilvering has, for some reason, occurred in the wrong direction, meaning that your replacement disk has been mirrored over the running disk causing the data to be lost.

Did you initiate the rebuild of the raid1? Or did it start automatically?

Last edited by hicksd8; 01-18-2019 at 05:34 PM.. Reason: Correct typo's
This User Gave Thanks to hicksd8 For This Post:
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

8 More Discussions You Might Find Interesting

1. Red Hat

RAID Configuration for IBM Serveraid-7k SCSI RAID Controller

Hello, I want to delete a RAID configuration an old server has. Since i haven't the chance to work with the specific raid controller in the past can you please help me how to perform the configuraiton? I downloaded IBM ServeRAID Support CD but i wasn't able to configure the video card so i... (0 Replies)
Discussion started by: @dagio
0 Replies

2. Solaris

Software RAID on top of Hardware RAID

Server Model: T5120 with 146G x4 disks. OS: Solaris 10 - installed on c1t0d0. Plan to use software raid (veritas volume mgr) on c1t2d0 disk. After format and label the disk, still not able to detect using vxdiskadm. Question: Should I remove the hardware raid on c1t2d0 first? My... (4 Replies)
Discussion started by: KhawHL
4 Replies

3. AIX

SCSI PCI - X RAID Controller card RAID 5 AIX Disks disappeared

Hello, I have a scsi pci x raid controller card on which I had created a disk array of 3 disks when I type lspv ; I used to see 3 physical disks ( two local disks and one raid 5 disk ) suddenly the raid 5 disk array disappeared ; so the hardware engineer thought the problem was with SCSI... (0 Replies)
Discussion started by: filosophizer
0 Replies

4. Linux

If i don't have raid disks can i shut down dmraid device-mapper?

hello my centOS newly installed system loading dmraid modules on startup I did remove all LVM/raid things from system installation menus and after installation too but dmraid is still there and he says: no raid disks found also I did modprobe -r dm_raid45 and it do remove it but only until... (7 Replies)
Discussion started by: tip78
7 Replies

5. UNIX for Dummies Questions & Answers

RAID software vs hardware RAID

Hi Can someone tell me what are the differences between software and hardware raid ? thx for help. (2 Replies)
Discussion started by: presul
2 Replies

6. UNIX for Dummies Questions & Answers

Copying multiple folders to local machine (don't know folder names)

Hi. I'm trying to copy multiple folders from the remote machine to the local machine. I wrote a batch file to run an ftp window. The problem I am having is that the only command to copy files is mget *, and this copies only files, not folders. For example, ftp ts555 cd ts555/test ' test... (5 Replies)
Discussion started by: leenyburger
5 Replies

7. UNIX for Advanced & Expert Users

Bad magic number on /dev/md0

Hello All, (RHEL4) Few weeks ago I had posted a message in this forum about the problem I had when I replaced my two scsi disks and tried rebuild raid1 array. I somehow managed to up the system with working raid1 array. But the main problem persisted.. i.e when I reboot the system, mounting... (0 Replies)
Discussion started by: ravinandan
0 Replies

8. Solaris

RAID 5 mount points don't automount on boot

Hi, I set up a RAID 5 configuration and for some reason the volumes won't mount when the system boots. I have to manually mount them from the command line and all is fine. Here's the vfstab entries: #device device mount FS fsck mount mount #to mount ... (2 Replies)
Discussion started by: rpollard001
2 Replies

Featured Tech Videos