AUTOFS(5) BSD File Formats Manual AUTOFS(5)
autofs -- automounter filesystem
To compile this driver into the kernel, place the following line in the kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The autofs driver is the kernel component of the automounter infrastructure. Its job is to pass mount requests to the automountd(8) daemon,
and pause the processes trying to access the automounted filesystem until the mount is completed. It is mounted by the automount(8).
These options are available when mounting autofs file systems:
Mount options for all filesystems specified in the map entry.
Filesystem mountpoint prefix.
To unmount all mounted autofs filesystems:
umount -At autofs
To mount autofs filesystems specified in auto_master(5):
auto_master(5), automount(8), automountd(8), autounmountd(8)
The autofs driver first appeared in FreeBSD 10.1.
The autofs was developed by Edward Tomasz Napierala <trasz@FreeBSD.org> under sponsorship from the FreeBSD Foundation.
September 3, 2014 BSD