NTPD.CONF(5) File Formats Manual NTPD.CONF(5)
ntpd.conf - Network Time Protocol daemon configuration file
This manual page describes the format of the ntpd(8) configuration file.
The optional weight keyword permits finer control over the relative importance of time sources (servers or sensor devices). Weights are
specified in the range 1 to 10; if no weight is given, the default is 1. A server with a weight of 5, for example, will have five times
more influence on time offset calculation than a server with a weight of 1.
ntpd.conf has the following format:
Empty lines and lines beginning with the `#' character are ignored.
Keywords may be specified multiple times within the configuration file. They are as follows:
listen on address
OpenNTPd has the ability to sync the local clock to remote NTP servers and, if this directive is specified, can act as NTP server
itself, redistributing the local clock.
Specify a local IP address or a hostname the ntpd(8) daemon should listen on to enable remote clients synchronization. If it
appears multiple times, ntpd(8) will listen on each given address. If `*' is given as an address, ntpd(8) will listen on all local
addresses. ntpd(8) does not listen on any address by default. For example:
listen on *
listen on 127.0.0.1
listen on ::1
sensor device [correction microseconds] [weight weight-value]
Specify a timedelta sensor device ntpd(8) should use. The sensor can be specified multiple times: ntpd(8) will use each given sen-
sor that actually exists. Non-existent sensors are ignored. If `*' is given as device name, ntpd(8) will use all timedelta sensors
it finds. ntpd(8) does not use any timedelta sensor by default. For example:
An optional correction in microseconds can be given to compensate for the sensor's offset. The maximum correction is 127 seconds.
For example, if a DCF77 receiver is lagging 15ms behind actual time:
sensor udcf0 correction 15000
server address [weight weight-value]
Specify the IP address or the hostname of an NTP server to synchronize to. If it appears multiple times, ntpd(8) will try to syn-
chronize to all of the servers specified. If a hostname resolves to multiple IPv4 and/or IPv6 addresses, ntpd(8) uses the first
address. If it does not get a reply, ntpd(8) retries with the next address and continues to do so until a working address is found.
server 10.0.0.2 weight 5
server ntp.example.org weight 1
To provide redundancy, it is good practice to configure multiple servers. In general, best accuracy is obtained by using servers
that have a low network latency.
servers address [weight weight-value]
As with server, specify the IP address or hostname of an NTP server to synchronize to. If it appears multiple times, ntpd(8) will
try to synchronize to all of the servers specified. Should the hostname resolve to multiple IP addresses, ntpd(8) will try to syn-
chronize to all of them. For example:
default ntpd(8) configuration file
The ntpd.conf file format first appeared in OpenBSD 3.6 .
$Mdocdate: October 2 2007 $ NTPD.CONF(5)