Find command doesn't pipe the output as required.

Login or Register for Dates, Times and to Reply

 
Thread Tools Search this Thread
# 1  
Find command doesn't pipe the output as required.

Hi,

I am using below code snippet to echo/display the files found
(matching a pattern from searchstring.out file) and the corresponding owner.

Code:
while read j
do
echo "Pattern to search is:- $j"
  find / -name "*$j*" |\
  while read k
  do
    echo "File found is:- $k"
    owner=$(ls -ld "$k" | awk '{print $3}')
    echo "Owner is:- $owner"
  done
done < searchstring.out

However, this is not working as expected. The pattern is getting "echoed" correctly (as Pattern to search) but it doesn't proceeds ahead. No file found is displayed. Whereas, when I execute the find manually on shell using the search string, there are rows returned from the same.

Can anyone please confirm/suggest what could be the issue here and how this can be resolved?

Many Thanks.

Last edited by Don Cragun; 04-02-2015 at 01:50 AM.. Reason: Add CODE tags again.
# 2  
The last line should probably read done > searchstring.out, that is redirecting the output.
# 3  
Hi Walter,

The last line is reading the strings/pattern to find from the out file rather, hence its < - which is correct I believe.

Regards.
# 4  
I see.

Strangely trying your example as is works for me. Are you using a different shell for the script than on the command line? In any case doing something like bash -x scriptname may help with debugging.
# 5  
Hi Walter,

I am running this on HP-UX box (k shell). It doesn't really work for me and I am not understanding why Smilie
# 6  
Ok, so where does the No file found message come from? Sounds like it would be find (linux find doesn't do this btw.). Or isn't that the exact error message?
# 7  
Hi,

Ok, so there is a confusion I believe. What I meant is:- The pattern from the out file (searchstring.out) is displayed on console but the output from the find command (files found) is not returned with the next echo.

So, it essentially means that after the pattern is echoed from the out file, there is not further output from the next echo and the execution is stuck after the pattern is displayed from first echo in the script.

Hope this helps.

Regards.
Login or Register for Dates, Times and to Reply

Previous Thread | Next Thread
Thread Tools Search this Thread
Search this Thread:
Advanced Search

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Get the output of w command in pipe delimited format

Since output of w command have variable number of columns I want to get the output in pipe delimited format. I tried export OFS="|"; w but that does not work. Any ideas? (4 Replies)
Discussion started by: Soham
4 Replies

2. Shell Programming and Scripting

Find or ls with pipe to the command file

Hello all! I am trying to find the "Notes" backup from my iPhone in my folder ~/Library/Application\ Support/MobileSync/Backup/ which used to be in the sqlite file ca3bc056d4da0bbf88b5fb3be254f3b7147e639c. But since an update of the MacOS it is still there, but not updated anymore. (This is... (9 Replies)
Discussion started by: marek
9 Replies

3. Shell Programming and Scripting

How to pipe command output to shell script?

Hi Team, Need a help on how to pipe a command out put to a shell script. My shell script looks like below. cat shell_script #!/usr/bin/ksh input =$@ echo " we are inside the shell script" echo " here are the input parameters" .......................... .................. ... (11 Replies)
Discussion started by: gvkumar25
11 Replies

4. Shell Programming and Scripting

Pipe output a command to another using xargs

xargs work great when a command gives multiple line output which can be input to another. In my case it is not working coz the second command uses two words in it. $ scr.sh gives output like 193740 638102 375449 .. .. another command takes these number as inputs. it works great... (1 Reply)
Discussion started by: mahesh113
1 Replies

5. UNIX for Advanced & Expert Users

Pipe text in to find command

I would like to know why this command does not work. I have a script which connects to and ftp site. After getting the remote files localy i need move each remote file to a archive folder on the FTP site *Please also note that some of the files have spaces in the file name. Im trying to... (3 Replies)
Discussion started by: juanjanse
3 Replies

6. UNIX for Dummies Questions & Answers

is there any way of using rm command on output of pipe

Hi, I am having a list of directories with different login id's. My requirement is that i need to list the directories of my id and need to delete them. So i am using following code ls -ltr grep userid rm -rf But this is not working. So is there any way of doing it. Please note... (3 Replies)
Discussion started by: sarbjit
3 Replies

7. Shell Programming and Scripting

Assign command (with pipe) output to a variable

Hi , I would like to assign command (with pipe) output to a variable. The code is as follows. The goal of the code is to get the last folder folder with a particular name pattern. myDate=`ls | grep 2009 | tail -1` echo "myDate=" $myDate However, in the presence of the pipe, the code... (3 Replies)
Discussion started by: jeff_cen
3 Replies

8. Cybersecurity

Help Required: Command to find IP address and command executed of a user

Hi, I am trying to write a script which would figure out who has run which command and their IP. As i dont have any clue as to which commands would do this job, i request some gurus to help me on this. Thanks Vishwas (2 Replies)
Discussion started by: loggedout
2 Replies

9. AIX

Man command doesn't display any output amonst other problems

hi all, Newbie to Unix and AIX. So my apologies if this is in the wrong place, etc. Working on box - uname# uname -a AIX appt 3 5 00C08AAF4C00 when i type man (some valid command) it just returns me to the # prompt. Its running on the KSH shell. man was working but i was trying... (6 Replies)
Discussion started by: djdavies
6 Replies

10. UNIX for Dummies Questions & Answers

Man command doesn't display any output amonst other problems :-)

hi all, Newbie to Unix and AIX. So my apologies if this is in the wrong place, etc. Working on box - uname# uname -a AIX appt 3 5 00C08AAF4C00 when i type man (some valid command) it just returns me to the # prompt. Its running on the KSH shell. man was working but i was trying... (14 Replies)
Discussion started by: djdavies
14 Replies

Featured Tech Videos