Visit Our UNIX and Linux User Community


Solaris 10 installation over WAN using jumpstart


 
Thread Tools Search this Thread
Operating Systems Solaris Solaris 10 installation over WAN using jumpstart
# 1  
Old 06-11-2008
Question Solaris 10 installation over WAN using jumpstart

I am trying to install Solaris 10 OS using jumpstart over WAN. I have configured the jumpstart server with apache server and created all the necessary configurations and files. When i WAN boot my target machine, it gets booted using wanboot, it downloads the miniroot from the jumpstart server, but when it tries to use, it shows panic and throws a segmentation fault. Hence the process fails. Can anyone help ?? Copying the screen shot below

Code:
Rebooting with command: boot net -install
Boot device: /pci@7c0/pci@0/network@4 File and args: -install
100 Mbps FDX Link up
100 Mbps FDX Link up
<time unavailable> wanboot info: WAN boot messages->console
<time unavailable> wanboot progress: wanbootfs: Read 368 of 368 kB (100%)
<time unavailable> wanboot info: wanbootfs: Download complete
Wed Jun 11 08:38:38 wanboot info: WAN boot messages->10.20.28.10:80
SunOS Release 5.10 Version Generic_118822-25 64-bit
Copyright 1983-2005 Sun Microsystems, Inc. All rights reserved.
Use is subject to license terms.


panic[cpu0]/thread=180e000: BAD TRAP: type=10 rp=180ac00 addr=138abd4 mmu_fsr=0

: illegal instruction fault:
addr=0x138abd4
pid=0, pc=0x138abd4, sp=0x180a4a1, tstate=0x99e2001606, context=0x0
g1-g7: 5a827999, 70039000, 10325476, 10325400, 1, 10, 180e000

000000000180a920 unix:die+9c (10, 180ac00, 138abd4, 0, 180a9e0, 10000)
%l0-3: 0000000000000000 0000000000000010 0000000000000010 0000000000000000
%l4-7: 0000000000000000 8b32926340000000 0000000000000000 0000000001072c00
000000000180aa00 unix:trap+12f0 (180ac00, 20, 0, 0, 180c000, 180e000)
%l0-3: 0000000000000000 0000000001836340 0000000000000010 0000000000000000
%l4-7: 0000000000000000 8b32926340000000 0000000000000000 0000000000000000
000000000180ab50 unix:ktl0+64 (19d148c059d148c0, 578d1e33858bfaeb, d439668e2cca4
98d, 2ca4ae3d2ca4ae3d, 768b03ef368b03ef, a7ed263d27ed263d)
%l0-3: 000000000180c000 0000000000000000 00000099e2001606 000000000101c370
%l4-7: 2282016112010262 8b32926340000000 0000000000000000 000000000180ac00
000000000180aca0 swrand:swrand_mix_pool+44 (180ae48, 70000204, 180b1b4, 70039238
, 40, 3f)
%l0-3: f1a3c670b17f5d70 26a2276d3e810a6f 0000000000000000 0000000000000010
%l4-7: 2282016112010262 8b32926340000000 000000000180af88 000000000b329263
000000000180ad50 sha1:SHA1Update+1fc (180b1b4, 70000204, 40, 200, 40, 0)
%l0-3: 000000000180ae48 000000007003922c 000000000180afc0 0000000000000000
%l4-7: 000000000000003f 0000000000000000 000000000180af88 0000000000000000
000000000180b0f0 swrand:swrand_mix_pool+44 (70000204, 0, 40, 180b1b4, 0, 180b1a0
)
%l0-3: 0000000070000000 0000000000000000 0000000070000000 0000000070000000
%l4-7: 0000000070000000 0000000070000000 0000000070000000 0000000000000000
000000000180b210 swrand:swrand_add_entropy+2c (700001f8, 8, 70000000, 0, 7000000
0, 0)
%l0-3: 0000000070000000 0000000000000000 0000000070000000 0000000070000000
%l4-7: 0000000070000000 0000000070000000 0000000070000000 0000000070000000
000000000180b2c0 swrand:_init+88 (0, 0, 70000000, 0, 1863800, 70000000)
%l0-3: 0000000070000000 0000000000000000 0000000070000000 0000000070000000
%l4-7: 0000000070000000 0000000070000000 0000000070000000 0000000070000000
000000000180b380 genunix:modinstall+cc (0, 300005c8968, 0, 1860550, 80000000, 13
89bd0)
%l0-3: 000000000180b209 000000000180b2e1 000000006f000000 0000000000000000
%l4-7: 0000000000000000 0000000001818a88 00000000011e0780 0000000000000000
000000000180b440 genunix:___const_seg_900003701+2510 (300005c8b48, 5, 0, 30001d7
efe8, a, 300005c8968)
%l0-3: 000000000180b209 000000000180b2e1 000000006f000000 0000000000000000
%l4-7: 0000000000000000 0000000001818a88 00000000011e0780 0000000000000000
000000000180b4f0 genunix:modinstall+60 (0, 300005c8b48, 0, 1860550, 80000000, 6)
%l0-3: 000000000180b209 000000000180b2e1 000000006f000000 0000000000000000
%l4-7: 0000000000000000 0000000001818a88 00000000011e0780 0000000000000000
000000000180b5b0 genunix:___const_seg_900003701+2510 (300005c8be8, 5, 18a9630, 3
0001fa5d40, a, 300005c8b48)
%l0-3: 000000000180b209 000000000180b2e1 000000006f000000 0000000000000000
%l4-7: 0000000000000000 0000000001818a88 00000000011e0780 0000000000000000
000000000180b660 genunix:modinstall+60 (0, 300005c8be8, 0, 1860550, 80000000, 6)
%l0-3: 000000000180b209 000000000180b2e1 000000006f000000 0000000000000000
%l4-7: 0000000000000000 0000000001818a88 00000000011e0780 0000000000000000
000000000180b720 genunix:___const_seg_900003701+2510 (300005c8d28, 5, 18a9630, 3
0001fa5d20, a, 300005c8be8)
%l0-3: 000000000180b209 000000000180b2e1 000000006f000000 0000000000000000
%l4-7: 0000000000000000 0000000001818a88 00000000011e0780 0000000000000000
000000000180b7d0 genunix:modinstall+60 (0, 300005c8d28, 0, 1860550, 80000000, 6)
%l0-3: 000000000180b209 000000000180b2e1 000000006f000000 0000000000000000
%l4-7: 0000000000000000 0000000001818a88 00000000011e0780 0000000000000000
000000000180b890 genunix:mod_hold_stub+128 (1818a88, 5, 18a9630, 300005c8d28, 18
18a78, 0)
%l0-3: 000000000180b209 000000000180b2e1 000000006f000000 0000000000000000
%l4-7: 0000000000000000 0000000001818a88 00000000011e0780 0000000000000000
000000000180b940 unix:stubs_common_code+30 (0, 35b6b, 18ac000, 18aec00, 0, 181ac
00)
%l0-3: 000000000180b209 000000000180b2e1 000000006f000000 0000000001800000
%l4-7: 0000000000000000 0000000001818a88 00000000011e0780 0000000000000000
000000000180ba10 genunix:main+d8 (1815208, 1016400, 1836340, 18a9400, 180e000, 1
815000)
%l0-3: 000000000184e000 0000000001080000 000000000184d800 0000000001800000
%l4-7: 000000000183b000 000000000184dc00 00000000011e0780 0000000000000000

syncing file systems... done
skipping system dump - no dump device configured
rebooting...


Last edited by DukeNuke2; 06-11-2008 at 07:22 AM.. Reason: CODE tags for better reading
# 2  
Old 06-11-2008
please try:

Code:
ok boot net - install

# 3  
Old 06-12-2008
y know T1000 is sun4v architecture and not sun4u?!
# 4  
Old 06-12-2008
MySQL

the problem was the solaris 10 version i was using did not support t1000.

t1000 is sun4v.

Previous Thread | Next Thread
Test Your Knowledge in Computers #348
Difficulty: Easy
Awk's built-in variables include the field variables: $1, $2, $3, and so on ($0 represents the entire record).
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

help me! jumpstart installation error

Hi actualy my two machines are sun sparc ultra 60. Both are same configuration. I am trying jumpstart Installation in my two machines, i got no errors in server side but in the client side actually it detects the server machine with correct hostname and domainname but after showed that it will... (2 Replies)
Discussion started by: Grovestreet
2 Replies

2. Solaris

Could not start installation using jumpstart

hello I created a boot server and tryed to run intstall with jumpstart on other solaris server, but jumpstart coudn't starts, only text-based install. sysidcfg and rules file are in the same shared folder, rules file has only one string any - - any_profile - and thta't all. also I created... (2 Replies)
Discussion started by: sluge
2 Replies

3. Solaris

Solaris x86 installation using jumpstart does not local boot ( boot from hdd)

I am trying to install Solaris x86 using the Jumpstart server. I run the add_install_client command with appropriate options, and reboot my x86 Target box. The installation starts fine and unattended. After the installation completes and the target goes for a re-boot, it does not boot from the HDD... (9 Replies)
Discussion started by: hemalsid
9 Replies

4. Solaris

jumpstart installation

hi friends, i dont know how to install jumpstart . i have solaris cds( 5 nos.). i tried to install jumpstart but there is no setup_install_server file. What i want to do for installing jumpstart server please help me thanks to all (8 Replies)
Discussion started by: sijocg
8 Replies

5. Solaris

Flash installation with Jumpstart

I get following error while doing a flash installation. I 'm trying to deploy a flash archive created by our engineering team. I 'm trying to install it with ZFS root and the profile which i using is as following #more flash_profile_test install_type flash_install archive_location nfs... (3 Replies)
Discussion started by: fugitive
3 Replies

6. Solaris

Jumpstart Solaris Installation Program screen

Hi! I'm trying to skip the installation welcome screen (actually the first three screens: The Solaris Installation Program screen, Identify This System screen and date and time settings - not timezone settings). Everything else runs automaticly from jumpstart except these three screens, just... (6 Replies)
Discussion started by: Luka
6 Replies

7. Solaris

Error in Solaris installation over WAN(unix: Could not start init) Program terminated

I am trying to install Solaris 10 on a target machine which is t1000. ( sun4v). I have configured my jumpstart server to install solaris over WAN. when i boot my machine, the wanboot image gets downloaded properly, miniroot gets downloaded properly, but after that the process fails with the... (3 Replies)
Discussion started by: hemalsid
3 Replies

8. IP Networking

Accessing Solaris 8 over WAN

We can access our solaris 8 from our LAN . However when we try to access the same over our WAN , it is not able to ping the server . /etc/hosts has entries for our DNS server. Another thing all WAN clients are Windows 2000 workstations . Here is the output netstat -nr Routing Table: IPv4... (7 Replies)
Discussion started by: Hitesh Shah
7 Replies

9. Solaris

accessing solaris 8 over WAN

We can access our solaris 8 from our LAN . However when we try to access the same over our WAN , it is not able to ping the server . /etc/hosts has entries for our DNS server. Another thing all WAN clients are Windows 2000 workstations . Here is the output netstat -nr Routing Table: IPv4... (1 Reply)
Discussion started by: Hitesh Shah
1 Replies

10. Solaris

Jumpstart installation problem.

We are installing Solaris 9 with Jumpstart ...facing problems.. Problem is .it is prompting for questions, even though we set the Sysidcfg and class files properly. when we give "boot net - install" at OK prompt, it is coming till "The system is coming up. Please wait" After that it... (5 Replies)
Discussion started by: b_manu78
5 Replies

Featured Tech Videos