👤
Home Man
Search
Today's Posts
Register

The Solaris Operating System, usually known simply as Solaris, is a Unix-based operating system introduced by Sun Microsystems. The Solaris OS is now owned by Oracle.

Boot problem with SMF svcs-Solaris 10 for x86

👤 Login to reply

 
Thread Tools Search this Thread
# 1  
Old 03-29-2008
Error Boot problem with SMF svcs-Solaris 10 for x86

Hi All,

I am newbie in solaris, please guide me.
A week before i installed solaris10 on my x86 system, it was working fine i always used "init 5" to shutdown my system as per my collegue advice.
But yesterday when i started my system it gave me following message

svc:/network/rpc/keyserv:default:method "/usr/sbin/keyserv" failed with exit status 1
svc:/system/filesystem/local:default:WARNING:/sbin/mountall -l failed: exit status 1
svc.startd[7]:svc:/system/filesystem/local:default:method "/lib/svc/method/fs-local" failed with exit status 96
[system/filesystem/local:default misconfigured(see 'svcs -x' for details)]

requesting system maintanence mode
console login service(s) cannot run
Root password for system maintanence (control-d to bypass):-

i gave the password and executed the command svcs -x

# svcs -x
svc:/system/filesystem/local:default (Local file system mounts)
state:maintanence since Sat Mar 29 12:06:32 2008
Reason:start method exited with $SMF_EXIT_ERR_CONFIG
see:Sun Microsystems Message Lookup
impact:13 services are not running


So this is my problem, please your prompt response is required.
Thanks In advance
# 2  
Old 03-29-2008
can you get svc:/system/filesystem/local:default out of maintenance mode?
# 3  
Old 03-29-2008
From the output you have posted it is failing to mount one or more of the filesystems described in /etc/vfstab.

Either look at the log to see which filesystems are the problem, or alternatively run
Code:
mount -a

or
Code:
/sbin/mountall

which should also give you this information.
# 4  
Old 03-30-2008
Pupp: As you've mentioned, it is no coming out/clearing from maintanence mode, i tried many options but no luck !!!

Reborg: i invoked the commands you said it gave me below result

#mount -a
mount:No such file or directory
mount:/tmp is already mounted or SWAP is busy
mount:/devdsk/c1d0s7 is already mounted or /export/home is busy

#/sbin/mountall
mount:No such file or directory
mount:/tmp is already mounted or SWAP is busy
mount:/devdsk/c1d0s7 is already mounted or /export/home is busy


Still no luck !!! Please help
# 5  
Old 03-31-2008
Today i tried with svcadm but still no luck

Please any solaris angel who can help me out.

Thanks in advance
# 6  
Old 03-31-2008
do you have an NFS mounts? Whats your mount output?
# 7  
Old 03-31-2008
Hurray !!!

Thanks guys for your support... issue is finally resolved.

well i have added new mount last week in /etc/vfstab file as i am using two harddisk in my system. i forgot to mentioned above.

first i removed the newline which i added in /etc/vfstab then disabled the service by command
#svcadm -v disable svc:/system/filesystem/local:default
service came from maintenance mode to disable mode

#svcadm -v clear svc:/system/filesystem/local:default
#svcadm -v enable svc:/system/filesystem/local:default

And it worked fine. Again i repeated the same steps to ensure the problem was with mounting.

Thanks again to all of you!

!!!You help someone and god helps you!!!
👤 Login to reply

« Previous Thread | Next Thread »
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

More UNIX and Linux Forum Topics You Might Find Helpful
Thread Thread Starter Forum Replies Last Post
Boot Solaris 10 U1 for x86 from DVD vectrum Solaris 3 05-26-2015 04:17 PM
Create a boot disk mirror on Solaris 10 x86 TKD Solaris 6 04-09-2012 05:50 PM
Solaris x86 installation using jumpstart does not local boot ( boot from hdd) hemalsid Solaris 9 08-17-2011 04:04 AM
x86 Solaris 8 does not boot. gogusrl Solaris 3 07-27-2010 08:47 PM
Solaris X86 grub boot menu gonzotonka Solaris 5 07-28-2009 12:31 AM
Query related to boot process of Solaris x86 saagar Solaris 0 07-17-2009 01:44 AM
Problem with Solaris system on x86. It would not boot again after updates. platforminc Solaris 0 12-18-2008 09:27 AM
Installation of Solaris 10 11/06 on X86 Platform with Xp SP2 as dual boot skargarika Solaris 2 06-05-2008 05:38 AM
Solaris 10 x86 Installation Will Not Boot From CD Disks RobSand Solaris 5 11-26-2007 07:33 AM
Solaris 10 x86 1/06 CD1 boot fail mozheyko_d Solaris 1 03-29-2006 02:27 AM


All times are GMT -4. The time now is 01:19 AM.

Unix & Linux Forums Content Copyrightę1993-2018. All Rights Reserved.
×
UNIX.COM Login
Username:
Password:  
Show Password