Visit Our UNIX and Linux User Community


migrate complete OS from v240 to v440


 
Thread Tools Search this Thread
Operating Systems Solaris migrate complete OS from v240 to v440
# 1  
Old 02-21-2008
migrate complete OS from v240 to v440

We are concluding development of a new application on a v240 and would like to migrate the entire Solaris10 OS on the v240 to a v440 that is currently live with Solaris 9.

The steps outlined in my head are as follows:

1) Flash archive the v440 and v240 and store the flar file on a different server.
2) Flash install on the v440 from the v240 flar.

Now, I'm not sure what needs to be done next to get all the devices up to date. Do I need to boot into single user mode and delete the /dev directory and run devfsadm? What else needs to be done?

Thanks.
# 2  
Old 02-21-2008
do a "boot -rsv" for the first boot from the obp.
# 3  
Old 02-21-2008
If you are doing a flash install of the 440 then there is nothing more to do. The Device tree will be rebuild on install.
# 4  
Old 02-21-2008
Thanks reborg.

How will the Flash install handle SVM mirroring and ZFS filesystems that exist currently on the v240? Will they be migrated seamlessly to the v440?
# 5  
Old 02-21-2008
The flar doesn't retain the mirror or the ZFS (at least Solaris 10 10/06 didn't retain ZFS, haven't tried with 08/07). You'd have to remirror the box and recreate the pools.

One method that may be unpopular here Smilie that I have used in the past, is simply moving the HDs from the v240 to the v440. As long as the disks show on the same c*t*d*, you should be good to go.
# 6  
Old 02-22-2008
Quote:
Originally Posted by System Shock
The flar doesn't retain the mirror or the ZFS (at least Solaris 10 10/06 didn't retain ZFS, haven't tried with 08/07). You'd have to remirror the box and recreate the pools.

One method that may be unpopular here Smilie that I have used in the past, is simply moving the HDs from the v240 to the v440. As long as the disks show on the same c*t*d*, you should be good to go.
That was actually my first though. It does work, and a "boot -r" should fix anything out of place provided there is nothing too strange attached to the machine.

Flar does not retain zfs, nor svm configurations, and it is not intended to. A set ZFS disks encapsulates all of the information needed to import the pool, so one would normally either backup and recreate the pool and restore the data on the new pool, or move the disks ( even between dissimilar hardware).

If you use jumpstart you can recreate the SVM information at install time, but not the zpool and zfs filesystems.
# 7  
Old 03-17-2008
I tested the flar from a V240 on a 280R. The data in the ZFS filesystem was not backed up at all. It looks like I will have to move the data from the ZFS filesystem over to a UFS mountpoint before creating the final flar.
Otherwise everything seems to work as expected. Thanks!

Previous Thread | Next Thread
Test Your Knowledge in Computers #917
Difficulty: Easy
Unix time is also known as Epoch time.
True or False?

10 More Discussions You Might Find Interesting

1. Solaris

V240 no OBP or console available

Hey guys, I recently replaced the heatsinks on two different V240's. Repasted and replaced them myself. After attempting to bring them back up, there was no display coming from the KVM. I figured it was a matter of environment in OBP and attempted to get to the OK prompt from the... (20 Replies)
Discussion started by: DanielSluder
20 Replies

2. Solaris

Can v240 disks be moved to v440 and have a chance of working?

We have a v240 running Solaris 10, and an application that I don't want to go through the pain of reinstalling on a new system right now. Can I just move those disks to a v440 for an easy upgrade? At first I thought the idea was laughable, but then I started thinking that they are both Ultra... (9 Replies)
Discussion started by: lyle
9 Replies

3. Solaris

breaking into a v240's alom

had a v240 pre-configured and running the OS and alom, for about 3 months good, no issues. All of sudden, I can't see the IP address of the OS and the alom.. There is nothing wrong with thet network... I suspect the ALOM crashed and/or something bad happened to it.. Is there anyway... (3 Replies)
Discussion started by: ppchu99
3 Replies

4. Solaris

Alom Sun V240

hallo anybody know how to set alom mail alerty server with yahoomail ? thank u?where i can find mail server address for yahoomail?thank (1 Reply)
Discussion started by: yanto85
1 Replies

5. Solaris

V210 to V440

I'm currently trying to move a perfectly find harddrive from a V210 to a V440. From what I can tell, the disk labeling a bit different, (V210 is c1t0d0 and V440 is c0t0d0). My question is, what all do I have to change to get the V440 to boot off of this with very little complications. Right now, it... (21 Replies)
Discussion started by: adelsin
21 Replies

6. Solaris

V210 to V440

I recently acquired a server for home use. Currently, I'm running a V210. I was wondering of a way to basically swap hard drives into the V440. I would like to avoid reinstall on the V440 for many reasons. Currently on the V440, when I try to boot up it forces itself into System Maintenance... (1 Reply)
Discussion started by: adelsin
1 Replies

7. Solaris

sun v240 performance

Hi, we are having one sun v240 server, now this server is performing very slow, checked using top, iostat and vmstat commands, output is looking normal, but the performance is very slow and generating more traffic in network, how can we resolve this. Regards RJS (5 Replies)
Discussion started by: rajasekg
5 Replies

8. UNIX for Dummies Questions & Answers

BASH complete-filename & menu-complete together

Hi, Does anyone know how to make BASH provide a list of possible completions on the first tab, and then start cycling through the possibilites on the next tab? Right now this is what I have in my .bashrc: bind "set show-all-if-ambiguous on" bind \\C-o:menu-complete This allows... (0 Replies)
Discussion started by: Mithu
0 Replies

9. Solaris

Can't get ok prompt on V440

Hello all, This is probably a commonly asked question, but it has me stumped. I have a V440 which upon bootup gives me the option of getting into ALOM with #. I don't have the ALOM password so I want to re-install Solaris 10. When connected to the Management serial interface (on the PCI... (3 Replies)
Discussion started by: juanj
3 Replies

10. UNIX for Dummies Questions & Answers

Jumpstart Sunfire V240

Hi, I trying to jumpstart SunFire V240 Solaris 10, 2006_01. All the jumpstart files on jumpstart install and boot server are ok (tested on another machine Sun Ultra 10). But this system comes out with: "The file just loaded does not appear to be executable." after "boot net - install" and setting... (0 Replies)
Discussion started by: jump
0 Replies

Featured Tech Videos