Today (Saturday) We will make some minor tuning adjustments to MySQL.

You may experience 2 up to 10 seconds "glitch time" when we restart MySQL. We expect to make these adjustments around 1AM Eastern Daylight Saving Time (EDT) US.


Cannot proxy a file repo, complains its not version 4, but it is!


Login or Register to Reply

 
Thread Tools Search this Thread
# 1  
Cannot proxy a file repo, complains its not version 4, but it is!

I have a Solaris 11.4 global zone (at the most recent SRU) where I am trying to install a Solaris 11 zone. To do this I need to have the system-repository and the zone proxy service started.

I created a full (GA 11.4 with newest SRU rolled in) repo using "pkgrepo create" and the install-repo.ksh script to an NFS file system called /share/114repo

I then published it locally and the repo comes up and is valid. I can use it to update the global zone.

When I try to start the system-repository service (which the zone-proxyd service depends on) it goes into maintenance mode.

This is the output of the /var/svc/log/application-pkg-system-repository:default.log

Code:
[ 2019 Jun 13 12:48:40 Enabled. ] 
 [ 2019 Jun 13 12:48:40 Executing start method ("/lib/svc/method/svc-pkg-sysrepo start"). ] 
  pkg.sysrepo: unable to get publisher information: file repository  file:///share/repo cannot be proxied. Only file repositories of version 4  or later are supported. 
 pkg.sysrepo: failed to create Apache configuration 
 [ 2019 Jun 13 12:48:41 Method "start" exited with status 95. ]

It seems to be complaining that it can only proxy repositorys of version 4 or later.

I ran "pkgrepo get -s" on the repo I created and get the following:

Code:
SECTION PROPERTY VALUE 
 publisher prefix solaris 
 repository check-certificate-revocation False 
 repository description This\ repository\ serves\ a\ copy\ of\ the\ Oracle\ Solaris\ 11.4\ Build\ 15\ Package\ Repository. 
 repository name Oracle\ Solaris\ 11.4\ Build\ 15\ Package\ Repository 
 repository signature-required-names () 
 repository trust-anchor-directory /etc/certs/CA/ 
 repository version 4

It says its on version 4. So not sure whats going on here.

It breaks the following as you can see, so I cannot get zone proxy going.

Code:
root@sptcs654:/var/svc/log# svcs -l svc:/application/pkg/zones-proxyd:default 
 fmri svc:/application/pkg/zones-proxyd:default 
 name Zones Proxy Daemon 
 enabled true 
 state offline 
 next_state none 
 state_time June 13, 2019 at 12:48:06 PM EDT 
 logfile /var/svc/log/application-pkg-zones-proxyd:default.log 
 restarter svc:/system/svc/restarter:default 
 contract_id  
 manifest /lib/svc/manifest/application/pkg/zoneproxyd.xml 
 dependency require_any/none svc:/system/filesystem/minimal (online) 
 dependency require_any/error svc:/milestone/network (online) 
 dependency require_all/none svc:/application/pkg/system-repository (maintenance)

Code:
root@sptcs654:/var/svc/log# svcs -l svc:/application/pkg/system-repository 
 fmri svc:/application/pkg/system-repository:default 
 name IPS System Repository 
 enabled true 
 state maintenance 
 next_state none 
 state_time June 13, 2019 at 12:48:41 PM EDT 
 logfile /var/svc/log/application-pkg-system-repository:default.log 
 restarter svc:/system/svc/restarter:default 
 contract_id  
 manifest /lib/svc/manifest/application/pkg/pkg-system-repository.xml 
 dependency optional_all/error svc:/system/filesystem/autofs:default (online) 
 dependency require_all/none svc:/system/filesystem/local:default (online) 
 dependency require_all/error svc:/milestone/network:default (online)

--- Post updated at 06:01 PM ---

Decided to bring down the hammer and did a



Code:
chmod -R 777 *


on the repo, then everything worked.

Going to roll that back a bit since its not secure. Going to try 770 and then 644 on the catalog files.
# 2  
Thanks for the update.

I will mark this issues "solved".
Login or Register to Reply

|
Thread Tools Search this Thread
Search this Thread:
Advanced Search

More UNIX and Linux Forum Topics You Might Find Helpful
Configuring EPEL repo and setting it as default repo.
Hijanoqu
I am using RHEL 6, but with no RHN subscription. I tried installing the EPEL repo, it is enabled under yum repolist but when I try a sample search such as yum search nginx , there's a string of errno 14 PYCURL error 6 . When I tried yum list installed, it didn't work because it defaults to the...... UNIX for Dummies Questions & Answers
0
UNIX for Dummies Questions & Answers
Does any hunk knows how to block ultrasurf in squid proxy red hat version 4
vishwanathhcl
Does any one knows how to block ultrasurf in squid proxy ?:) I have one shell script i.e blocking all ultrsurf version except ultrasurf 8.9 if any one knows pls share the documents with me.... Linux
1
Linux
Does any hunk knows how to block ultrasurf in squid proxy red hat version 4
vishwanathhcl
Does any one knows how to block ultrasurf in squid proxy ? I have one shell script i.e blocking all ultrsurf version except ultrasurf 8.9 i f any one knows pls share the documents with me. Please read the rules: No double posting! Thank you - site moderator... Cybersecurity
0
Cybersecurity

Featured Tech Videos