Today (Saturday) We will make some minor tuning adjustments to MySQL.

You may experience 2 up to 10 seconds "glitch time" when we restart MySQL. We expect to make these adjustments around 1AM Eastern Daylight Saving Time (EDT) US.


Need help to compile and create python64 bit (2.7.9) on Solaris10


Login or Register to Reply

 
Thread Tools Search this Thread
# 1  
Need help to compile and create python64 bit (2.7.9) on Solaris10

Hi,

I am trying to build python(2.7.9) 64 bit from source on solaris10. Using the below to compile

Code:
./configure CFLAGS=-m64 LDFLAGS=-m64

But getting errors like below while executing make

Code:
make: Fatal error: Command failed for target `libinstall'

OS info:
Code:
isainfo -v
64-bit amd64 applications
32-bit i386 applications

Code:
uname -r
5.10

Code:
cat /etc/release
                       Solaris 10 10/09 s10x_u8wos_08a X86

Need to know how to compile to build 64 bit python from source. Am i missing to include some other flags during configure?

TIA
# 2  
Did you look for libinstall ? its permissions and where/what it is?
From what I remember in older days at a SUN presentation of its strategy and evolution (like including X86 servers in roadmap...) I remember interventions of people for the local university, and and more from CERN complaining saying that solaris10 on X86 was not all that 64bits OS and when will it be...
You may have 2 distinct libraries one for 32 and one for 64, be sure to set the path accordingly
# 3  
Hi,

While debugging I came to know that the following error line appears many times

Code:
WARNING: renaming "itertools" since importing it failed: ld.so.1: python: fatal: /usr/sfw/lib/libgcc_s.so.1: wrong ELF class: ELFCLASS32
building 'future_builtins' extension
WARNING: renaming "future_builtins" since importing it failed: ld.so.1: python: fatal: /usr/sfw/lib/libgcc_s.so.1: wrong ELF class: ELFCLASS32
building '_random' extension

The above same error line appears many times. I have just copied little

I have also changed the configure line as below,

Code:
./configure  CC="gcc -m64" CXX="g++ -m64" CFLAGS=-m64 LDFLAGS="-L /usr/sfw/lib/amd64/"

And i have added environment variable LD_LIBARAY_PATH as follows where 64bit libraries are available

Code:
LD_LIBARAY_PATH=/usr/lib/64/ld.so.1

I dont know why it is pointing to 32 bit library only(/usr/sfw/lib/libgcc_s.so.1) instead of "/usr/sfw/lib/libgcc_s.so.1" it should take /usr/sfw/lib/amd64/libgcc_s.so.1

TIA
# 4  
Go to your directory /usr/sfw/lib/ and do an ls -l and post back here the results wrapped in code taggies.

Let's make sure you sym links to the shared libs are correct.

I see a lot of different directories in your post:
  • /usr/sfw/lib/
  • /usr/sfw/lib/amd64
  • /usr/lib/64/

Let's make sure they are as they should be.

Thanks.
# 5  
Hi,

Contents of /usr/sfw/lib with respective to gcc

Code:
drwxr-xr-x   3 root     bin            3 Nov 16  2010 gcc
lrwxrwxrwx   1 root     root          13 Nov 16  2010 libgcc_s.so -> libgcc_s.so.1
-r-xr-xr-x   1 root     bin        40212 Jan 23  2005 libgcc_s.so.1
drwxr-xr-x   2 root     bin           59 Sep  3  2015 amd64
lrwxrwxrwx   1 root     root           5 Nov 16  2010 64 -> amd64

Contents of /usr/sfw/lib/amd64 with respective to gcc
Code:
lrwxrwxrwx   1 root     root          13 Nov 16  2010 libgcc_s.so -> libgcc_s.so.1
-r-xr-xr-x   1 root     bin       172408 Jan 23  2005 libgcc_s.so.1
lrwxrwxrwx   1 root     root          13 Nov 16  2010 libgcc_s_amd64.so -> libgcc_s.so.1


Last edited by Sumanthsv; 04-07-2019 at 08:11 AM..
# 6  
That reminds me some time ago when I compiled python and had issues, are you sure you fullfill all the prerequisites? especially about gcc? as I see your libgcc is of 2005...
# 7  
Hi,

Yes. The gcc is not the latest version . It comes with the Solaris. I don't think thats an issue.. Only thing is that, while compiling it should take from /usr/sfw/lib/amd64 which is for 64 bit..

Don't know in which flag I need to include that while compiling..

TIA
Login or Register to Reply

|
Thread Tools Search this Thread
Search this Thread:
Advanced Search

More UNIX and Linux Forum Topics You Might Find Helpful
How to create Zones on Solaris10
mobilethink
Hi, Can anyone plz explain how to cerate zones on Solaris10... Solaris
2
Solaris
Solaris10 rrdtool compile issues
Donkey25
Hi all, I'm trying to install rrdtools on a sparc solaris10 system for use with Nagiosgraph. I inititially just added the rrdtools package from sunfreeware but this package doesn't include the directory that Perl needs. I've been told that compiling from source is my only option. I;m trying...... UNIX for Dummies Questions & Answers
0
UNIX for Dummies Questions & Answers
How do I compile a 64-bit program on SPARC??
amit_27
Hi, wcslen(), strlen() returns size_t. On 64-bit platform i want to use int like str length is 10. int len = wcslen(str); On 64-bit what should I need to do if i wants the length in int. Because getting error as "Conversion of 64 bit type value to "int" causes truncation". if i...... Solaris
17
Solaris
Is it possible to compile 64 bit application on 32 bit machine
Mandar123
Hi, I am using 32 bit machine, and I want to compile 64 bit application on 32-bit machine. So please tell me is it possible or not? Regards Mandar... Linux
7
Linux
error: compile 64 bit mysql on Solaris 10
csross
I'm trying to build 64 bit mysql-5.0.37 on Solaris 10. CFLAGS="-O3" CXX='gcc -m64 -mcpu=v9' CXXFLAGS="-O3 -felide-constructors -fno-exceptions -fno-rtti" ./configure –disable-shared --prefix=/usr/local/mysql --datadir=/home1/mysql_data --with-mysqld-user=mysql ...... Solaris
0
Solaris

Featured Tech Videos