Solaris11.4 - no X11


Login or Register to Reply

 
Thread Tools Search this Thread
# 1  
Old 09-06-2018
Solaris11.4 - no X11

After some problems, I have installed Solaris 11.4. The warnings said
Code:
WARNING: /pci@0,0/.....
(xhci1): Connecting device on port 5 failed
WARNING: /pci@0,0/.....
(xhci1): Connecting device on port 6 failed

Preparing image for use
Unable to mount media
Requesting System Maintenance Mode
(See /lib/svc/share/README for more information)
Console login service(s) cannot run

The problem was that I had inserted the USB stick into a USB3 port. I instead used a USB2 port and could finally install Solaris 11.4. So for future reference, if anyone fails to install with these error messages, I have recorded the solution here.


Now I have a problem. I cannot get to X11. I see the splash screen, so I have graphics. But when I try to start X11, it does not work. How can I get X11 graphics?



After Solaris 11.4 installation, I added the desktop package:
Code:
# pkg install solaris-desktop

But still there is no X11. I reboot the PC, and see some error messages. Can anyone help me solve this problem? I have reinstalled the nvidia driver, I am using version 387.34 which is the one NVidia web site gave me.



I have a Supermicro X10SAT, E3-1245 cpu and a NVidia Geforce 1070Ti.


The error messages say:
Code:
WARNING: Signature verification of module /kernel/drv/amd64/nvidia failed
WARNING: Signature verification of module /kernel/drv/amd64/nvidia_modeset failed
Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms 387.34
nvidia_modeset: Unloading
krtld: WARNING: Signature verification of module /kernel/drv/amd64/nvidia failed
krtld: WARNING: Signature verification of module /kernel/drv/amd64/nvidia_modeset failed
nvidia_modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms

And then I try to do "svcadm enable gdm" and after that I do "startx" and see these error messages:
Code:
xauth: file /export/home/root/.serverauth.1374 does not exist
X.org X Server 1.19.5
Release Date: 2017-10-12
X Protocol Version 11, Revision 0
Build Operating System: SunOS 5.11 i86pc
Current Operating System: SunOS 5.11 11.4.0.15.0 i86pc
Solaris ABI: 64-bit
Current version of pixman: 0.34.0
Before reporting problems, check https://support.oracle.com/ to make sure you have the latest version
(==) Log file: "/var/log/Xorg.0.log"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE)
Fatal server error:
(EE) no screens found(EE)
(EE)
Please consult the Oracle corporation, based on X.Org Foundation sources support
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information
(EE)
(EE) Server terminated with error (1). Closing log file
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error


Last edited by kebabbert; 09-06-2018 at 05:50 AM..
# 2  
Old 09-06-2018
So are you publishing a solution here or do you still have a problem?
# 3  
Old 09-06-2018
Quote:
Originally Posted by hicksd8
So are you publishing a solution here or do you still have a problem?
Thanx. I have edited and clarified that I cannot get to X11. That is my problem. I dont have a GUI. why?
# 4  
Old 09-11-2018
Hello!


Have you checked in /var/log/Xorg.0.log that the driver is loaded properly with all its modules? I would guess that this could be an issue. You could try loading X with Vesa instead to see if this is the case.


Good luck!


/Peter
# 5  
Old 09-21-2018
I've just had cause to install Solaris 11.4 x86 with GUI (solaris-desktop package) and it just worked (Gnome).

Are you installing on Sparc or x86?

Did you use the AI media or Text install media?
(I tried the AI media but had issues with it so success was with Text.)
Login or Register to Reply

|
Thread Tools Search this Thread
Search this Thread:
Advanced Search

More UNIX and Linux Forum Topics You Might Find Helpful
Configuring network interfaces in Solaris11 nypreH Solaris 2 01-16-2014 01:24 AM
Solaris11 and samba4 dc Linusolaradm1 Solaris 0 10-08-2013 02:32 PM
Xmanager 4 not able to connect to Solaris11 Maqsood Mohamme Solaris 2 09-19-2013 03:12 AM
Solaris11: Permission issues with auto-scrub ZFS pool taltamir Solaris 4 01-10-2013 04:32 PM
[Solved] putty+x11:How do I pass X11 display rights to "su"? dkarr UNIX for Advanced & Expert Users 2 01-26-2012 06:16 PM
[Unix Solaris11] RPM2PKG error about compilation. Fraste_ Solaris 1 12-10-2011 09:20 AM
is x11 and vnc different? chidori Solaris 3 06-24-2011 11:51 AM
X11 privileges lleontiev UNIX for Dummies Questions & Answers 1 02-16-2011 12:44 PM
Error: installing Nmap on Solaris11 Express fragile_it Solaris 0 02-07-2011 06:55 AM
X11 problem kingdbag UNIX for Dummies Questions & Answers 2 11-04-2008 06:26 PM
X11 in solaris jayaramanit Solaris 4 07-18-2008 04:28 PM
cygwin-x/can't install xorg-x11-f100 & xorg-x11-fnts binodbdrchand Windows & DOS: Issues & Discussions 1 06-25-2008 01:07 AM
x11 Josiah Olson OS X (Apple) 3 06-21-2005 05:52 PM
X11 and its problems..... gnerd UNIX for Dummies Questions & Answers 4 04-01-2004 04:50 PM