Cloning a Sunblade 2500

Tags
driver, solaris, solaris 9, solved

 
Thread Tools Search this Thread
# 1  
Old 10-12-2017
Cloning a Sunblade 2500

Good Morning,

I took a mirror drive from one Solaris 9 machine and used it to set up another. After syncing another mirror on the second machine I restarted but I don't get a login screen.

I see a message:
Code:
The X-server cannot be started on display :0

Also during startup I see:
Code:
Can't find driver for console framebuffer

Could someone please help me troubleshoot this?

Last edited by vbe; 10-12-2017 at 12:47 PM.. Reason: code tags
# 2  
Old 10-12-2017
You are cloning a Sunblade 2500 to another Sunblade 2500?

Are they the same hardware revision?

It looks like the O/S isn't loading the correct graphics driver. Do you know the type of graphics card in each? Are they the same?

You might have some luck if you tell Solaris to reconfigure at boot time:

Code:
ok> boot -r

If it's a third-party graphics adapter you might need to get drivers for it.

Can you get into single-user text mode with:

Code:
ok> boot -s

More questions than answers right now I'm afraid.
This User Gave Thanks to hicksd8 For This Post:
Stellaman1977 (10-12-2017)
# 3  
Old 10-12-2017
Thanks.

Yes- 2500 to 2500.

Not sure about hardware revision. I did look at the video cards (info below). Should I look at something else?

I could
Code:
boot -r

and
Code:
boot -s

. Both will boot the machine but it looks about the same.

I opened them up. The card on the old machine is a 3D Labs card. The card on the new machine is ATI Radeon Graphics. When I boot up, I do see text and a Sun XVR 100 graphics logo just fine.

Is the different card my issue?

Last edited by Stellaman1977; 10-12-2017 at 05:06 PM..
# 4  
Old 10-12-2017
Yes, I reckon the different graphics adapters is the issue. Sunblade 2500's come in different flavors. You have one with a 3D Labs card (aka Sun OEM XVR-600) and one with an ATI Radeon card (aka Sun OEM XVR-100).

Since they are both Sun OEM cards I would have thought that both drivers would be on your Solaris 9 installation media but I'm not sure (yet).

You could download the manufacturer's drivers but, in this case, I would rather download the Sun/Oracle version specifically for Solaris.

I'll need to check this out. Try searching this forum whilst I do that.

Perhaps another Solaris specialist will chime in too.

You could try swapping the card over from the other system but I'm not going to recommend you do that because you might generate a problem with your working system. "If it ain't broke, don't fix it."
This User Gave Thanks to hicksd8 For This Post:
Stellaman1977 (10-13-2017)
# 5  
Old 10-13-2017
I never used the installation media though I do have some. I only used the Operating Environment ROM when putting this together with the mirror drive.

What do I do now?
# 6  
Old 10-14-2017
Well, if you have the Solaris 9 install media you could do a new install on another disk to see if it installs the correct graphics driver and everything works.

I understand what you are trying to do but, physically mirroring a disk, is not really the way to achieve it. You could have used 'flarcreate' to create a flash archive of the whole system which would be easier to restore to the new box whilst coping with the different graphics adapter.

Ideally, we can find a download of Sun's XVR-100 driver and install that.

I may well ask around to see if anyone still has the driver(s) in distribution form.
This User Gave Thanks to hicksd8 For This Post:
Stellaman1977 (10-16-2017)
# 7  
Old 10-14-2017
Installing the Sun XVR-100 Graphics Accelerator Hardware and Software

This says the drivers for Solaris 8, 9 & 10 are on the Solaris 10 media which you can download.

Oracle Solaris 10 Downloads
This User Gave Thanks to hicksd8 For This Post:
Stellaman1977 (10-16-2017)

|
Thread Tools Search this Thread
Search this Thread:
Advanced Search

More UNIX and Linux Forum Topics You Might Find Helpful
Ufsrestore on SunBlade 2500 Stellaman1977 UNIX for Beginners Questions & Answers 22 01-29-2018 12:12 PM
Need in for a script that should check for errors in multiple log file (approx 2500) and should mail Pratik_CTS UNIX for Beginners Questions & Answers 2 04-26-2017 05:14 AM
Installing OpenBSD for Xorg on Sunblade 2500 harqobi22 BSD 2 08-20-2015 12:05 PM
StorageTek 2500 sprehodec Hardware 1 03-14-2013 10:53 AM
Now Over 2500 FB Fans for Our New Timeline Neo What is on Your Mind? 0 08-06-2012 10:51 AM
Boot Sunblade 1000 from disc Panther8644 Solaris 3 06-09-2012 06:20 AM
TTY Issue with Sunblade 150 Geekasaurus Solaris 5 02-21-2010 07:16 PM
PC133 for sunblade 100 vbe Solaris 2 09-15-2009 04:58 AM
Sunblade 1000 Kawakaze UNIX for Dummies Questions & Answers 3 03-16-2008 07:32 AM
SunBlade 2000 Arkayev Solaris 6 08-08-2007 08:13 PM
SB2000, 2500 server client convert howhowzz Filesystems, Disks and Memory 0 05-16-2006 08:12 PM
Anyone has problems with new Blade 2500???? facaizhu Solaris 4 01-11-2006 07:43 PM
AMD 2500 / 1G RAM / Soyo KT600 Ultra MB Neo Linux Benchmarks 5 01-17-2005 05:57 PM
regd.sunblade 100 solaris8in Solaris 3 12-15-2003 11:42 PM