Unix/Linux Go Back    


Solaris The Solaris Operating System, usually known simply as Solaris, is a Unix-based operating system introduced by Sun Microsystems. The Solaris OS is now owned by Oracle.

How do you make a superuser?

Solaris


Reply    
 
Thread Tools Search this Thread Display Modes
    #8  
Old Unix and Linux 09-16-2017   -   Original Discussion by kkeevv
jlliagre's Unix or Linux Image
jlliagre jlliagre is offline Forum Advisor  
ɹǝsn sıɹɐlos
 
Join Date: Dec 2007
Last Activity: 8 December 2017, 2:00 PM EST
Location: Outside Paris
Posts: 4,876
Thanks: 18
Thanked 637 Times in 556 Posts
The urtwn driver (port from BSD) might support the TPLINK device but it looks like it is difficult to find its source code or binaries on the Internet.
Sponsored Links
    #9  
Old Unix and Linux 09-17-2017   -   Original Discussion by kkeevv
hicksd8's Unix or Linux Image
hicksd8 hicksd8 is offline Forum Staff  
Moderator
 
Join Date: Feb 2012
Last Activity: 11 December 2017, 9:31 AM EST
Location: Devon, UK
Posts: 1,662
Thanks: 241
Thanked 406 Times in 344 Posts
You can boot your system into single-user mode by adding '-S' to your GRUB boot command (either on a temporary basis or on a permanent basis).

Solaris 10 (x86/x64) : How to boot into single user mode from the Grub boot loader

Search this forum or Google for:

'Solaris x86 boot single user' for more information.

I don't know why the 'rolemod' command was not found when you tried it. However, try again when in superuser (su) mode with a # prompt.
It should definitely (using Solaris 11) allow you to revert 'root' to a standard account so you can login to it directly. You might need to run


Code:
# passwd root

command to set/change the root password (again whilst superuser).
The Following User Says Thank You to hicksd8 For This Useful Post:
kkeevv (09-17-2017)
Sponsored Links
    #10  
Old Unix and Linux 09-17-2017   -   Original Discussion by kkeevv
jlliagre's Unix or Linux Image
jlliagre jlliagre is offline Forum Advisor  
ɹǝsn sıɹɐlos
 
Join Date: Dec 2007
Last Activity: 8 December 2017, 2:00 PM EST
Location: Outside Paris
Posts: 4,876
Thanks: 18
Thanked 637 Times in 556 Posts
Beware that with the current Solaris 11 release, GRUB2 is used instead of GRUB 0.97 (a.k.a. Legacy GRUB) so some of the information provided in the Solaris 10 link is obsolete and wouldn't apply.

See:

x86: Introducing GRUB 2 - Booting and Shutting Down Oracle Solaris 11.1 Systems and

How to Upgrade Your GRUB Legacy System to a Release That Supports GRUB 2 - Booting and Shutting Down Oracle(R) Solaris 11.3 Systems

The rolemod command was not found because it is located in /usr/sbin, so not in the path of a regular, not root user.
The Following 2 Users Say Thank You to jlliagre For This Useful Post:
hicksd8 (09-17-2017), kkeevv (09-17-2017)
    #11  
Old Unix and Linux 09-17-2017   -   Original Discussion by kkeevv
kkeevv's Unix or Linux Image
kkeevv kkeevv is offline
Banned
 
Join Date: Sep 2017
Last Activity: 19 September 2017, 8:50 AM EDT
Posts: 15
Thanks: 11
Thanked 0 Times in 0 Posts
Well i have only run a few commands, but apparently enough to screw something up. Solaris won't let me in to NETWORK settings now. When I try a lil window pops up asking for a 'user' or 'role'. If I put my username in it disappears but the settings don't come up. If I enter root it ask for a password.

I was looking at 'USER MANAGER' and it has my user listed as 'STAFF'. Not only can I not change the group or permissions for 'STAFF', I can't add a new user. It says I'm not authorized.

I think I'll delete the partition and re-install. Then I take a closer look at "rolemod" and single user boot.

Did re-install but it didn't improve much. I still can't change my user or create new user. I can get to network settings now but it won't klet me make changes. I can log on to the router but when I go to places/network/windows network it says "failed to retrieve share list from server". Looks like I'm going to have to learn 'ipadm' and 'dladm' commnads. Doesn't make since that I can't do this from the console.





Guess I'll start here Solaris 10 (x86/x64) : How to boot into single user mode from the Grub boot loader.

I tried the temp solution because /boot/grub didn't have a menu.lst file. My GBL didn't look like the one in the link. But I did find a line that mentioned multiboot and added a space and "-s" to the end of it and pressed F10. It booted to service maintenance something? and dropped me at a root# prompt. Not knowing what to do I entered "exit" CR. then it requested that I log on to console. I was still blocked from areas in the console.

I guess this is what I need. x86: Customizing the GRUB Configuration - Booting and Shutting Down Oracle Solaris 11.1 Systems
Quote:
The grub.cfg file contains most of the GRUB configuration. An additional, editable file named custom.cfg can be used if you want to add more complex constructs, for example, menu entries or other scripting, to the GRUB configuration. This file does not exist on the system by default. You must create the file, and it must reside in the same location as the grub.cfg and menu.conf files, which is in /pool-name/boot/grub/. GRUB processes the commands and any customizations that are in the custom.cfg file through the following code that is located at the end of the grub.cfg file: "


Code:
if [ -f  $prefix/custom.cfg ]; then source $prefix/custom.cfg; fi

But it doesn't help until I know how to use it. Going to see if I can change my user permissions.

Last edited by kkeevv; 09-18-2017 at 03:09 AM..
Sponsored Links
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Linux More UNIX and Linux Forum Topics You Might Find Helpful
Thread Thread Starter Forum Replies Last Post
Superuser pinklemon UNIX for Dummies Questions & Answers 2 08-04-2014 01:12 PM
to run sql as superuser Sreejith_VK Shell Programming and Scripting 4 04-28-2008 10:07 AM
SuperUser maconte UNIX for Dummies Questions & Answers 0 03-19-2007 02:36 PM
runing a script as superuser bcheaib UNIX for Dummies Questions & Answers 2 07-07-2004 02:24 AM



All times are GMT -4. The time now is 11:04 AM.