Compile PHP as an Apache module on Solaris


 
Thread Tools Search this Thread
Operating Systems Solaris Compile PHP as an Apache module on Solaris
# 1  
Old 11-30-2015
Compile PHP as an Apache module on Solaris

Hi,
I need to install php 5.5.30 as an apache (2.4.17) module on Solaris 10.

Please any help is wellcome.

Some aditional info:
Code:
/usr/sfw/bin/gcc -v
Reading specs from /usr/sfw/lib/gcc/sparc-sun-solaris2.10/3.4.3/specs

Code:
bash-3.2# g++ -v
Reading specs from /usr/sfw/lib/gcc/sparc-sun-solaris2.10/3.4.3/specs

Code:
bash-3.2# isainfo -b
64

LD_LIBRARY_PATH_64=/usr/lib/64
LD_LIBRARY_PATH=/usr/local/lib:/usr/lib:/usr/lib/sparcv9:/lib:/usr/ccs/bin
PATH=/usr/local/lib:/usr/sbin:/usr/bin:/usr/sfw/bin:/usr/lib/sparcv9:/usr/ccs/bin

I execute ./configure with a mínimum of arguments by now:
Code:
./configure --with-apxs2=/usr/local/apache2/bin/apxs

But gmake gives me the next error:
Code:
gmake
ld: fatal: file main/: unknown file type
ld: fatal: file processing errors. No output written to .libs/libphp5.so
collect2: ld returned 1 exit status
gmake: *** [libphp5.la] Error 1


Any idea about how can be solved this error?
Thxs in advance.

Last edited by Franklin52; 11-30-2015 at 08:58 AM.. Reason: Please use code tags
Login or Register to Ask a Question

Previous Thread | Next Thread

10 More Discussions You Might Find Interesting

1. Shell Programming and Scripting

Solaris install php as an apache module

Hi, I need to install php 5.5.30 as an apache (2.4.17) module on Solaris 10. Please any help is wellcome. Some aditional info: /usr/sfw/bin/gcc -v Reading specs from /usr/sfw/lib/gcc/sparc-sun-solaris2.10/3.4.3/specs bash-3.2# g++ -v Reading specs from... (1 Reply)
Discussion started by: lbslbs
1 Replies

2. Web Development

Apache module development on apache 2.2

Hi, I'm new to developing modules for Apache. I understand the basics now and can develop something simple which allows a 'GET' request to happen, but what I want to do is actually 'POST' information to my site. I know the basic POST Request works and I can see that it is post by looking at... (2 Replies)
Discussion started by: fishman2001
2 Replies

3. Ubuntu

Compile smbfs module in kernel version 3.10 running Ubuntu 12.04 LTS

Is there any way to compile smbfs module in kernel 3.10 running Ubuntu 12.04 LTS. I did a 'make menuconfig' and it shows cifs. I found out online that smbfs is deprecated and replaced by cifs. I have an old system with kernel version 2.4 which only has smbfs (no cifs). Is it possible to compile... (1 Reply)
Discussion started by: Monil
1 Replies

4. Solaris

Compile PHP 5.3.6 with MySql on Sun Blade 1500 Solaris 10

Hello, I'm trying to compile PHP 5.3.6 with Apache2 and MySql 5.5.12. I hit a problem that I can't seem to resolve by myself and I could not find a solution on the web. It looks like Apache and MySql installed ok, I can start/stop them with no problem. When I try to compile PHP the... (4 Replies)
Discussion started by: pn8830
4 Replies

5. Linux

Howto compile my own module into the kernel

Hi there, I'm currently writing a program/module which makes use of the Linux Security Modules (LSM), which provide hooks for some security . The bad thing about it is: The function to set the hook to the LSM is not exported. That means, I can't just write a loadable kernel module, but have to... (3 Replies)
Discussion started by: disaster
3 Replies

6. Solaris

Compile php with curl on solaris 10 question

I have curl compiled into /usr/local. I needed to install another version into /usr/local/curl-7.19.5 and compile php using that directory. I believe I had done that but an ldd run against php shows it is using /usr/local/lib. I have my configure script below showing how it was built and php -i... (1 Reply)
Discussion started by: csgonan
1 Replies

7. Solaris

PHP 5.3 compile on Solaris 10 : make distclean :: fatal error

I'm trying to install PHP 5.3 on Solaris 10 . I'm using etc/apache2 and installed mysql 5.1.39. When I tried to compile PHP 5.3, with the following configure text, ./configure --with-mysql=/usr/local/mysql \ --with-mysqli=/usr/local/mysql/bin/mysql_config --with-zlib-dir=/usr/local \... (21 Replies)
Discussion started by: ppa108
21 Replies

8. Solaris

Errors trying to compile PHP for use with MySQL on Solaris 10

have installed and am using the GNU based tools from the Sunfreeware site to compile PHP. I already have Apache, MySQL, and Oracle compiled and working properly. Below is my configure string for my PHP build: ./configure --prefix=/usr/local/php5 \... (2 Replies)
Discussion started by: sunsysadm2003
2 Replies

9. UNIX for Dummies Questions & Answers

get error while compiling apache with php module

hi, i'm compiling apache with php module after i finish compile mysql-4.0.0-alpha. i do it as the follow steps after untar'ed them in the same directory, 1) cd apache_1.3.22 ./configure 2) cd php-4.0.6 ./configure --with-mysql=/usr/local/mysql \ --with-apache=../apache_1.3.22 \... (2 Replies)
Discussion started by: jApHEth
2 Replies

10. UNIX for Dummies Questions & Answers

apache, php on solaris

Hi, our spark 5, os 2.8, solaris 8, came with Apache. But this Apache is some kind of bastardized wrapper that has no configuration files, nothing. So, I got the real version of Apache that is configurable. That is so I can configure it with PHP-4. I installed this new Apache version but now I... (6 Replies)
Discussion started by: softarch
6 Replies
Login or Register to Ask a Question

Featured Tech Videos